UVI still doesn't show in Dorico 3.0.10

I am also having an issue with UVI not available. I read the post:
https://www.steinberg.net/forums/viewtopic.php?f=246&t=169975&p=908132&hilit=UVI#p908132
and deleted the VSTAudioEngine 3 folder in /Users/your-username/Library/Preferences and restarted Dorico following Daniel’s suggestion. It worked for the original poster, but not for me. UVI still does not appear on the list of available libraries. In fact, after deleting VSTAudioEngine 3 and restarting Dorico, all of the VSL and VEPro items disappear as well. I saved off the original VSTAudioEngine 3 and copied it back into preferences to re-establish the VSL entries, at least. My system is running MacOS Mojave 10.14.6.

Any suggestions?
Also, 3.0 is a great release!

Thank you in advance,

Jonathan

Could you please do Help > Create Diagnostic Report ? That creates a zip file on your desktop. Please attach here.

Hi Ulf,

I recreated the steps to delete the VSTAudioEngine 3 preference file and relaunched Dorico. This time, UVIWorkstationVST appears but all of the Vienna Symphonic Library listings do not. As stated before I am using Dorico 3.0.10 and Mojave 10.14.6.

I attach two files:

OldDorico Diagnostics.zip has the original VSTAudioEngine3 preference file (No UVI but many VSL and VEPro listings).
NewDorico Diagnostics.zip was created after deleting the original preference file. (UVI but no VSL, VEPro)

Thank you, Ulf.

Jonathan
NewDorico Diagnostics.zip (335 KB)
OldDorico Diagnostics.zip (411 KB)

In regards to UVIWorkstation, before it was not on the whitelist and therefore did not appear.
Now it is on the whitelist (you must have put it there yourself) and so it does appear.

The VSL plugs however get all blacklisted (for reasons I don’t know) and therefore don’t appear anymore.
Try again deleting the content of the folder /Users//Library/Preferences/VSTAudioEngine3 except for the vstwhitelist.txt
then start Dorico again and let it scan for plug-ins. Same result?

Same result, Ulf. UVI is present. The VSL plugs are not. And, yes, UVI was put on the whitelist during version 1 of Dorico, I believe.

Yes, but in the old diagnostic file you posted, UVI was not on the whitelist. Then in the new diagnostics it was again, so somewhere in between you must have edited the whitelist somehow.

In regards to the VSL plugs: Please open a Terminal window (/Applications/Utilities/Terminal.app) and type following command:

/Applications/Dorico\ 3.app/Contents/Applications/VSTAudioEngine3.app/Contents/Components/vstscanner -p /Library/Audio/Plug-ins/VST3/Vienna\ Ensemble\ Pro.vst3

What is the output then?

Ulf,

I just tried this on VE Pro. The main program is an alias. I copied the aliased file to the same location and it now shows up in Dorico 3.0.10. I will do the same for the rest of my plugins.

Looks like this is the issue with Dorico 3.0.10 and the VSL VST3 plugins.

Something must have changed in the vst3scanner that it can’t follow the symlinks anymore. Will ask the developer of the scanner, he must have had good reasons.

I have updated all my plugins. My vst3blacklist is now empty.

Not sure what the correct protocol is for this but we now understand the issue. I’m sure you all can sort out the correct way of doing things.

Thanks for the tip.

My apologies, Ulf. Reverse the names of the diagnostic files, I mislabeled them. In other words, new is old and vice versa.

I ran the terminal command but have the same result: no VSL Plugs.

I received this message after submitting the terminal command:

2019-10-09 13:57:17.746 vstscanner[2823:191990] /Library/Audio/Plug-ins/VST3/Vienna Ensemble Pro.vst3: the main executable or Info.plist must be a regular file (no symlinks, etc.)

Jonathan, I think they are labelled right, because UVI must be on your whitelist now, otherwise it would not turn up. But anyway, it is there and good is.

Regarding the VSL plugs: It’s the same as what dbudde wrote. Under /Library/Audio/Plug-ins/VST3 there are only symbolic links to the VSL plug-ins. The real binaries of the VSL plugs reside somewhere else. If you do the same as dbudde, namely copy the plugs over to /Library/Audio/Plug-ins/VST3 it will work again.

As I already wrote, in the 3.0.10 update the vst3scanner changed and unlike before, can now not follow symbolic links anymore. I will ask our scanner developer, he must have had good reasons to make the change.

I keep having this problem and can’t figure out where my error lies. I hope Dave or somebody will be kind enough to help me understand how to accomplish this.

In an attempt to troubleshoot problems I’ve described in another thread, I’ve created an external SSD with bootable clean installations of OS X 10.12, 10.13, and 10.14 (latest versions in every case). I’ve tried my best to do as Dave did, using information from the 3 threads which mention this issue, but my VSL plugs keep ending up on the VST3 blacklist (even after trashing the VST3 Audio Engine folder and restarting Dorico). I must be missing some essential part of the process and unfortunately I think I need a step-by-step “for dummies” explanation here.

I’ve tried typing this in Terminal as Ulf suggested:

But Terminal returns this:

vstscanner: illegal usage
usage: vstscanner -p pluginPath

(I’ve also tried typing the path as “Plug-Ins” in case it’s case sensitive; same result.)

“Show Package Contents” on the .vst3 plugin located at Library/Audio/Plug-Ins/VST3 reveals a subfolder which contains an alias pointing to a Unix Executable file housed within the .vslplugin bundle located at Library/Application Support/VSL/Vienna Ensemble Pro … I’ve tried moving the .vslplugin to the Plug-Ins folder which contains the original .vst3 symbolic link, but Dorico 3.0.1 still puts everything on the VST3blacklist.

  1. Should I only move the Unix Executable instead of the entire .vslplugin?
  2. Should I delete the original .vst3 containing the symbolic link from the Plug-Ins/VST3 folder, or should it and the .vslplugin both be included there?
  3. Do I need to delete the .vslplugin from the Vienna Ensemble Pro folder, or can I keep it there as a backup?
  4. Instead of messing with this, would it be better to install 3.0, run it so that plug-ins are scanned, and then update to 3.0.1 … or will doing so just result in needing to move the plugs anyway?

I’m way out of my element with this stuff. Any effort to help me understand is greatly appreciated! Thanks in advance.

Here are the steps to fix the alias problem with VSL plugins.

Locate a finder window to /Library/Audio/Plug-Ins/VST3
Right click on a VST3 file and select Show Package Contents
Go to the folder named MacOS (this contains an alias pointer to a unix executable)
Right click that file and select Show Original (This will take you to the folder where the original file is)
Select the file and Copy it to the clipboard. (Don’t move it. Copy it)
Return to the folder where the alias file is (you can click the back button in the upper left corner off the Finder window to do this.)
Edit>Paste and select replace file. This will replace the alias with a copy of the original.

Do the above for each plugin that has an aliased file. Then delete VSTAudioEngine3 local preferences folder, reboot your machine, and launch Dorico. This will rebuild your blacklist (which should now not contain any VST3 that you fixed as above).

Thanks very much Dave! Very clear instructions, even for the tech-challenged like me. :smiley:

I greatly appreciate your help. I’ll get this done as soon as I’m back in the studio later tonight.