VDL article on Tapspace on how to make rack combo

Hello,

I went through the Tapspace article on how to make a VDL rack combo in Dorico, but I can not get all of the instruments on the rack combo to sound. I made sure to turn on my MIDI keyboard before starting Dorico. I can only get the snare drum to sound. I was curious if someone could help me out. I’ve attached some screenshots. Thanks.

Article I am referencing: Virtual Drumline Tip: Integrating VDL with Dorico Notation Software - Tapspace News

Screenshots:

Are all the instruments set to go to channel 1, because in the image you have Toms 1-5 and the clash cymbal routed to their own channels and don’t have an expression map defined. You might just need to expand all the instruments in Play mode and set them to use Channel 1?

Also, there is a new Facebook group where some users are setting up a full VDL template - you might want to join it here Facebook Groups as it may save you time in the end.

John

Thanks for the response. So I thought another problem arose from this, in that the MIDI notes were all shifted up a third (example, the sound that was on C4 was being sounded when playing E4). On a side note, it looks like the VDL documentation calls “C4,” “C3,” but that is not the issue here.

So another user pointed out that in preferences, under “note input and editing,” I needed to change the “input onto kit or grid” from “use staff position” to “use percussion map.” That fixed the MIDI input- all of the notes are now being written and sounding correctly when I play it on my MIDI keyboard in “write” mode.

In terms of the routing, in the article, the screenshots they showed just showed port 1 and channel 1 being taken up by the “rack combo” instrument, it actually didn’t show anything in the other slots and channels, so I wasn’t sure what to do. For the expression map, it showed in the article to keep it as “default.”

I attached screenshots just to show what I did based off of your advice. In the “endpoint” screenshot, this is what it looked like after I changed all of the instruments to channel 1, which is shown in the “channel” screenshot. Those other instruments are now gone, and this is what the screenshot in the article looked like. Thanks again!

Yes, the input method will make a difference if you are using a MIDI keyboard for note input.
Now that you have them all mapped to Channel 1 you of course won’t see any other instruments in the Endpoint setup dialog - and the expression map isn’t being used, so ‘default’ is fine.

Glad you found a solution!