Velocity data not transferred to BBCSO (SOLVED)

I apologize for asking a question with a potentially huge number of answers, but I’m a little at a loss. I’ve spent hours writing expression maps for BBCSO strings, got patches switching properly, things seem good to go. Import it into a score, and the dynamics are not being played properly.

I DO remember seeing the faders being controlled during playback at an earlier stage of my working, but now it’s gone and they are stuck on one dynamic. Any suggestions on first steps to figure this out?

With BBCSO, short notes such as staccato use velocity for dynamic. All others use CC1, so you’ll need to ensure that this is correctly in the expression map.

This is actually pretty common practice in most commercial sample libraries (at least the ones I’ve used) as I’ve no doubt you know quite well Paul. :wink:

Yes, the HSO sounds use this convention too. The reason is that staccato and other ‘shorts’ are usually one-shot samples that aren’t looped. They have no sustain so there’s no need to control the dynamic over the course of the note, and so they usually respond to note velocity. However for sustaining instruments you want to be able to control the dynamic over long notes, and you can’t do that with note velocity so you have to use a CC instead. Many libraries use a slightly different mechanism of using velocity and a CC. Which Dorico can support using the Secondary Dynamic settings in the expression map. This isn’t a panacea though because now you’ve got dynamic controlled by two separate quantities it can be difficult to get a good balance between articulations and between dynamic levels. In my experience you can sometimes get the best results by limiting the range of the secondary dynamic (which is now possible in the Expression map editor), eg to the range 64-127.

Thank you Paul! And thank you for 3.5! And thank you for the grace period!

Now I need to fix all of this erroneous data hahahaha. I input all this stuff without an awareness of how it’s encoded into the play lanes. Now I’ll take a look and see if I can automate it better, or just draw it in. Solved the problem, thank you.