Velocity issues using Play 4

I’m experiencing a curious phenomenon and wondered if any of you EW Play users can replicate it.

If I create a midi track for a velocity sensitive instrument ( for example a Stormdrum 2 instrument) and programme in a series of notes at a velocity of 127 and then play it back - then hit the same note hard on my keyboard, it becomes clear that the playback is not triggering at full velocity.

As a guess, I would say that a velocity played back from a midi track programmed at 127 is triggering the relevant sample layer for around 50 - 70 in Play (4 v 12). This behaviour is not replicated with Kontakt. I have replicated it so far using Stormdrum 2, HW Strings & HW Brass.

Anyone noticed this - or have any theories? (I’m using v 7.06 on a 64bit PC in Windows 7).



Try comparing the programmed notes with some you record with your keyboard. Make sure to do a round-robin reset at the start of each one so the performance is the same as you play them back.

I haven’t run into a velocity problem with Play 4 yet, though. What patches are you using from SD2 (or HS /HB, whatever)?

I didn’t notice I had a problem until I tried using the Mahler Hammer from EWQLSO today and realised I wasn’t triggering the high velocity sample. I then tried it with the Godzilla hits, same result. Then when I tried HW Strings & Brass I started wondering how long I’d not been getting high velocity when I play back to Play.

I can try recording in the same thing, but 127 is surely 127 - however it gets put there. Similarly with the round robins - though the difference between the two is huge enough (i.e. different velocity layers) that differences between round robins won’t make much difference.

I’d appreciate it if you could try the simple compare a few programmed 127 notes with hitting the same notes on your keyboard test so I can try to work out if it’s just me or a compatibility/bug issue? If anyone is on an earlier version of Play that doesn’t display this behaviour, that would be useful to know too!



I’ll go ahead and try out Play 3 and 4 and compare.

A weird thing with Play 4 is that it will crash immediately when I try to load any tempo-synchronized patch, but not so with 3. I’m like the only person on the internet who has this problem, so don’t be surprised if the velocity issue is your special bug!

It will be a real shame if this issue ( for me at least) relates to Play 4 as I’ve found it to be much more hassle free than it’s predecessor in terms of patch loading. I’ve yet to test whether legato playback is a little more reliable at higher latencies (my previous ‘I’m the only one in the world’ issue)

Yeah, I’m not having any issues with velocity here with 3 or 4. Sorry, man.

Do you have any velocity scaling applied somewhere in Play or Cubase? Something in the global logical editor maybe?

I just checked the tracker and didn’t see it on there, so if it’s not a modifier you’ve got hiding somewhere, it might be a new issue. I think you should go to soundsonline tech support for this one.

If that were the case (Cubase settings), then surely it would affect Kontakt too - but it doesn’t. In play, the velocity curve is the only thing I can see which might affect this issue, and they all appear to go up to 127 as normal.

Just to be clear, when you say you haven’t any issues, do you mean you just tried my test or that you haven’t noticed any issues while working?

I played with a couple HB and HS velocity-sensitive ‘shorts’ patches as well as some of the ‘best of SD1’ and the congas in SD2 using both Play 3 and 4. I could input notes in the key editor and record / play from my keyboard, and max velocity could be achieved as expected when played back.

Should I try the test another way?

OK, now I feel like an utter banana!

If only I’d listened to your first post! It turns out the solution is a little silly.

The cause was that I had inadvertently activated 3 zones on my keyboard, so every time I hit a key it was playing 3 notes. So I tried your ‘play it in on the keyboard and compare’ suggestion, and the playback was indeed louder, but I couldn’t see any difference between the programmed and played in notes. That is, until I looked in the list view and saw there were 3 notes piled on top of each other.

This is where your comment about round robins comes in. I can only guess that somehow when receiving 3 simultaneous notes, Play stacks the round robins, somewhat like the same option in Storm Choir and that produces what sounds like a higher velocity layer. Once I stripped out the extra notes and reset the zones, everything was back to normal.

So, there are two bright sides - firstly, my problem has gone away and secondly, I now know how to stack round robins in play if I need a thicker louder sound!

Thanks so much for your help!



Good that it was an easy PEBCAK fix, haha.

Let’s hope it’s that easy next time, you never know with these things…