VEP ASIO spikes on empty session


Here are my reproduction steps:

-Open a New Blank Project in Cubase 9

-Open Vienna Ensemble Pro Server Interface Plugin in Cubase (VST3)

-ASIO Usages jumps to 75% sustained and realtime peak is red zone.

-Disable VEP and ASIO usage returns to 0.

This is without any samples loaded or the server running. The interface plugin is not connected to anything but still is causing Cubase to perform this way. Other plugins behave fine.

ASIO Guard is disabled, and changing these settings has no effect. RME HDSPe AIO is set to 512 buffer, 48KHz. LatencyMon shows no issues with DPC latency or driver conflicts.

Cubase 9.0.30

VEP 6.0.16419 (September 27)

Thanks for your help!

works fine in Reaper

Does the VEP server have to be run before opening the Cub project? Or even before running Cubase perhaps? I have been doing the latter to be on the safe side.

I would love to know if anyone solves this mystery. I’ve spent hours trying to figure out why my VE pro project makes cubase spike. Then I completely unlink one of my Ve pro connections. Then I enable one of my kontakt instances. And suddenly my percentage falls from about 850% back to 150%.
This is the strangest workaround I have ever had to do. I also leave my computer on with Ve pro running in fear that I may not be able to pull my session up without the cpu freaking out.

Anyway, at least it works but please chime in if I’m not the only one experiencing this evil behavior from Ve pro.


Platform? OS? VEP version?

I had this issue and managed to fix it by installing an earlier version of VEP. However, I re-installed the newest version and it worked , unfortunately I’m not sure why.

FWIW My old specs were this:

Windows 10
Core i7 3930k
Corsair XMS3 64GB (8x8GB)
Nvidia GT 640

Moved over to a new PC on an ASUS X99 Deluxe II, clean install of windows and now it works with no spikes. Same audio card, graphics, only thing that changed was the mobo and cpu. Hmm… Well my old X79 motherboard is completely dead, so I guess we will never know.