Vertical gap settings doesn't work

Would anyone be able to spot what I am doing wrong in vertical gap settings. You can see Dorico decided to put several systems onto one page but some staves bumped into each other. Looks like the ideal gap setting isn’t followed at all.

I can of course manually adjust vertical spaces but I feel it shouldn’t be required with correct settings. Any idea?


What % fullness is the frame fullness indicator (bottom right of the page) showing? I suspect it could be more than 100% and red?

If so, try reducing these values: a 6 space staff-to-staff gap is quite large in a tightly-spaced score. Try more like 4 to 5, and also something like 6 for the other gaps between bracketed groups. Then rely on the minimum gaps left between staves/systems with content and vertical justification to spread staves out over the rest of the page.

(As explained on this page, “ideal gaps” are more like minimum gaps really: Dorico will space staves out wider than this if there’s space available on the page, but will never, except in overfull scenarios, let staves get closer together than this. Because Dorico does collision avoidance automatically anyway, so very high/lower notes and dynamics etc will create extra vertical space anyway, you don’t need to bake in room for those things here.)

Thank you for the input. Yes, these pages are overloaded (from 110% to 130%). But I am curious why Dorico chooses to fit two or more systems onto one single page when doing so will overload the page.

I understand your point to lower the gap value to have Dorico use less space for each stave and make room for the collissions. But even with the high value, a single system should still be way below 100% of a frame. So, I needed a bit more space for each stave and also hope Dorico will use it as a threshold not to fit more systems into one frame than it can handle. Am I understanding the mechanism correctly?

I get this behavior whenever I turn on “hide empty staves,” for large ensemble with different numbers of staves displayed each system even with default values for gaps. I have been manually adding frame breaks to get around this. That’s why I ask, believing dorico is designed to require no manual frame breaks to layout without collisions. Or if I have another wrong setting.

This has been explained many times.