Vertical Zoom excluding Folders - possible?

Hi all -

I like to use folders to keep things in order, but I don’t like the folders to take up any more screen space than necessary.

I often use Alt+S to enlarge one or more tracks … however, if these tracks are in different folders it also enlarges one of the folder tracks which is a waste of screen space. Again, when I want to zoom vertically the folder tracks are also zoomed - which is pretty pointless most (if not all) of the time.

I want my folders to stay at 1 row height regardless of the zoom setting of the tracks. I can use the PLE to select only non folder tracks but all the subsequent zoom variations (zoom to 1 track etc.) seem to apply to all tracks regardless.

Is there any way I can keep my folder tracks locked to one row, or set up a macro that will exclude folders from vertical zoom operations?

Cheers,
dbh

Hi,

What version of Cubase do you use? I cannot reproduce it here (Cubase 8.5.15). Only the selected track is enlarged. Not the parrent folder.

Hi Martin,

I’m on 8.5.10 Pro…

What were you doing to reproduce? The Alt S problem only occurs is the two tracks selected to enlarge are in different folders. I have a macro setup to hide all tracks except selected (one of the visibility agents) and then enlarge the two selected tracks using the Alt + S Zoom to selection function.

PLE -
Channel and Track Visilbity - Agents: Show only selected channels/tracks
Edit - Select all on tracks
Zoom - Zoom to selection

This works fine when there are no folders involved.

For example I might have violins in a Strings folder and flutes in a Winds folder but want to select Flutes and Violins to work with … Ideally all other tracks would be hidden using the “only selected” visibility agent and then using the zoom to selection the two tracks would be enlarged to fit the screen.

In reality whilst the visilbity agent does indeed hide anything that isn’t selected it still shows the folder tracks of the two selected tracks. When the Alt + S zoom to selection is applied to the selected tracks the folder of the lower track also gets zoomed…

Does that make sense?

Cheers,
dbh

Haven’t tried your macro but it seems like instead of using the Select All Tracks function, you need a PLE script that selects all tracks EXCEPT folder tracks.

Also, just tried the ‘Zoom Tracks Exclusive’ key command and it works perfectly with multiple tracks in different folders. The selected tracks are zoomed but not the folders.

Hi,

I did it manually.

Could you send a screenshot, or describe your PLE?

Thanks for the help guys!

J-S-Q: Zoom exclusive worked perfectly, and if I follow it with the Zoom to selection it works even better (as it zooms to fit the screen but doesn’t affect folders). Good stuff!

It seemed in my earlier experiments with using PLE to select all non folder tracks that the macro worked fine but as soon as you select a standard Zoom setting it applies it to all tracks regardless rather than just selected tracks. At the time I was looking to set two zoom Macros - one that had all non-folder tracks zoomed to 4 rows and the other to have a single row.

Cheers,
dbh

Hi, I recently came across the same issue. To set all folders to one line and all other tracks to say, 4 lines, I use this macro…

(i) Zoom - Zoom Tracks 1 Row
(ii) PLE - Create a filter to select non-Folder tracks
(iii) Zoom - Zoom In Tracks
(iv) Zoom - Zoom In Tracks
(v) Zoom - Zoom In Tracks
(vi) Edit - Select None

Not very slick, but it works!

HTH, Ian

Thanks Ian - very useful.

You can tie yourself in knots with these things - I should have asked earlier…