Very difficult driver problem - SOLVED


Has anyone had a problem anything like this? Any help or ideas would be greatly appreciated.

I have the UR22 interface. It was working prior to unplugging it to take my computer somewhere. Then it would not work after I plugged it back in. Figured I may have to reinstall the driver, but at the time I gave up and used the standard windows sound driver/hardware for several months. No other sound hardware has been added since, or other system changes made.

Now I need to use the UR22 again, but I am stuck. Cannot install. Cannot uninstall. No method of uninstall will work.

Windows 7 Ultimate with driver version 1.9.6

Plugged directly into USB3 hub. System makes connect/disconnect sound when plugging it it or unplugging. But the light flashes on the interface and doesn’t stay lit. So not recognized?

Downloaded newest driver today hoping that would help.

Cannot uninstall driver under any circumstances. Not with installshield through Windows control panel, not through device manager either. And not even by running the downloaded setup.exe. In every case, there is an error of some kind.

Device manager only shows the driver for this as ksthunk.sys. The actual driver files are not there

Searching through regedit I see that the proper driver files are referenced here and there. Located in ProgramFiles32/Yamaha/Yamaha Steinberg USB Driver

Tried just installing new driver version. But even when it says it did, it does not work.

No matter what I do, device manager says “There are no drivers installed for this device”

So basically I am stuck - cannot install or uninstall. And now - Windows Programs and features shows there are two versions of the driver installed.

Thanks for any suggestions or solutions.

As an update, while I was waiting for approval of my post…

I went through my registry and removed everything I could that referenced the UR22. Some entries - whole sections said they could not be removed.

After this, Windows showed that it was no longer installed.

I restarted, then reinstalled the driver.

But same results. When I view it in Device Manager, it says No drivers are installed for this device. But when I look at driver details, now there are some things showing, but nothing related to the UR22.

One change - the driver will say it installed correctly, and it will uninstall now.

But the unit led only flashes. I tried using different USB plugs. Shake the cable, etc. Nothing helps.

Also, the computer will not shut down if the unit is connected. And it will not boot either.

I also uninstalled and reinstalled the driver for my VIA USB3 card. My motherboard does not have USB3 built in. But it did work fine last summer for a while.

This is a USB 2 unit. Are you trying to connect it through USB 3? That may be your problem.

UR824 is also a USB2 unit. I have mine now and always have on a PCIe USB3.0 card. No issues-well except when I did have them two years ago when this thread was started and moved. The problem seems to be with certain MOBO’s, USB controllers, and the interface drivers. I guess we will never know since Yamaha decides not to respond…

I have no issues now but I watch this thread daily as I keep hoping they will at some point deal with the problem. Not looking like they care…:frowning:

Hmm. USB2? Interesting… But it did work before, though the same USB3 card. My computer does have problems with some of its original USB2 hubs on the front of the case. Physical damage to them. Maybe I can check and see if they show as a yellow alert flag. Maybe there can be cross-talk between USB systems if one is damaged…

Eliminate one thing at a time and eventually find the cause… Whew!

Actually, it could be worse. My last card was an M-Audio. Worked great until I made the obvious bonehead I-am-fully-to-blame mistake of plugging in a microphone. :unamused: Phantom powered mic, and Phantom power was active at the time. FRIED the unit dead. Found out M-Audio was not doing any kind of warranty or replacement for this, which is a clear case of poor design. Evidently in some circumstances if the mic is not perfectly plugged in, there is an open circuit or a short circuit somewhere, frying the unit. Fried even the main outputs.

So… Did some research, not wanting to get burned again. Decided UR22 was the next great thing. It was, until this cryptogenic problem occurred…

Got it fixed.

Plugged it into the onboard USB2 port. Unit was recognized, and all is working correctly now.

I don’t know why this should matter, but it works, so I won’t question it. I hope if someone else has a similar problem that this can help them, too.


For me it is the other way around :wink:
My UR824 used to work fine on a USB2.0… till last december a new USB driver (V 1.9.9) was released/installed. From that moment problems showed up like no sound at first startup, UR software/firmware versions could not be shown. After using a USB3.0 port instead of the 2.0 port this problem vanished and all worked fine. This morning I downgraded the USB driver to V1.7.3 (still available at website) and found both USB2.0 and USB3.0 working excellent.
Steinberg Support showed a lack op support : None!

i have a zoom g5n multieffects pedal that can work directly into a computer usb and then into a daw without a seperate interface…i have similar problems and would like to know how you downgraded your driver?

He is referring to the driver specifically for the UR824. It wouldn’t apply for the Zoom. You could check the Zoom website for old versions of the drivers it uses.


I have a same problem with ur 824. i bought 6 months ago, at the beginning it work good in these days it disconnected to the computer advice say:(the device that use yamaha driver seem to be detached from usb) after couple of minutes it work again. In the interface panel it say “status stopped” today i saw this topic and in the evening i will try to use usb 2 like someone said. i hope to solve the issue