VERY! large project

I’m working an a very large project for voices and orchestra. An operatic act consisting of one single flow of 1332 bars.
I’ve put the wind parts in and I was starting to cast the condensed score, but Dorico is getting too slow.
Every single condensing change or a note change or an articulation takes 40 seconds.
And I didn’t put in strings, voices and percussion yet.
Is this a normal behavior? Please check the attached project. (The file was larger than 4 MB, so I had to shorten it a little bit). (3.0 MB)

Is this beyond Dorico capabilities?
I know I could split the flow, but printing and putting together the single pieces can be very tedious and source of errors.
Any suggestion will be very appreciated.
Thank you very much in advance

It’s not beyond Dorico’s capabilities, but you’ll definitely want to edit the notes and articulations in “normal” (which is to say, “not condensed”) mode, and only turn on condensing to do the final graphical edits/layout.

I just tested your score on my m1 mac mini, and it did take a while to load, but I was able to insert a random condensing change and have it only take about 3 seconds. Note changes were instantaneous. So this could partly be that you are pushing your hardware to the absolute limit.

1 Like

What are your computer’s specs?

Dear Romanos401,
thank you very much. Really very kind of you!
I just find a bit strange that my hardware could be pushed to the limit.
I have a Windows system with an Intel Core i7 4792K CPU, 32 GB RAM, and NVidia GeForce GTX 970. Not exactly a wreck!
Thank you once again.

Do you know how many cores it has?

As Dan says, the number of cores can be critical.

Here are two gifs. One is showing an octave manipulation with condensing off, and the other is the addition of a condensing change while condensing is one (it is almost immediate).

I have a Ryzen processor with 8 cores. It could be that your computer has less than 4 cores; or that something else, a MIDI loop or some other process, is tying things down.



Note manipulation:

Note manipulation

1 Like

Indeed, it’s certainly not a slow CPU, and it was a high-end processor when it was released in 2014, but that’s quite a long time ago now.

There is a performance improvement for condensed scores coming in the Dorico 4.0.10 maintenance release, which will be released this week. I’m running that build, and on my own Mac (which is an M1 Pro, so a very fast computer with a CPU released just a couple of months ago rather than 8 years ago), I can make edits to the music in your project reasonably easily. Adding an articulation takes around a quarter of a second; repitching a note or a bar full of notes roughly the same; adding a condensing change can take a while (creating a new one at bar 204 took around 8 seconds). But it’s certainly possible to get better performance than you’re currently experiencing, I think.

1 Like

Intel i7 has 8 cores.

1 Like

That score is nowhere close to the size where editing should be an issue with that machine. Perhaps the update will help, but I can’t help thinking there is something else although I am no technician …

1 Like

Thank you Claude,
if nothing is wrong in my project, I can’t figure out what’s going wrong in my computer.

1 Like

Thank you, Daniel.

Double check that there is no “midi loop” going on as @claude_g_lapalme suggests; this has caused major slow downs for a few people recently. If you search “midi loop” a few threads should pop up including Daniel’s advice.

I would advise not even THINKING about condensing until all note entry is done.

1 Like

Yes I know.
The problem is that casting-off must be made in condensing mode of course.
But every single condensing change takes almost one minute.
Impossible to work like this.
I’m stuck.

Why do you need to cast off while you’re entering notes?

I’m not entering notes, or at most just fixing few mistakes here and there.
I just want to cast-off the project and it’s impossible at this speed.

Hi Stefano,
I can easily edit the score without any delay. Adding new notes takes about quarter of a second, so not really an issue. I did turn off Condesning. My iMac has only 8 GB ram so I was surprised that it wasn’t a problem after reading your computer specs.

Sorry - I took the above to mean you hadn’t finished note entry. Have you definitely not got a midi loop or something in there? Unplug keyboards just in case?

It is a quad-core machine, unfortunately…

Unplugged everything. Nope

1 Like