Video Playback not smooth (SOLVED!)

Hi all. This is a post to see whether anyone else has this problem, or if it’s specific to my system.
I’ve found video playback in Cubase 10 to be less than ideal. It’s most noticable with things like passing cars - their movement is jerky as if certain frames are not being played back. I’ve tried all the usual suspects - trashing preferences, latest graphics card drivers (Radeon R7 200 series), re-encoding the video in Cubase-friendly format (ProRes, HD264, etc…) nothing solves the issue. Video plays back fine in Quicktime, VLC, Windows Media Player. I’ve checked burned-in timecode for a 1hr 33min film and it matches Cubase’s timecode exactly, so it looks like a playback issue.

Also - vids play back fine in Cubase 8.0.40 (thats with the Quicktime video engine), but with Cubase 9 onwards I hit this problem.
Anyone else have this issue?

Is it every video, or just this one…? If there’s another one, smaller, that you can post up somewhere for others to download and try on their systems, might give you a clue…

Win10 or Win7…?

FWIW - I’ve had no similar concern with videos I’ve had playing back in Cubase (converted to H.264 MOV container format first, using AudioSpot MediaER Toolkit https://audiospot.audio/audiospot-creativetools ). But they’ve generally been under 5mins duration - not that that should make any difference.

Good luck.!
Bob


(PS:- there is another tool, a video-player VST plugin that might help; you can download a free demo here http://vidplayvst.com/index.htm )

I’ve yet to find a video file that doesn’t exhibit this behaviour.

Win8.1

Vids that I’ve converted have used H.264 MOV container format - using MediaER Toolkit (a great bit of kit!).
I’ve tried vidplayvst, but to be honest it’s a bit clunky for work purposes. Thanks for the sugestions.

Here’s something random I grabbed off the net that plays fine in everything except my copy of Cubase 9/10 -
Cars Passing.zip (497 KB)

Well, you’re right of course - the file plays smooth, no visual ‘stuttering’ on the passing car, in VLC and Windows MediaPlayer. Not so inside Cubase (or, to a lesser degree in Vegas Movie Studio NLE).

We can assume its been like this with Cubase’s video player for ages. Clearly I’ve just not been critical (bothered.?) enough in my previous efforts to see it (concentrating on the music/soundtrack instead).

Today, I’ve learned something. :wink:

[EDIT]And, just tried in StudioOne v4.5.1 - its a winner.! Perfectly fluid and solid playback.

Thanks for the reality check Bob! At least it’s not something to do with my system being set up wrong. I must be super-sensitive to visual glitchiness.
And the solution, it appears is switch to Studio One… :smiley:

No worries - would be good to see if others try the file too and report what they see on their systems. One to look out for would be a Reaper user - I understand it uses VLC as its playback engine, so should ace it like S1 (which makes me think - hint, hint Steinberg - would anything similar be possible for Cubendo…? No reinventing any wheels, etc, etc…)

Cars Passing.mov video, plays fine and smooth here in Cubase 10.0.30.

Looks like the recent update might have fixed this?

Not on my system, which I just updated to 10.0.30. I’m still getting glitchy playback.
Your system is quite similar to mine - but what makes it so special…
What are you using for graphics?

Cars passing.mov file plays fine and smooth here too with cubase 10.0.30
My computer is less powerful than yours.

I had this problem long time ago. Updating the graphics card driver fixed it.
Regards,

Thanks for testing this.
Unfortunately I’m already using the latest graphics drivers.

What I really don’t understand is - why is Cubase the ONLY program where I have this issue?
It’s a mystery to me!

JeeTee,
Your file is really small. I use to work with 1080p prores files that play smooth.
I understand you use the lastest drivers from AMD no from Microsoft.
I should suggest check for un needed bells and whistles.
For example a codec pack.
Estrange software running.
You can try to disable all unnecessary software using msconfig or task manager.

Smooth for me if I set the video framerate of my Cubase project to the clip’s rate of 30 DF…

Not smooth if I use my default/normal/european 25 FPS.

Expected behaviour, BTW.

H.264 is not a good codec for audio post. Use prores of dnxhd, big files but easy to decode and every frame is there.

Thanks for all the suggestions, but unfortunately none of them solve the problem.

However, I did accidentally stumble on the solution!

It’s a graphics card setting. Simple as that.
For my AMD card, if I RIGHT-CLICK on ‘Radeon Settings’ in the windows task-bar, and select ‘Graphics Profile’ I get 3 options:
‘Optimize Performance’, ‘Balanced’, and ‘Optimized Image Quality’. ‘Balanced’ is the default.
Selecting ‘Optimize Performance’ solves the Cubase video issue.

So for anyone out there who is having video issues in Cubase, I absolutely recommend trying this.
Even if you don’t have an AMD graphics card, you may have similar options to choose from in your graphics card software.

OMG.! You the man @JeeTee:slight_smile: :smiley:

Just saw the ‘solved’ edit to the subject line…

Immediately dived into my graphic card settings to see if I could tweak something similar - lo and behold, found a ‘performance vs quality’ slider (under 3D settings…?). It was on ‘quality’; switched it to ‘performance’ and voila.! Smooth playback of the file inside Cubase.

Nice. One. Son.

Bob

(Oh, and even now updated to v10.0.30 - all good.!)

:smiley:

JeeTee
Thanks for sharing your experience.

And from me too - thank you! ))