VideoEngineDecoder crash

Hello, just curious, after browing the forum I found renaming the file “VideoEngineDecoder.exe” (C:\Program Files\Steinberg\Cubase 6\Components) to “VideoEngineDecoder.exe.off”" solves the problems for now on both my desktop and laptop (while loading cubase the program crashes while loading a Vsti and moving the mouse, and experiencing random crashes while working on projects). (On my laptop a “DEP” message informed me of problems with the “VideoEngineDecoder.exe”).

In short; A question for Steinberg: is this a hardware or software related problem? Is the isue going to be solved in future updates or should I roll back to 6.02 and stay there, or upgrade my videocard, or upgrade to Windows 7/ new computers?
Is there anything else I can try? (need video in some projects).

No problems with v 6.02, things started with 6.03 (strangely enough not rightaway, but after a few days ), (not yet upgraded to 6.04) the folder-bug in 6.02 which is solved in 6.03 is one thing I will miss…

desktop; Q6600/ASUS P5K/NVidea Geforce 8500GT/4gb ram/3gb bootloader/XP sp3
Laptop: Dell latitude E5500/ Dell ODW635/ Mobile Intel 4 internal 1024mb graphics/2 gb ram/XPsp3

There is a problem in Cubase 6.03/6.04:

  1. Start Cubase
  2. Start Taskmanager
  3. Kill Cubase process

-> VideoEngineDecoder.exe crashes intermittently

This means that when Cubase crashes from what any reson an error message could point to the video engine also if the video engine is not realy part of the problem.

This is how you started your post:

Clarify what is the problem and how exactly it occurs in detail before writing how you think you have solved it or ask questions about the occurence. :wink:

Gr,
JHP

This is something new since 6.03, it wasn’t there before. My soft- and hardware hasn’t changed. If I don’t run the VideoEngineDecoder.exe with Cubase I have no problems. So it’s not Cubase without the VideoEngineDecoder.exe, it’s not my hardware or other software as it runs without problems without the VideoEngineDecoder.exe. There seems to be some change in the Cubase software that triggers the problem. (I never said it was due to the VideoEngineDecoder.exe)

And in what way would you want me to be more specific about the problems please?
As for your links at the bottom of the page: been there, done that. (exept for trashing the prefs, don’t see the need, correct me if I’m wrong).

kind regards, Jurgen

Hi, JHP

Maybe this one might enlighten you… : http://www.kvraudio.com/forum/viewtopic.php?t=329462

Bump…

Here is the .log file from the issue and its content :

C:\Users\Gest\Documents\Steinberg\CrashDumps\VideoEngineDecoder.LOG

===================================================================
VideoEngineDecoder.exe Uninitialized Build - 23.9.2011 20:09

Timestamp is 4e41464e (Tue Aug 09 16:38:06 2011)
C:\Program Files (x86)\Steinberg\Cubase 6\Components\VideoEngineDecoder.exe

Exception code: C0000005 ACCESS_VIOLATION

  1. In your quote (all the way above this post box) you are putting my name above a sentence that I never wrote. That is absolutely inappropriate. Do this a couple of times more with any forum member’s username and you will be banned. I never even write “off” behind files I would like to hide. :slight_smile:

  2. You have not clarified the problem that you are facing. Explain in detail when what happens. What happens after you start Cubase? What do you do then? Which Plugins do use? Which functions do you use? When exactly does which error message appear? Just because “VideoEngineDecoder.exe” is mentioned in a log or error message it does not mean that this is the cause of a problem! What are you actually doing? Make a decent report! Stop making assumptions and clarify the circumstances so we can make a proper report for the Devs.

Maybe a clearafication from jb about the actual occurences might be more appropriate then your thread interfering and failed enlightment attempt. :slight_smile:

This is a link to a thread at KVR about a specific problem with Alchemy. It shows you reporting a particular issue with Alchemy on KVR and a co worker from Camel Audio helping you to solve the particular plugin issue. If you would like to talk about those events here you should start your own thread instead of hijacking this one.

Lets give jb an oppertunity to make a proper report about his issue so we can forward it to the engineers.
jb, on Windows 7 the crah logs can be found at “C:\Users[Your Username]\Documents\Steinberg\CrashDumps”. You can send me your crash logs per PM or post them in this thread. :wink:


Certainly the “VideoEngineDecoder.exe” alone does not cause problems.
I will in any case forward your crashlogs to the respective departements.

Gr,
JHP

  1. Thanks for this… :unamused:
    As this thread is about VideoEngineDecoder.exe crash, I thought that this would be helpful to pinpoint where is the problem concerning it. Failing attempt ? OK, sorry for the bother…

  2. I am not hijacking anything and, sincerely, don’t like at lall this kind of assumpton : again, this thread is video engine related. As I never used the video implementation in Cubase, I am wondering why does it interfer with a ‘classic’ ( should I say) use of a VSTi. So, logically, I posted here a report concerning an issue that is directly related. What’s the point to create several threads about the same problem ? And, about the crashlogs you have everything at disposal in the post that followed my first intervention. No need to PM it.

You had a problem with Alchemy that was solved at KVR. The first part of my first post in this thread contained… ->

In your case errors pointed to the videoengine but the problem was related to Alchemy.

Your name is not mentioned in the Crashlog request; I directly addressed jb the thread starter to send me his crashlogs and a detailed report about the sequence of occurrences.

Gr,
JHP

Just a short reaction (bussy with other things for now)
@JHP/1: your right, did not even notice, ment to quote myself, sorry.
@JHP/2: JB said: “I never said it was due to the VideoEngineDecoder.exe”, I tried to explain that since the update something has changed on my systems, and I was just fishing for some answers. Maybe sometimes you have to stirr things up a bit to get some attention?..(I posted another treat about this subject earlier with no results) And surprise: it looks like the problem is solved on my desktop (stable again for 24hrs), if so then it was a pluggin related problem…(points for JHP :laughing: ) (I still have to check if it’s the same situation on my laptop). The post of “cubic 13” set me on the right track (thanks!..), deleting the prefs like mentioned in his threat did not help at first, but since the plugin-list rebuilds, some older plugins refused to reload properly. Removing the dll’s from the plugin folder (for JHP: seems to have) solved the issue.

I was hesitant to reset the prefs the way it is described here:

https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/removing-the-preferences-of-the-sequencer/

because I would loose ALL my settings if I deleted ALL prefs, cubic 13’s post showed me which prefs to try to delete first in this case (quite obvious now, but not when I started this thread).

I’ll send a repport and logs to JHP later, kind regards, JB