Vienna Ensemble Pro having bizzare effect

I think the video explains(?) it best - but it seems like instantiating an instance of Vienna Ensemble Pro is messing with mouse clicks in Dorico?
https://i.imgur.com/tVyeZeA.mp4

The same is happening to me with VEPRO (on a Mac).

Paolo

That’s very strange. We’ll look into it. Does the problem persist if the VE Pro window is not shown? Does the plug-in merely have to be instantiated, or does its window also have to be shown?

In my case, it seems that this issue can occasionally happen even without any player selected. Please see this example:

http://www.studio-magazine.com/video/sw/dorico/dorico-mouse-not-responding.mov

Paolo

We are aware that sometimes buttons can get stuck down when you click between them quickly and repeatedly, but that appears to be a different situation than all button clicks not being registered properly as shown in the original video in the thread.

Yes, it persists regardless of the windows visibility.

I believe this issue is not pinned to VEP, I have similar issues with any window I click outside Dorico. The buttons need a second press to work. The same sometimes refers to the properties switches.

I see this behavior also. It’s certainly worse with VE Pro. When monitoring CPU % in activity monitor, the CPU for Dorico eventually gets to 99 or 100% and then things go south really fast.

With other plugins (e.g., contact or Pianoteq), the CPU % for Dorico rarely gets above 30%, and if it does, it quickly comes back down.

I tried reducing instance core counts allocated to VE Pro and that did not have any effect to improve this issue.

When this happens could you please make a note of the time it happened and create a diagnostic report?

Dorico got to 99% at 9:20AM
Dorico Diagnostics.zip (588 KB)

Hmm, unfortunately there’s nothing in there that gives any clue as to what is happening. Could you please take a spindump when this next happens? Open Activity Monitor, select the Dorico process, and from the cog in the menu, choose Sample Process, then save the resulting text file, zip it up and attach it here.

Here you go.
Spindump.zip (294 KB)

Thanks. I can see that it’s spending a huge amount of time drawing the UI, but I’m not sure why. Which mode were you in at the time? Could you please send us the project? p dot walmsley at steinberg dot de

I just created a new project with a singe instrument and connected it to VE Pro Server. I didn’t even load any samples. I then just started clicking around changing modes and watched for it to slow down and the CPU % to go to 99%, It’s pretty easy to do this just clicking around the UI. I think Play mode is the most suspect to get issues started but can’t say that for sure.

When it slows down you’ll see it delay executing a click. Or leaving behind active buttons (darkened) even after it switches to whatever you click. Some clicks require more than one click to cause it to take action.

Paul has found the problem here, which is caused by Dorico doing some overzealous updating of the name of the plug-in when it’s too long to fit in the display. If you open the Endpoint Setup dialog and rename “Vienna Ensemble Pro 7” to something short enough that it doesn’t need to be elided to fit, e.g. to “VE Pro 7”, then you will find that the problem is solved. We will of course fix this problem at our earliest opportunity.

There is also another workaround - hide the right panel by clicking the disclosure or use ctrl-9 (win) or cmd-9 (mac)

Thanks, Shortening the name works great!

Ha! Both of these solutions are really funny…! You guys are brilliant anyway!

I’m having a mouse click issue with Better Touch Tool. With it active for D3, I can click one note to start a selection but am unable to CMD or CTRL click a second note to extend the selection. I did not have this issue with D2.

**Leigh

Can you Shift+click to extend the selection?