Vocoder being played by Chord Track

Hello,

I was excited to find a vocoder in cubase 13.

My current project includes a chord track, and an audio & MIDI track set up with the vocoder. I watched Dom’s video and read the plug-in manual, and as far as I can tell, the vocoder is set up correctly. It is inserted on the audio track, and the output of the MIDI track is inserted to it. The monitor is engaged on the MIDI track. I played around with it “live” a little bit. It does what it’s supposed to do.

But in the context of the project, before I even played any keys on my MIDI controller, the vocal was being processed polyphonically by the vocoder via the MIDI notes of the chord track. The way I understand it, the chord track notes were acting as the “carrier”.

This would all be fine and dandy. In fact, it sounds cool. However, I only want to process the vocal as a monophonic part.

I’ve gone back and forth among the chord track, the instrument track to which the chord track is routed, the audio track, and the MIDI track quite a bit to check the MIDI routings. After tinkering around, the only way I’ve found to stop the chord track from being the carrier is to render the chord track as audio and delete the chord track. Then I can play whatever I like on the keyboard and the vocoder follows my keyboard notes.

That works fine, but I would rather figure out how to make it work without resorting to those measures. I can’t help but think there’s another way that I’m just not seeing.

Got any ideas?

Most likely this is the source of the problem & you have the Chord Track MIDI Destination set to Use Monitored Tracks. You can resolve this by Muting the Chord Track or changing its Destination to a specific Track (including a dummy Track that does nothing if you like).

Thank you for your response.

I knew I forgot to put something in the OP. The Chord Track MIDI Destination is the instrument track I set up for the Chord Track. That’s not it.

I’ve messed around with it a lot and I get what’s going on, I just don’t know why. Honestly, this plug-in is clunky and confusing.

Here’s what I did:

I muted the Chord Track, and even though the chords no longer play through the virtual instrument track, the processed vocal still follows the chords (of the Chord Track). Baffling. I still can’t figure out why.

I completely deleted the chord track, and at first the vocal was still being processed by the vocoder, but instead of following the chord changes, they got “stuck” on the MIDI notes that were playing from the chord track at the moment I deleted it. This is all while I’m not playing my MIDI keyboard. There should be no vocal coming through at all.

But if I click twice on the Activate/Deactivate Sidechain button (once to activate and again to deactivate), the vocal finally goes away, and the vocoder works as expected. The processed vocal appears when I play my keyboard, and disappears when I’m not playing my keyboard.

I’ve repeated this process several times.

Can you post some screenshots showing 1) The MIDI Port Setup tab in Studio Setup 2) the MIDI Input Routing on the Vocoder.

Have you checked to see if a hidden Track might be causing the problem? Do you ever use Virtual MIDI Cables?

[quote=“raino, post:4, topic:888855, full:true”]
Can you post some screenshots showing 1) The MIDI Port Setup tab in Studio Setup 2) the MIDI Input Routing on the Vocoder.[/quote]

Sure thing:

I have no hidden tracks. I don’t think I use virtual MIDI cables. If I have, it was inadvertently. Do you think I would know if I had used them?

I had some time to tinker around with Vocoder more today and can confirm the Chord Track does “play” the Vocoder. Step-by-step, here’s what I did:

  1. Created new project
  2. Added one audio track and one MIDI track
  3. Recorded voice on the audio track
  4. Inserted Vocoder on audio track—the vocal was being processed immediately as the vocoder MIDI mode was FIXED
  5. Set Vocoder MIDI mode to EXTERNAL
  6. Vocal went away; neither processed nor unprocessed vocal present
  7. Routed output of the MIDI track to MIDI input of Vocoder
  8. Still no vocal
  9. Selected “Intimidating Robot” preset of Vocoder; unprocessed vocal appears
  10. Playing MIDI keyboard does not process vocal
  11. Engaged Monitor on MIDI track; unprocessed vocal while not playing keys and processed vocal while playing MIDI keyboard
  12. Added Chord Track; vocal still plays back unprocessed while not playing MIDI keyboard
  13. Added chord to Chord Track. MIDI destination is “Use Monitored Tracks". Vocal is processed while not playing MIDI keyboard.
  14. Added instrument track to monitor Chord Track. Selected instrument as MIDI destination from Chord Track. The instrument plays the chord, but the vocal still processed

Still not sure how to prevent the Vocoder from following the Chord Track. All things considered, this does provide a useful way of using the Vocoder IF one wants to do it that way, but if a melody (rather than chords) is desired from the Vocoder output, it appears that there must be no Chord Track (with chords present, at least) in the project, unless I’m missing something else, which is completely possible as I’m not exactly a Cubase whiz yet.

Yeah, you’d know. It involves installing a 3rd party app.

It’s hard to figure out from even a detailed text description what’s going on since there are so many different possible combinations of what Monitors are enabled, Tracks Muted & Routings.

Just to confirm, a couple of posts up you said the Vocoder was following the Chord Track even though the Chord Track was Muted. If that’s the case it implies that the source for the MIDI which the Vocoder is receiving is something other than the Chord Track. When the Chord Track is Muted its data can’t go anywhere.

I’ve been using the Vocoder a bunch since C13 came out. Once the Vocoder seemed to be receiving MIDI Data out of nowhere & it was driving me crazy trying to sort it out. In the end it went away after I cleared out the Retrospective MIDI Record Buffer on the MIDI Track that was routed to the Vocoder. Maybe give that a try.

The Chord Track is absolutely what the Vocoder is responding to. There is no other MIDI information (other than groove agent) in the project. That doesn’t explain how the MIDI information is getting to the Vocoder, but it’s not as if the Vocoder could otherwise know the chord changes are going from Gm to Dm.

I went to try the MIDI Buffer, and it is grayed out. Everything else is still consistent with how I’ve described it.

At any rate, I feel comfortable knowing how to work around the issue, which was the entire point in the first place. Thanks for trying to help me. As I learn more about Cubase, perhaps I’ll come to a more complete understanding of what’s happening in this scenario.

Try doing a Save As… to make a copy of the Project and Delete its Chord Track -what happens then?

I have the same problem.
If I insert a vocoder in a project that contains a Chord track; the vocoder sound is garbled.
If I delete the Chord track; the vocoder works fine.
I use a large Chord track as a visual reference.
I need it while composing.
Has anybody found a workaround?

Following. I couldn’t get the vocoder to work the other day. I have a chord track in my template, so I’ll try removing it.

I hadn’t thought about this topic for a while. I stopped using C13 until the recent update. I’ll jump in and see if the vocoder is any different since the update.

Thanks for your experimenting DictionaryOfExcuses.
I would not have found the link between the vocoder and the Chord track by myself.
I’m afraid that the update did not solve the problem.
I like the sound of the Cubase vocoder very much.
It’s a shame I can’t use it.