Voices in Score editor

Hi there,

I’m trying to enter a piano part in the score editor, but although I’ve set it up exactly as described in the manual, the 2nd & 3rd voices and so on, don’t do what they are expected to do. The score is set to polyphonic as the manual says, the staff is active, I click on the appropriate number in the insert note tab, but nothing works as it should. So here’s what’s happening:

Entering notes in voice 1: no problem
Entering notes in voice 2 (channel 2 according to the settings): are also showing up in voice 1, replacing the already entered notes.

Voice 3 (channel 5 according to the settings): are showing up in voice 1, replacing the existing notes.
Voice 4 (channel 6 according to the settings): are also showing up in voice 1, ditto

When I check the midi editor, all notes are in channel 1, despite the setting in the polyphonic tab where it says they should automatically go to channel 1, 2, 3 & 4 :open_mouth:. When I select the specific notes and change the channel, then the notes appear correctly in the score and correct voice. I’ve changed the instrument to listen to ‘any’ channel, to 1, 2, 3 and so on, no result, all notes keep going into channel 1. According to the manual Cubase spreads the notes to the different channel by itself, but this is not happening in my file. I’m out of options, couldn’t find anything on internet, so I hope someone here has a clue.

Cubase Pro 9.5.30 on Windows 10 64 bit. Cubase works great and without any issues, except the one described above.

But how are you entering the notes? Mouse? Recording? Cubase doesn’t automatically set the channel, until yo use Scores>Functions>Explode - to polyphonic voices.

Example of entry by mouse is in the video zipped and attached.
polyVoices.zip (64.1 KB)

In the Key Editor in the upper right there is a drop-down which sets how the notes are colored. By default the color changes with velocity. Change it to color based on the Channel. Now it is easy to see which notes are on which channel to help sort out what’s happening.

Also on the Track’s Inspector you want the Channel set to “Any” which will let the note play on whatever channel is assigned to each note. If for example you set it to 1, then all the notes would play on channel 1 regardless of what channel is specified with the note. In effect this lets you override the channels specifically assigned to each note. I know this effects the channel used for playback but am not certain if it does the same for the score (not at DAW to check, Steve will know off the top of his head).

Thanks guys, for your input.

@Steve: I enter them using the midi keyboard and step input. The way I do it is described here from page 67.

https://steinberg.help/cubase_pro_artist_score/v9.5/en/Cubase_Pro_Artist_9_5_Score_Layout_and_Printing_en.pdf

Mouse input works as you showed, but I don’t see anywhere that I can’t use my midi keyboard for inputting notes into voice 2, 3, or 4.
Bytheway, I just figured out Cubase puts them in the corresponding channel 2, 3 and 4 for each voice, but connects them to the notes in voice 1, creating tied notes and unnecessary rests and so on. After I’m done with a frase, I can do the explode option, but I think this step should not be necessary, as it will consume a lot of time, especially in larger scores.

@Raino: I did set it to Any, but the result remains the same. Thanks to your suggestion of the note colors, I discovered they are spread to the right channel, but are displayed as voice 1, so I’m one step closer to resolving it.

By setting the keyboard to transmit on the desired channel, or using an input transformer to transform the channel to the desired one.

Hmm. If the staff is set to polyphonic, a note on an assigned channel will appear in the corresponding voice. It should be that simple.

Cubase doesn’t need the “voice” to be set to decide where to put a note on the staff. That is all determined by the channel number. Although maybe all the tied notes etc. are the result of the voice being set.

I almost always enter notes by drawing them in the Key Editor (not via controller). Whenever I do that the Voice field for the notes are always blank. I’m not sure what is causing this value to be set in your case. Try selecting all the notes and deleting the Voice value in the Info Line.

If that works you could make a Logical Editor/Key Command to do it easier on a regular basis. But I’d try to figure out what is setting the Voice value and stop it before it starts.

Or even setting the Channel in the Track’s Inspector will force the notes to record on that channel. So you could set it to channel 1 and play the soprano line, then channel 2 for the alto etc.

When done set to Any.

Hm… The term Voice refers to different things in the Key Editor and Score Editor.

The Score Editor polyphonic voices are strictly for notation and are based on the notes’ channels, and not SATB.

In the key editor Voices refer to SATB, and are connected to the harmonic functions in Cubase, chord track, Logical Editor Context Variables and so on.

Of course the Logical Editor can be used to set poly voices from SATB voices and vice-versa.

(If it’s a piano part, the midi channel of the track should be set to the channel of piano VSTi is receiving on, not ‘any’.)

Yes - egg on face

It might be helpful to see a screen grab of the same notes in both the Key & Score Editors and the Track Inspector showing its channel setting. Have the Key Ed show channel colors and select one note on a channel other than ch. 1 so we can see its settings in the Info Line.

This is all going to come down to some silly little thing - in general this works pretty easily.