VSL Saxes Staccatos not playing back as expected


I have a piece for Saxophone orchestra that is not playing back staccato as expected. I am using the Vienna Saxophones Library and the Vienna expression maps. I have slightly modified the expression map CC11 and CC2 as dynamic control, otherwise it is as provided by Vienna.

The Soprano and Alto parts (which share an expression map) have a section marked as staccato. In the play window the technique is clearly shown as Staccato. The expression map for staccato calls for the key switches C1 and C2, which is correct in the Synchron player. However it is actually playing back C1 and D2 which according to the expression map should be Natural, Note Length == Short. I am baffled as to why the playback is not using the expected Staccato key switches.

I can modify the MIDI in a DAW to C1, C2 and it works correctly. I’m just a bit baffled as to what I’m missing in Dorico.

Here is the file, if that helps anyone.
Harlem Nocturne (for audio).dorico (1.1 MB)

Thanks in advance


Short naturals are better associated with portato/loure/staccato+tenuto etc. I hadn’t noticed this (I have Synchronized Woodwind), and will give it some thought. At first blush, though, there is nothing to be gained from a Natural Note length == Medium and a Natural Note length >=Long. It seems to me that Natural Note length >short covers both.

Thank you for your reply Marcabru. I agree with your comments regarding the short naturals. What alerted me to the issue is the the playback didn’t sound quite right and on investigation I found that the stacatto is being played in short natural. My problem is that the expression map should be making the Synchron player play the correct key switches , that is C1 and C2, but it’s actually playing C1 D2 and I have no idea why.


I had a look and I do not know why exactly it is happening, but it seems to be related to the “rhythmic feel” settings.

If I delete both the rhythmic feel signpost “Light swing 8ths” from the beginning and the “Straight (no swing)” signpost at the end of bar 19, then the staccato in bar 20 plays back correctly. If either rhythmic feel signpost is present, then you get portato instead of staccato.

It seems like this might be some kind of playback bug in Dorico to do with rhythmic feel. It is possible that it has gone unnoticed, if it only affects people using different rhythmic feels in Dorico (classical composers are unlikely to ask for swing and other such things).

It also plays back properly if the notes are shortened to sixteenth notes instead of eighths. At first this made me think that it was an issue with the Playback timing setting “Maximum duration for staccato playback technique”, but no matter what this was set to, it did not make a difference. But I think it has something to do with the fact it is swung eighths, that it only breaks staccatos involving eighth notes somehow.

The other very odd thing here is that either way, the playback line shows “staccato” as the active technique at that spot - Dorico does seem to know what technique is supposed to be triggered there, but that isn’t actually what is being triggered.

Maybe @dspreadbury should have a look at this.

1 Like

Oh, well done Mducharme! The sound you hear is me slapping my forehead… I do not have this problem in the other pieces I have written out for the Sax Orchestra and was completely stumped as to what was different with this particular piece and you’ve put your finger on it exactly. I haven’t used the swing signposts on the other pieces.

This problem is now solved - or at least moved onto the developers shoulders…

Thanks again


@dspreadbury Sorry for pinging again, but last time I tagged you, it was in an edit to the original post, and I’m not sure if forum users get a notification icon when they are tagged in an edit instead of originally. If you already saw this, please disregard.