VST and CPU issues

Hi everyone. I have suddenly got so much trouble with my CPU in Cubase.The sound on my project disappears very often, and it is playing in “slow motion” with a lot of noise on sometimes.

I´m using Cubase 8.
I´ve recently installed Native instruments Komplete Ultimate 11 on an external hard disc. Ive also installed 16 GB ram on my Macbook pro (2012), and an extra screen. I have tried to change the buffer size to different types, I´ve also turned off the record enable button (that makes my machine running slower for some reason). I have tries to move the VST to the hard disk, like Reaktor basses for example, that is the biggest problem, nothing helps. It´s getting better if I turn off the “constrain delay compensation” button, but then I can’t mix. :frowning:

I recently got these problems, earlier it was just fine. The project contains about 25 VST instrument and of course a lot of EQ and compressor. Im using 441 kHz and 16 bits. Sometimes the project works, but suddenly it VST performance go to overload without any specific reason.

Anyone else with these problems? It´s so frustrating. Please help if you can!


NI plug-ins are pretty CPU hungry. Do you use multi timbral? Or do you use single instance for every single sounds only?

Why you cannot mix if you disable Constrain Delay Compensation?

What Audio Device do you use? What macOS version? Did you try Repair Disk Permissions (or First Aid) from Disk Utility? Does Activity Monitor point to something? Any CPU hungry background process? Is your web browser closed?

Sorry just ideas…

Thank you for feedback. I use send effects for reverb and delays, and paralell compression. Eq and compression on each track. With Constrain Delay Compensation off
I don’t get the right feeling while mixing. Nothing as far as I know is using CPU. Only Cubase is open. The machine is just fine, works really fast. so I have not done any rebooting or first aid. It’s captain OS from 2012, and a Scarlet 212 sound card.

I’ve been thinking about my disk space, some if the vst are on the disk, maybe Native need more GB space from the disk, not only from ram? While installing Native I needed 70 GB free… It’s strange, it started after I changed the ram size. Earlier the machine was great.


I would recommend to trigger the First Aid anyway.

I probably didn’t get your Constrain Delay Compensation settings. This should be off. Otherwise you work in a real time, and some plug-ins might be bypassed.

Yes, it’s good to have at least 10% of the hard-drive free.

If it started when you change the memory, then the problem is in the memory. Make sure you are using supported memory, with the supported speed, and you are not using unsupported combination. Might be one of the memory module is faulty.

Thank you for answering. The problem started before I changed the ram, that’s why I changed it. Project without all the native plug in works fine, so I still have no solution. I will try the first aid.

Sorry, but you wrote:

it started after I changed the ram size

So when did it really start? This is an important hint.

Sorry, it was a problem before I changed the ram, a much bigger issue now, but I’ve also installed native ultimate a couple of weeks before I changed the ram, and I started the project that contains about 25 vst instruments (this project is the problem)

NI instruments are CPU very hungry.

If you have 25 instances of Kontakt or Reaktor… Can you use multi-timbral? Optimize NI according to their recomendation.

NI Komplete instruments tend to use internal convolution reverb by default - one per instrument not shared.
Highly recommended shutting off the instruments reverb and routing your instruments to reverb and other effects in Cubase itself if you haven’t already to reduce CPU load.