VST Audio Engine not unloading when Dorico closes

Hi Ulf / Daniel,

When I close Dorico, the OSX Activity Monitor is showing that the VST Audio Engine is still running. If I restart Dorico, the program will hang.

I’ve tried reinstalling Dorico 5 - the problem is still there. Attached is a diagnostics file.

Dorico Diagnostics.zip (1.4 MB)

Hi David,
so the audio engine lingers on every time you close down Dorico?
In that case it probably is deadlocked somehow and is not repsonding anymore.

Could you please open Activity Monitor and then create a spindump?
In AM at the top of the window is a little icon with 3 dots, click on that and then create spindump.

Hi Ulf and thanks for the quick reply.

Yes, that’s correct. The Audio Engine lingers. FWIW I’ve just opened and closed Cubase and the Audio Engine closes OK for that program. Spindump attached.

Spindump.zip (398.1 KB)

Thanks very much, David.
It appears that the audio engine is hanging in a wait for the MediaBay.
Could you please do it one more time, but this time take two spindumps in a row and attach both of them here? That’d be fantastic, because by that I can check if it is really hanging at the same spot.

And by the way, in Cubase the audio engine is running directly in the Cubase.app, there is no separate process for it like in Dorico.

Thanks Ulf.

Spindump 1.zip (347.7 KB)
Spindump 2.zip (390.5 KB)

Thank you so much.
So yeah, all spindumps are identical, so it is really deadlocked accessing the MediaBay.

Please do once more (sorry, again and again), but instead of doing a spindump, you click on the icon next to that with the 3 dots, it’s the button with the little “i” inside, and then choose the “Open Files and Ports” tab. With the mouse select all and copy to the clipboard and paste it into a text editor, save and send me.
Let’s see if that brings more insights.
Thank you so much.

:+1: File attached.

Open Files and Ports.zip (2.6 KB)

Thanks for all the stuff you’ve sent me, but I still can’t figure out exactly what is going on. What I know is, the main thread is stuck in a function where it tries to read some data chunk of an instrument, but I can’t figure out which one. So I have some more questions:

When did that behaviour start with you, already longer ago or suddenly just recently? You can work normally with the project files, right? Nothing gets destroyed or missing, right?
Does it happen with every project file you are working or just particular ones?
If you save a project file, does in Activity Monitor the audio engine get marked as "unresponsive?

Sorry, so many questions…

  1. I’ve only noticed it recently - as in since last weekend. However I wouldn’t read too much into that as I’ve been working on other stuff (non Dorico) for 2-3 months.
  2. I can work normally with Project Files - nothing appears to be missing and they all load up OK…
  3. It seems to be happening with all Project Files. For example. I’ve just created a very basic one from scratch, entered a chord, saved it, closed it, closed Dorico - same result.
  4. There’s no “unresponsive” message.

Just a quick follow up: During a remote session with David I found out that the SteinbergMediaBayServices is crashing on loading of a project. Team7 will need to take over the case.

1 Like

Many thanks for your help, Ulf.

1 Like

Hi Ulf,

Just to let you know I may have solved this. I had a problem setting up Cubase 13, looked at the OSX crash logs and they were about MediaBayServer. That rang a bell…

Oh, thanks for letting me know and good that you found a solution for it. Excellent :smiley:

1 Like

That sounds awesome, actually… Like a Tom Clancy thing…