vst busses do not show up in mixer view

hi

i first posted this to the general forum, but it appears this must be a bug.

synopsis - when working with an audio device that has multiple inputs + outputs, vst instrument busses do not show up in the mixer window. the mixer slider ‘elevator’ dutifully shrinks as more vst outputs are enabled, but they do not appear. disabling hardware outputs from the audio interface will reveal the vst instrument busses ; it’s as though they are ‘hidden’ behind the hardware ins and outs. when enough hardware i/o are enabled, you can slide the slider elevator back and forth, but nothing on the window will move [hardware ins and outs all stay put]. disable the hardware busses and the vst busses will move back and forth as you slide the slider.

for visual, see here :
http://www.steinberg.net/forums/viewtopic.php?f=226&t=78906&e=0#p451580

to reproduce -
1- configure a multi-in/out interface to use all available i/o. mine has 10 ins and 10 outs.
2- instantiate a vst w/multiple outputs. i used kontakt with 8 outputs.
3- inside the vst, make sure you have all output busses activated.
4- on the cubase track view, inspector panel, enable the outputs you have configured in the vst.
5- open the mixer window. you should see something like the screen shots above. move the horizontal elevator, you will see nothing in the window changes.
6- disable hardware i/o busses. you will see vst outputs becoming visible in the space between the hardware inputs and outputs [where the 2 red arrows are in the screen shot], and the horizontal elevator will lengthen to indicate that there are fewer busses in the field of view.
7- move the horizontal elevator again, you will see the vst busses move.

platform info

  • pc with pentium i7 cpu, gigabyte ga-z77x-ud3h mobo, 24gb ram, 2 hard disks, standard onboard graphics
  • edirol ua-1000 audio interface
  • windows 7 enterprise x64 sp1
  • cubase 8 elements trial