VST connect only going to speakers [MAC?]


I had a session with someone using MAC and I couldn’t get his computer to output to his headphones. We tried also his desktop mac and it was the same.
sound woud go to speakers no matter what. If he plays a film on computer he could have it to headphones (jack connection) or speakers (if unpluged)
in VSTconnect his connection was labeld “headphone …something” other output didn’t work and had weird names. But this headphone output was played by speakers…
He tried with a desktop mac There’s was 3 output available. But whatever I selected there the master could only display n/c
To mention finaly MAC asks for some permission for vst connect (were my pc with vst performer doesn’t) so we selected yes and allowed everything. but was the same.

It happened to me once with another vst connect session but then the person was so bad with his setup i didn’t bother and just used the laptop speakers (blutooth headphones connected to his phone etc) But I guess it was a similar issue.

So I tried with my laptop as vst perfomer and it’s working fine with headphones (asus) over internet (not lan)
I wonder if that’s some routing specific to mac. (i don’t know mac)
can someone help ? I have to solve that.


… I guess you are talking about “External Headphones” for the “Audio Output” on the Performer side? After you have selected the Output Device, please let the Performer restart the Performer application and do a re-connection. Better now?

See you,

1 Like

ok thank you. I will try that and see if it works. Although I know we did several restart because having issues… but it’s worth double try it.

so we finally did it. restarting the app was not enough !
We had to leave the headphone plug in the socket of the laptop and restart the computer :stuck_out_tongue: then launch the app, select the proper soundcard in VST connect settings and it’s master track and now it was working .
So not sure what goes on. but that helped thanks.