VST Connect & VST Connect SE - Solution Thread

I’m just thinking out loud…would anyone be interested in setting up a forum song that can be passed around to a few individuals who might enjoy experimenting with VST’ Connect SE. I’m more of a player user than an engineer user , guitarist, and have some free time now that summer is approaching. I won’t take the lead on this yet,I am still in the process of getting started but after reading 6 pages of posts, seems do able

I would actually be highly interested if at some point they can also get this to function within the same local network. My studio consists of two separate rooms with separate computers in separate buildings, but with the same Internet account. If in the future there be someway to link them using VST Connect, that would be awesome! :smiley:

A “pro” version has been mentioned at additional cost, which will work on a private LAN. I asked the same question a few dozen pages back!

I would personally recommend both users be connected directly to their router or modem via a physical ethernet connection. A wireless connection on either user’s end is not ideal and will not give you the same performance.

Also a VST Connect SE to VST Performer connection requires two different IP addresses.

Of course this is best - but nevertheless I did it with a wireless performer on a not so fast connection and it worked flawlessly :slight_smile:

I always get “server not responding” when I try to login. Does this mean that ports 5111 to 5113 are not open (it should be now) or can this be also a bandwidth test ? I’m connect via with a cable and the router (from my provider) is set to open this ports.

Did anyone have been blocked by this error before ?

Thanks in advance !

I assume your firewall is configured to not allow UDP at all. The connection server is always available, it’s just as if you open a webpage in your browser. The only difference is that it uses UDP. It certainly has nothing to do with low bandwidth, because for logging in, only a few bytes are exchanged.
With the latest versions, port forwarding should no longer be necessary except in very rare cases.
Do you happen to have some extra firewall installed?

Hi all

I’m not sure if this is an issue or not with VST connect.

I ran into issues running a home based server that I wanted to log into. The method was to connect to a server on the web and it would redirect the dynamic IP and ports to my internet connection(ISP). After many hours of port forwarding, reading about it, etc, i discovered that my setup was running 2 NATs.
NAT = Network address translator
Its purpose is to translate the incoming IP and ports (WAN) to your internal IP addresses on your LAN.
NAT # 1 is in my modem’s firewall and NAT # 2 is in my main router. I don’t use the modem as a router or wireless for personal reasons. Even with setting forwarding on both devices, the uPNP would not work.

To resolve the uPNP not being able to set up port forwarding correctly i disabled the firewall on the modem and set the DMZ to my router’s IP and let it do all the security stuff etc. This fixed my server issues and i have had no issues with VST connect except i want to run it internally.

I have some ideas that i am exploring, to get it to work internally, cuz i want to use my laptop in another room as a capture device. trying to eliminate cables and speakers etc in the other room. It just seems to make more sense. One cat6e cable to my router and all the clutter and noise is minimized.

Please be careful when playing with your network setup, and don’t shoot the messenger.
I’m just sharing my experience.

Gotta go play and record. :smiley:

Listen up folks! :slight_smile:

“server not responding” or “another program are in use of the same socket”- type or error can may be nothing to do with your own setup or Internet connection.

It seem that sometimes it can be about STEINBERG-NET servers that are completely down for the moment, that cause this error messages. It can be a good idea to try and see if you can web surf to Steinberg’s website to exclude this kind of problems.

This happen yesterday Saturday 20th of July 2013 approximately between 8-10 PM Standard Central European time. Both the Steinberg-Website and the FORUM was completely down and also “VST Connect” couldn’t be used or connect during this hours.

Because of that it cause all kinds of strange error message when you tried to use of “VST Connect”. It even followed with a long one that urge you contact Steinberg if this errors continues. :wink:

I don’t know exactly how this work but its seem to that “VST Connect” need Steinberg severs to functional correctly. After all the Severs finally were up again, “VST Connect” work perfectly with out any problems again without me changing anything in my setup.
It seem that “VST Connect” need to contact a specific Steinberg Server to get the random code or confirmation of some sort.

Steinberg tech knows exactly more about how this actually do work but I guess they will not explain further for security reasons. I’m glad if they don’t, we don’t want someone to crack and intercept our sessions.

Then after connection has been established I guess the session work in “peer to peer”-mode between the two clients.

I hope it help solve some of the confusions. :wink:

Best Regards

Thanks musicullum,
But after many hours trying to get this work, I still get this “Connection Error” - Server not responding.

Also, Cubase does not connect to Steinberg Hub, do you think this could be related ?

This is without firewall, and internet works fine.

Do you think that trying to have a UPNP server working with iTunes could be something to try ?

Thanks !


Hi DiSky,
pls don’t confuse UDP with UPnP. VST Connect doesn’t deal with UPnP at all. And The Hub problems might well be related.
UDP is the protocol which VSTC uses to connect to the connection server when you engage the login button. In general, this is no different than sending a search request to Google, because like Google, the server is wide open to welcome your request. This is quite different from me sending a request to your computer, because your firewall is not expecting this and not williing to let anything in just like that.
When Google replies, your firewall has remembered that you sent a request recently and therefor let the reply in.
The only difference with VST Connect is that your browser uses the htp protocol while VSTC uses UDP. This works close to 100% on almost every connection because there is nothing bad with UDP at all. But firewalls can be set to block UDP packets either on the outgoing request (less likely) or the incoming messages.
Unfortunately (in this case) there are often 2 firewalls to look at: the one of your router, and the “software” firewall in your computer (like Windows Firewall). Either of those may have been set to generally block UDP, probably on the incoming side. Except for when there is actually no internet connection, or the connection server is down (pretty much never), connecting to the connection server has never failed.
Things are quite more difficult when you want to establish a peer-to-peer connection as you would do later on. But that has nothing to do with your problem. Bottom line is: the connection server always welcomes requests and replies reliably, so it is very likely that one of your firewalls is set to block UDP traffic (probably incoming). If you tell me exactly what you have I may try to figure out wher to look.
One final thought…whichever software firewall you use, why not switch it off and see if the message vanishes and you get a key. When you have all other applications closed nothing bad can happen. Then at least you’d know whether that was the culprit.
So when you say you switched off your firewall, which one is that? And how to you tell “internet works fine”, do you tell by googling or how else?
Hope that helps,

Thank you so much for you reply :slight_smile:

About Firewall : I use Comodo and I did quit before starting Cubase.

About the router firewall, I’m based in France and I have the “neufbox”

I went to the “NAT” section to open UDP :

UDP Plage 51111-51113

Is there a way to check if UDP ports 51111 to 51113 are open ?

I’ll continue investigate, from what you’re saying, the router is probably still blocking this.

Thanks again and have a great day !


That would be the first thing I would look at. Disable it for a test.

I’d love to be able to get this to work.

I’m using the vst connect template that is included with C7. (ver 7.0.4)

I have allowed Cubase Connect in both Windows Firewall (Win7) and in my router to allow UDP 51111-51113.

The remote user (ver. 1.3.0) keeps getting an error message that says:

" studio key ##### ##### is not logged in"

I can see the key that was generated at my end, with the word “logout” beside it, so I know I am logged in.

Any suggestions?

Does the port forwarding on UDP 51111-13 need to be done on both ends?


I swear the Performer mistyped the key, or has been told the wrong numbers.
When the engineer clicks the login button and gets a key displayed, he is definitely logged in, and that message says that the Performer was also successfully registered, but no match could be found for the key. Unless maybe there was more than 30 minutes between obtaining and submitting the key.

I can see the key that was generated at my end, with the word “logout” beside it, so I know I am logged in.

Any suggestions?

Does the port forwarding on UDP 51111-13 need to be done on both ends?

Usually ports don’t need to be opened at all anymore. For connecting to the primary connection server which provides the key numbers, there should also be no need. If this fails (message “server not responding”), one of the firewalls on the engineer’s ( Cubase) end is too restrictive and all ports should be opened there. When the peer to peer connection doesn’t work it’s hard to say which side fails, then both can try to forward ports. But again, if you don’t mess around and just use the router and OS firewalls and don’t change too much there or apply additional firewall programs, it should really work “out of the box”.

Argh! Thanks for your reply, musicullum!

I tried again with him and got the same result: " studio key ##### ##### is not logged in". I gave him the code one number at a time and had him enter it manually. I had him make sure there were no leading or trailing spaces in the key or the username, that there were no capitals in the username, and that there WAS a space between the two sets of numbers in the key. Same thing. FWIW, he is using Win XP.


I tried with another friend, and it connected just like it should - right out of the text book. This seems to rule out anything that I might be doing wrong. He is using Win7.


I had an issue with the second friend. Once connected, he could hear my talk-back mic, and any audio I played through Cubase. I could see his video stream. I could NOT hear him.

It may be relevant that, after being connected for about 30 seconds, I got a recurring error message that said, “continuous sample rate mismatch: please change either your sample rate to 16000 or the artists’ rate to yours.”

Now, when I went to the settings in Cubase Connect, we were both at 128kbps. I changed us both to 320 kbps. No difference. The project sample rate was (and is always) at the default setting of 44.1 khz. I couldn’t find any mechanism to change his sample rate to anything other than the stock list of 128, 192, 256, etc. kbps.

Can you make anything of this?




Just tried with my mom, running Mac OS Leopard 10.6.8 and she got the “studio key ##### ##### is not logged in” message. I regenerated another key, and still the same result.

Just thinking out loud… does it matter that we have Facebook or Google+ Hangouts running while we try this? This is how I am communicating the username and keys to the people on the other end.

Update again…

Just tried with my sister running Win7. Originally got a “server not responding” error. Tried again with a new key and got the “studio key ##### ##### is not logged in” message.

We both restarted our computers and tried again. After a couple of tries with me getting the “server not responding” error, I got a code and sent it to her. She got the “server not responding” error. I gave her another new code, and she still got the “server not responding” error.

I did check my speed with my provider using their own on-line test. My download speed is 6.25 Mbps, and my upload speed is 0.82 Mbps.

Any thoughts?



I have looked up the logs of aug 19th.
There are many cases of “key xxx not found” reports (which result in “…is not logged in”).
The reason in all of these cases is, that the Cubase side has been unregistered before the Performer submitted the (correct) key.
This is not good and we’d like to find out what happens.
My first guess is to agree to your suspicion that other Internet related applications and/or connections might get in the way. For instance Skype is also using UDP and under unlikely but possible circumstances it might use the same ports.
But what concerns me is that you have not reported that you were logged out when you returned to Cubase after switching to your browser or whatever. The logs say you were unregistered between obtaining the key, and the Performer submitting it.
So either we need more information, or you to try to not use other programs and see if that works, or drop me a PM and maybe we can sort this out together.
We are not allowed to store any personal information and we don’t, but if you try next time, you may also give us a key where it fails, so we can identify it in the logs. A new key is generated with each login, so there is no harm.
We’ll sort this out like we sorted out every problem so far, thanks for your patience!

Hi Musicullum;

Thanks for checking the logs and for your feedback. Interesting.

Here is how a typical session attempt would work on my end:

  1. I start Cubase.
  2. I initiate a conversation in either Google+ Hangouts or Facebook to facilitate my helper on the other end download and install the software, and to give them instructions on logging in, giving them a key, etc.
  3. End user attempts login and fails.
  4. I generate another code at my end and send it through either G+ or FB.

In any case, there is only a few moments between the time I generate the code and when the user tries logging in.

It may be worth noting, though, that the VST Connect plugin on my end - even with two monitors - is never visible when I open up the other browser window (Chrome) to send them a key. However, once I send them the key, the VST Connect plugin doesn’t show that I’ve been logged off. By all appearances, I am still on line with the Steinberg server.

Which, I guess begs the question, how do other people communicate the key to a partner, perhaps on the other side of the planet, other than by telephone or text message? Doesn’t something like FB chat or Google+ chat seem to be a natural go-to for most people?

FWIW, my sessions with Ali and my Sister were done with Facebook chat, so the log is saved. I have itemized these attempts (Eastern Standard Time at my end, near Toronto, Canada) below. My friend Dave (who was the one who actually got in, but got the sample rate errors) and my mom (whose attempts look just like the ones below) were attempted via Google+ chat. Unfortunately, those did not get logged. In any case, maybe these logs from my end could be helpful.

My friend, Ali, running XP. (second day of trying) - Aug 19

monday 21:17 - ali - 16782 38953 - studio key ##### ##### is not logged in
monday 21:22 - ali - 29790 7667 - studio key not logged in

My sister, Deanna, running Win 7. - Aug 20

tuesday 21:32 - deanna - 31718 43126 - Server not responding (deanna side)
tuesday 21:37 - deanna - 31845 77898 - ‘Studio with Key 31845 77898 is not logged in!’
tuesday 21:40 deanna and I both shut down and restarted computers
tuesday 21:49 - no code generated on my side - server not responding (my side)
tuesday 21:49 - deanna - 69265 63873 - Server not responding (deanna side)
tuesday 21:50 - deanna - 82223 53080 - Server not responding again (82223 53080)

^ for the latest one, I didn’t clarify whether it was, in fact, a “server not responding” error if that was just how she put it, but was really a “not logged” in error. I find it unlikely that a server not responding error would generate the key back on her end, would it?

Maybe I’ll try with my sister or my mom again and send them the code via text message.

Thanks for your ongoing assistance. It is appreciated.



Just tried with my mom again, running snow leopard 10.6.8. I had neither G+ nor FB (actually, no internet at all running) and gave her the key over the phone.

2:19pm - “studio 70478 65554 not logged in” error.