VST instruments wont record as midi track

Hi, Im completely new to cubase and I’ve recently purchased Cubase 8.5 pro and installed it onto my imac.
I wanted to plat around with the preinstalled VST Instruments so I followed a video on youtube on how to add VST instrument tracks and then choose the instruments and record. I selected Halion and chose something basic (Piano) i armed the track for recording and used the virtual keyboard embedded into halion and then preceded to record. when i pressed stop nothing recorded. I am getting the blue meter bar when i press a not but its not actually recording any midi information from the VST instrument. What am i doing wrong. I would like to note that at this stage i dont have an external midi keyboard i am just using the virtual keyboard.
I got stuck on this all afternoon and then gave up !
Any help greatly appreciated

Hi.

You’re doing nothing wrong.
It’s like that by design. You can’t record from instruments internal keyboard.

If you have no midi keyboard you can use the computer keyboard. Press Alt+K to enable virtual keyboard.
Then use the qwerty keyboard. These notes will get recorded.

Unfortunately, you can not record by just pressing with the mouse on the Instrument’s keyboard.

You need a midi controller or, as was mentioned, you can use the computer keyboard. I find that only marginally useful.

You can use step entry mode, but it will take a little time to get comfortable using it. Best solution, imho, is to get yourself whatever kind of basic MIDI controller you can afford. Good luck.

export the track…