VST live is not saving manual volume changes at VST instruments

Dear VST LIVE team,

I prepared a project file which I want to use for the new year 2024 for my band / gigs. All songs are successfully migrated, only the final volume config for each song need to be done :-).

Unfortunately I identified an issue with my current project file so that I am able to change volume settings for VST instruments via manual step.But it seems to be impossible that VST LIVE is not saving this volume config:

Step 1: Open VST instrument and change volume

Step 2: Saving project file (and hopefully volume chages at VST instrument)

Step 3: Switch to previous song to check if changed volume was successfully saved.

Step 4: Switch back to song which changed volume

Result: VST live was not saving the changed volume setting in the vst instrument.

Please can you help me what might be the background?
I checked the configuration parameters but what not able to identify a relevant parameter.

I was creating a complete test project file and in this project file I was able to change and save volume settings of VST instruments.

Therefor this issue only exists in my current project file for my band. I hope that this project file is not corrupt ;-).

It would be great if you please could help me to find the root cause.

Thanks in advance for your support.

Kind regards


… are you running the latest version, 1.4.11? I’ve re-checked and I have no problems. Ah, hold on. Now I see.

The MIDI-Volume of your Layer has 94. This value is sent to the connected HALion 7 instance. And this should be HALion 7 volume for it.

Now, if you change the Volume directly in HALION, like you did here


… the MIDI Volume in the Layer does not know anything about it. The Layer MIDI Volume is 94. When you Save it or select another song and re-select the “Sam old wearn” song, the MIDI Volume 94 will be send to HALion. And this will result in our starting value.

There are two options now

  1. Always use the Layer MIDI Volume Fader to control the HALion Volume
  2. Disable the Layer MIDI Volume and control the volume directly in HALion

For point 2, just move the Volume back to 0 (left) or enter “NOT SET” to the Volume Display

Now the layers stops to control the HAlion slot volume.

See you,

PS : Please be sure that you have installed 1.4.11

@musicullum pointed out to me that point 2 is wrong. Only “NOT SET” will not control the Volume of HALion. Just ctrl+click to the fader or enter “NOT SET” to the Volume Display.

See you,

That’s right. This is a tricky issue, that can easily lead to confusion. This is why the default setting for Layer (and MIDI Track) volume is “NOT SET”, which simply means that no MIDI message is sent (same for Pan btw). Otherwise you may run into problems when other processes (such as the plugin itself) fight for setting volume and/or pan.

Thanks Musicullum + Michael for your fast and helpful feedback. I will try to do the volume control within VST live and not in the VST instrument because this is to tricky. With VST live I can do the change maybe also via touch screen. I will try figure out the best way for me. Thanks again :slight_smile: