VST performance goes to 100% with every VST

Hi all,

I just searched the forum and google about my problem and haven’t found a solution (yet).
My problem is as following:
When i open a VST and press a key on my keyboard, the sound starts cracking.
When i open a second VST, the sounds starts cracking and stuttering even harder.

The meter of the VST Performance shoots to 50% with 1 VST, even when the sound isn’t played.
When i added a second VST, it goes up to 100%.
This is with every VST i have, such as Native Instruments Massive, Reaktor, Kontakt and with Cakewalk Z3ta+ 2, reFX Vanguard etc. Most of the VST’s are 64-bit, but some are 32-bit but it doesn’t make a difference.

I tried to increase the ASIO/wdm buffer size of my soundcard. It was on 256 samples and i increased it to it’s max, 4096 samples. But this also didn’t make a difference, whatever the amount of samples i choose.
The sample rate is at 96Khz, and the check box of “enable asio direct monitoring” is checked.

A few topics stated it was the hardware of the DAW, so i checked the CPU and memory load.
All the cores of my processor stays at 10-13% usage, and my memory doesn’t get above 2,5Ghz memory usage with 1 or 2 VST’s. When I open an old project, with lots of VST’s (around 30) the ASIO meter is flipping out and the sound is cracking and stuttering as a mad men! But the CPU usage stays around 30% and memory is at 5Gb.
Restarting my computer didn’t fix the problem.

Here are my specs of my DAW and it’s attributes:
Processor: AMD Phenom II X6 1090t (6-core processor @ 3,2Ghz)
Memory: 16Gb Corsair Vengeance DDR3 @ 1600Mhz
HDD: OCZ Vertex SSD 128Gb SATA-600
Soundcard: M-Audio Fast Track Ultra (with the latest driver)
OS: Windows 7 Pro 64-bit (with the latest updates)
DAW software: Cubase Artist 6.5.2 (re-installed, but didn’t make a difference)
Keys: M-Audio Keystation Mini 32

I have no idea how to solve this problem. If anyone has a suggestion, please let me know.
I can make a few screenshots, but I don’t know if it helps much…

Hi

Had the same problem when I set the buffer size to its maximum (in my case 2048), it worked OK when I used 1024. No idea why.

In other cases, I can solve the problem with “Save” and then “Revert”, I guess it is the same as a restart, but much faster :slight_smile:

You did select the M-Audio ASIO driver of your card in Cubase?
Any specific reason you are working on 96Khz. Is the behaviour the same at 44.1Khz?

Thanks for the reply!

@Egebjerg
I changed the buffer to 2048 and 1024 but it stays the same.
I re-installed the driver but still, it makes no difference.

@niles
Yes, my M-audio is the primary selected driver.
I was working on 96Khz because… it was the highest :smiley:
I thought; higher is better!
I changed it to 48 and then 44.1Khz but still there is no change.

I noticed when i played a few notes, the Midi Out Activity bar keeps showing a green bar.
But there is no key touched on my keyboard or anyhting else.
Also, with a few VST’s, the sound keeps echo-ing. When i mute the VST, the Midi Out Activity stops.
When i un-mute the VST, the Midi Out Activity start showing that green bar again.

I added a screenshot. I put an red circle around the green bar.
screen.png

Possible midi loop, have you got midi in and out connected?

Don’t really know what you mean :blush:
When I go to Device Setup I have;
Generic Remote: Midi input and output are note connected
Mackie Control: Midi input and output connected to iPad (for control with AC-7 Core)
Quick Controls: Midi input is connected to All Midi Inputs, Midi output is not connected

I have put a screenshot with this post.
screen2.png

Why is the buffer size so high? 128 to 64 usually does the trick. Theoretically the lower the more clicks but in modern times that has been at about 128 or 64.
Some soundcards do report strangeness at very high latencies such as you say you use so try reducing. 1024 is way over the top unless you’re still using Windows 98 or something.
New soundcard driver? Look on it’s website.

48 or 96 kHz are really meant if you write for games etc. 44.1 should do fine if you just work on music. Some say that it sounds better and reverb tails are smoother at, say, 88 but in general everyday use it’s arguable. You do get bigger files too.

Generic Remote: Midi input and output are > note > connected

Do you mean NOT connected?

iPad? Used as a controller?
I think maybe you have over-reached yourself on the connections. Can’t be sure but that seems a fairly, though not unrealistic, unusual set of input controls there. Most users have a simple midi keyboard in.
It’s a pain but you may have to spend a day or so really taking the system to task to see if what you think is connected really is.
Anyone with the same setup as Defect? Chime in please.

Could it be Automap or any other software included in the “In All Midi” is sending and receiving MIDI data.
Maybe try to untick all the ports in “In All Midi” except your master keyboard.

Why is the buffer size so high?

Well, I use Native Instruments Reaktor alot, because i can tweak almost everything i want.
The problem is that Reaktor is a heavy program.
On my laptop (Vaio) I could only use 3 Reaktor’s, otherwise I had the same problem as i have now.
So that’s why I have the buffer high.

The standard value is 256, but i will lower it to 128. I’ll let you know if it works.

48 or 96 kHz are really meant if you write for games etc. 44.1 should do fine if you just work on music.

With my set-up i really can hear a difference between 48 or 96Khz with, mostly, synths.
I can hear a bit more details of the sound, but when I save the project as MP3, the higher end of the sound is cut off.
Mostly I save my projects as .wav, because it has a higher bitrate. Counterside is that it’s big. Every song is around 200Mb. But this way I can really enjoy the music and sounds i make. And what others create :wink:

Generic Remote: Midi input and output are note connected

Sorry, i meant not :smiley: typed a bit to fast.

iPad? Used as a controller?

Yes, well, it’s something that’s just fun, to see what you can do with it in combination with Cubase.
It has the same features as my Korg Nano Control with a bit more.
I added a screenshot so you can see what it can do.
It’s fun if you have an iPad, but you shouldn’t buy one for this app. A bit too pricey :smiley:
And the program is a bit buggy at the moment, but i haven’t connected it for a week now.

Could it be Automap or any other software included in the “In All Midi” is sending and receiving MIDI data.
Maybe try to untick all the ports in “In All Midi” except your master keyboard.

I haven’t had any problems with Automap, it’s a pretty stable program, but i’m giving it a try.
Also, i’m going to disconnect a few controllers.
The only 2 things i’m going to connect are 2 Midi keyboards: M-Audio Keystation mini 32 and the Novation Nocturn 25. I work with those together for about a year now, and have never had any problems with them, so i think it’s safe to keep them connected. If i still have the same problem, i will disconnect the Nocturn 25.
AC7Core.jpg

Well, I use Native Instruments Reaktor alot, because i can tweak almost everything i want.
The problem is that Reaktor is a heavy program.
On my laptop (Vaio) I could only use 3 Reaktor’s, otherwise I had the same problem as i have now.
So that’s why I have the buffer high.

Buffer size shouldn’t make a difference. Ram and drives (more of them) have more bearing. Your drive may also be slow if on laptop at 5400rpm so more ram gets your samples in the computer and not streaming off disk. You could get an external disk but they’re expensive right now although coming down.

Buffer affects midi flow through the system to the VSTs but if the VST is a sampler it’s the samples on disk that slow things down not the set buffer rate.
The VST performance reflects the ram usage and the disk usage. You should see two lines. I’ll check later to see that’s not been changed as I haven’t looked recently. :sunglasses:

I doubt it’s the disk because Vanguard and Reaktor are not sampleplayer VSTi’s and they cause trouble too.

That may well be the unusually high buffer rate causing that.

The HDD couldn’t be the problem.
In both my PC and laptop i’ve got a 128Gb SSD.

I started Reaktor in stand-alone mode, to test what it would do without Cubase, and in this mode it doesn’t give any cracks or stutter. I went all-out with the options in Reaktor to stress my pc to the max, but whatever i did, there were no cracks or stutter.

I think i’m going to do the following;

  • Re-install the M-audio driver
  • Remove all installed VST’s and Cubase from my pc
  • Re-install Cubase Artist 6.0.0
  • Re-install a few VST’s (probably everything from Komplete 7)
  • Only connect a small Midi keyboard

When I got Cubase Artist 6 I had no problems with any VST or cracks or stutters.
2 weeks after I got the 6.5.2 update these problems occured.
Maybe that has something to do with it?

It could take a while before i reply on this post, because installing Komplete 7 takes quite a while :cry:

I would start there. Your MIDI in meter clearly states there is a lot of activity (loop?).
Maybe rename your Cubase preference folder and see if the behaviour is different.

I installed everything fresh and only connected 2 midi devices and… it works!
Buffersize is now 1024 and no more cracking and stuttering.

I noticed that the VST from Cakewalk (Z3ta 2) uses an insane amount of buffer.

But my problem is solved!
Thanks everybody for the helpfull comments and idea’s!