VST plugin (Opus) does not listen to MIDI signal

Hi!
Grateful for any help. I am new to cubase, and have tried for days to make my MIDI usb-kontroller (Komplete A-series) to work in cubase. I have tried googleing but everything I have tried so far does not produce any results. I am trying to get my Opus vst plugin to listen to signals from the midi-keyboard, but I cant make it work. Hitting the keyboard will produce a jumping blue bar in cubase, but Opus does not register any input. I have noticed in the studio setup that the MIDI remote controller is set to “N”. I cant change that as far as I can tell. Is that the reason? I have atteched 1 screenshots. Thank you!

Hello there,

I am tired and am about to tuck in so I am going to only pass some quick thoughts onto the next person that might read this and will try to help you:

  1. Kontroller is defined as MIDI Remote device, possibly usage blocked by remote script
  2. Audio output is not set up correctly or not all

Sorry, man, you deserve a little bit of a longer explanation what that all means and what to do about it. I am hoping for the next user to help you.

Thanks! I dont quite understand, but I am grateful for any information. I Will do my best to google myself but I am of course very grateful for any extra information in this thread.

When you say Opus does not register any input do you mean that other VSTs work, or is this the case with every virtual instrument?

Do you get audio out of Cubase at all, e.g. playing audio files?

I have only tried opus so far. I will check as soon as I get home if I can play a normal audio file, but still I think as far as I can tell that the main problem is that opus isnt och even registrating a key press in the virtual keyboard in the vst UI.

Sorry for the poor grammar, Im writing on a mobile without english keyboard😌

Seems like you’ve set is up as a MIDI Remote Controller, so if it’s not correctly configured it can block all MIDI messages from going to VST instruments.

Quickest way to get it working would probably be to remove the keyboard from the MIDI Remote tab, at least until you figure out the correct set-up.

You probably also want to make sure you’re running it in MIDI mode, instead of DAW mode if your keyboard version has one. I don’t use a NI controller.

Others are free to chip in with any more precise help/info.

Okay I will try this, thank you🙏

Sadly it did not work… I removed the controller from MIDI remote, and after this “usage” is empty in the midi port setup tab. I have to do this (remove the MIDI remote controller) every time I start cubase for some reason though.

Regardless I remember that some time ago I did manage to get the keyboard to work in cubase, so I opened an old project, and I could not get any sound out of it now, much less get the VST to work (so in reply to a previous question from Paka, the outgoing sound is not working either). I remember that I had some issues with my headphones, and got some error messages in cubase obout my audio output. Is there any way to completely reset cubase, wipe it completely, from the computer? maybe that will work?

I am fairly close to giving up now, having spent so much time on this, but I appriciate all the help I have received so far!

Also I have checked and my keyboard is in MIDI mode.

What do the following configurations look like in your Cubase?

Studio > Studio Setup > Generic Low Latency ASIO Driver
Studio > Audio Connections > Output

Hi, like so:


The Stereo Out in Audio Connections isn’t expanded, but I guess it’s Speakers 1 and 2 there for Left and Right, and you are trying to listen through your computer’s built-in speakers (or headphones, that are just named as speakers in Windows sound settings)?

Hi! That is correct. I swap between the built in speakers and headphones connected via the headphone jack. I did try and connect my bluetooth headphones at one point, and I think that is when it stopped working last time (but I did not connect the problems with my speakers/headphones and this new problem with the keyboard input until now)

In-built audio ports can be bothersome to setup but it looks like the settings are correct.

So just to double check.

  1. Create an audio track in Cubase and drop any e.g. mp3 or wav audio file there and hit play. Do you get sound?
  2. Create a MIDI track, record enable if it isn’t by default and try to record your MIDI keyboard. Does Cubase record MIDI data? Try removing your MIDI Remote: Deleting Unused MIDI Controller Scripts

Thanks! I will try this tonight as soon as my kids are asleep. Will post an update in a few hours :slightly_smiling_face:

One more go at it!

  1. No no sound if I drag an audio file in to a audio track.
  2. I did this, and also did shift alt ctrl during startup and completely reset cubase.
    Some progress, because I can now record a MIDI track and the keyboard respond normally in cubase, however I still cant use the keyboard in opus, so I guess Opus still does not recive any data from the keyboard. Also, even though I can record a midi-track I still dont get any sound.

Would it help to uninstall cubase and delete all local files? Starting to get slightly desperate.

Try checking:
Studio Setup > Generic Low Latency ASIO Driver > Control Panel

See that the Realtek Speakers are checkmarked in the Output Ports.

If that’s already the case, I’m pretty much out of ideas. Hope someone else can be of help.

Though, you can also try ASIO4ALL (https://asio4all.org/) as an alternative driver that people have reported works pretty well for the integrated Realtek chips.

It is possible that your Realtek soundchip is occupied by another software and therefore Cubase can’t deliver any sound to it.
Cubase uses an alternative audio system to Windows’ own. If the driver of an audio interface is not written to accommodate dual access (and Realtek’s driver usually isn’t as Realtek does not care about the music production clientel, too small a piece of the cake) it cannot serve Windows and Cubase at the same time.
Make sure that nothing else is running on your computer before you start Cubase.

Does that help?

Thanks Paka and Johnny
I hade to give up for the day and go to bed, but I will give it another go after work today. The speakers are checkmarked in the output ports. I dont think I was running anything else yesterday, but I will check again when I get home. I also uninstalled Cubase completely so first step will be to reinstall again.

(I did try and set up everything in another DAW and everything worked within 5 minutes. I much rather use Cubase for its functionality though).

I downloaded the custom drivers Paka wrote about and it worked! So big thanks for that advice. I have just one problem left, I realize it might be outside the scope of this forum (and this thread) but the ASIO4ALL website is quite hopeless so I just want to ask:

I cant find a way to get the sound to my headphones. However much I try it goes to my built in laptop speakers (still an improvement though over nothing). There are several options in the ASIO4All settings tab but nothing works exept for the first option (Realtek audio with sub-option 1 and 3 selected). My headphones are bluetooth headphones, but I have tried both using bluetooth and connecting via the standard headphone cable.

For the standard headphone with cable there might be a setting in the Realtek Audio Console app ((should be installed on your computer):


It is under “Advanced Device Settings”. Just try if switchting the Playback Device option changes anything.

Bluetooth headphones are an independent audio device. I assume they need to be activated before starting Cubase. Then they should be listed in the ASIO4All control panel, that is visible on your screenshot.