VST quick controls weird problem

I have set VST Quick Controls up and they are working fine with some VSTs as soon as I create a new instrument track e.g. Kontakt, Halion Sonic but with other instruments they don’t work until I add an instrument track of a working instrument and then the ones that didn’t work start working. Has anyone had this experience and do you know what I am doing wrong or a setting that needs changing? Thanks in anticipation.


Which instrument exactly are you talking about, please?

Could you write step by step instructions, please?

Hi Martin, Thanks for your reply. I use Cubase 11 Pro and a Nektar LX88+ midi controller.

The process is as follows

Open Cubase,
create an empty project
load Groove Agent –
LX88 faders do not have any effect on the VSTi in the right zone or on its GUI
Load Halion Sonic SE
LX88 faders control the VSTi in the right zone when the Halion track is in focus
LX88 faders control the VSTi in the right zone when the Groove Agent track is in focus. The faders also work on the GUI controls in both.

New test – remove all tracks
Load BBC SO VSTi (Spitfire Audio)
LX88 faders do not have any effect on the VSTi in the right zone or on its GUI
Load Halion Sonic SE
LX88 faders control the VSTi in the right zone when the Halion track is in focus
LX88 faders control the VSTi in the right zone when the BBC SO track is in focus.
The faders also work on the GUI controls in both.
I also noted that if I delete the Halion track the other track still works.

In my original test a few days ago I tried various VSTis. Some worked first time and others didn’t until I loaded a working VSTi.

Ones that worked first time were: Halion Sonic SE, Kontakt, Spitfire LABS, Analogue Lab, Cinematic Pads, Aperture 3 The stack, Retrologue.
Ones that didn’t work until a working VSTi was loaded were: Korg M1, BBC SO, Padshop 2, Groove Agent, Vital Synth. I have not tried any other VSTis yet.

I hope this information is clear. Please let me know if you have any ideas or need more info.

Thanks and regards, Chris Rollason


Sorry, I cannot reproduce it here.

The VST Quick Controls are moving in the Right Zone to me.

Do you use VST Quick Controls or Track Quick Controls, please? Even though it works in both cases (VST Quick Controls and Track Quick Controls) for me.

Helo Martin,
I do use both vst and track quick controls. The track QCs seem to work fine.
Today I have another strange problem. I set up Kontakt instrument track with one of the factory presets. Usually the rack instrument knobs show the name of the parameter they control but this time it showed no assignment until I set up a Retrologue track. Both tracks then showed the knob assignments. In Write mode the Kontakt track recorded automation. I switched off Write mode on the Kontakt track.
I recorded some midi on the Retrologue track. I then recorded some automation on the Retrologue track. I switched off Write mode.
I then set up a Spitfire Audio Cinematic pads track. With Write mode on, when I tried to record automation on that track, as soon as I adjusted a vst control the focus switched to the Retrologue track. No automation was recorded on the Retrologue track. I switched back to the Cinematic pads track and with Write still enabled tried again but as soon as a vst control was moved the focus switched back to the Retrologue track.
I am thinking that maybe I have some settings wrong somewhere in Cubase that I have either unwittingly changed of have not set right. Can you advise what settings I should check please as this is very strange and seems to do different things on different days. One track works ok and then when I add other tracks things get weird.
Regards, Chris Rollason


Do you use any other Remote Device by any chance? Like Mackie Control or Generic Remote?

Nektar have their own mapping extensions, that could be that interfering - I believe that hooks into the Mackie style/remote control (if their Cubase integration is installed) and ‘automaps’ to devices.

Hi Martin, I don’t use any other external controller but I do have the Nektar / Cubase integration software loaded. I will try uninstalling it.

Hi skijumptoes, thanks for your comment. I haven’t used this forum before but I guess you can see my reply to Martin. I will see what happens and report back

I tried deleting the Nektar daw integration but then I couldn’t get the transport controls to work and didn’t want to change lots of settings so re-installed it. I have discovered that the focus always jumps to the latest track that was added regardless of which instrument is on the track except for Groove Agent. The focus didn’t jump to the Groove Agent track. I also noted that if I saved and closed the project and then reopened it everything worked fine until I added another instrument track. Just saving the project without closing and reopening it did not solve the problem. I could imagine there being a setting somewhere that makes it do this. Any thoughts?

Which mode on the LX are you using for smart controls? (Mixer, Instrument, Preset I think are the different modes?) You need to use the preset mode otherwise the other modes will be part of the integration and not necessarily focusing on your current track, and will already be auto-mapped to other parameters.

Preset mode should just be sending plain MIDI that you can customise and use yourself.

So if you’re not already, swap to preset mode and learn those controls to the quick controls.

If they don’t learn, it’s possible they may send messages on a different port (vs mixer/inst) you have selected, I can’t remember how the Impact’s are setup now, but i’m sure there’s ‘DAW’ port and a standard port(?).

I use the preset mode and have set the knobs to track QCs and the faders to VST QCs. I have also set the track QCs to the volume, pan, EQ setting. Incidentally, is there a way to make that setting a default as I have to set it individually for each track and then next time I use that VST I have to set it again?
I have had a couple of Cubase crashes recently and wondered if the crash dumps would reveal anything useful if I sent them to Steinberg support.
I have also decided to uninstall Cubase, do all the Windows 11 updates (my music pc is only on-line for updates and otherwise is an off-line machine) and then re-instal Cubase. I am not convinced this will fix anything but it seems like the first thing any support might suggest.

You can save QC presets in that left side section and reload them, but you need to use a mouse which is a pain for me.

You can also setup track presets with the instrument and QC’s setup and load a track preset with QC’s intact, instead of loading the instrument on it’s own. A nice workflow if it works for you.

You can also use the Remote Control Editor (Not generic remote) to move around the ‘default’ first 8 parameters - even though this is for Mackie/MCU style controllers it seems to determine QC’s in my experience.

What i’d personally do though, is to not use the preset Quick Control maps in Studio Setup, but create your own generic remote and create them within a single mapping entry.

From there you can specifically assign controls to the selected tracks controls such as volume, pan. Or the selected tracks instance of an instrument (such as retrologue etc.) - so it’s hard assigned ‘per instrument’.

Then, as an additional step you can setup generic remote pages in that same screen, and set aside two buttons on your controller to go up and down those pages. That way, using only 8 rotaries you could swap between them being Track QC’s, VST QC’s and specific mappings for specific instruments - i.e. I have 4 pages for Retrologue - Filter page, Osc page, Env Page, LFO page.

I don’t know how much that makes sense, or if it appeals to you? But that’s become my most preferred method of mapping as you can have many pages, and also float a small dialog box on screen that shows which page you’re currently on.

Thanks, I will give this a go but not much experience with the RCE. Do I need to disconnect the LX88 from the Quick Controls before making settings in the RCE? Do you know of any videos which give good step by step instructions? I have watched a few on YouTube but not found one that gives the whole process. Maybe I will have to pick bits of info from a number of videos which has been useful in the past for other stuff.

You just need to set the MIDI ports to none in the Quick Controls.

And it’s very simple, you basically create a new generic remote and add a number of hardware controls that you have in the top section. Start with 8 faders or knobs and name them something each unique like Knob1…2…3…4 etc.

Then turn learn on and highlight each control and turn that hardware control and you’ll see the CC and channel # update. Turn learn off and the hardware is mapped. (Probably what you already done with the quick controls) - I usually select the first, turn the control and then cursor down on my keyboard, turn the control, cursor down… rinse, repeat.

Then in the lower section, make sure you’re in a project with at least one track that has quick controls, and assign the different VST Quick controls or Track Quick Controls as follows:-

(VST Mixer | Selected | Quick Control 1…2… etc)
(VST Quick Controls | Device | Quick 1…2… etc.)

Note: In the screenshot is my Komplete Kontrol keyboard and so i try to keep it simple:-
“KK P1 R1” = Komplete Kontrol Page 1 Rotary 1
“KK P1 R2” = Komplete Kontrol Page 1 Rotary 2
“KK P2 B4” = Komplete Kontrol Page 2 Button 4 etc.

If you want to get fancy you can also create pages at the side like this:-

And then you can assign buttons to go up or down those pages (Increment/Decrement), or buttons to specifically go to a page directly:-

In addition to that you can float a dialog box which shows the page you’re on for that generic remote option:-

Beyond quick controls It’s also entirely possible to hard map directly to an instruments parameters for example, i.e. like this for retrologue:-
You first make sure you have the instrument track selected, then in the mapping:-
You go VST Mixer | Selected | VSTi Parameter

Using the pages you could create a page for filters, oscillators etc. if you so wanted - really depends on what floats your boat… You just have to manually have the correct page selected - hence why floating the generic remote dialog is handy.

If there’s other DAW commands you want to trigger then go in the key commands list in Cubase and search for it, and depending on what section it’s in that’s how you will find it in the Generic Remote too - This is where it starts to become a little more fiddly.

Hope that helps, it’s a lot to take in I know! Hopefully this will be a lot better in Cubase 12 if you plan to update in future. :slight_smile:

1 Like

Thanks for taking the time to explain all this, I really appreciate your help.
I will upgrade to Cubase 12 if the price is ok. In the meantime I will try following the steps you detailed. I have a couple of questions before I try it: if the midi input is set to not connected how does Cubase communicate with the controller and also should I uninstall the Nektar / Cubase daw integration and if so how do I get the transport controls to work.
Sorry if these are all dumb questions and the answer is obvious.

You’ll only be disconnecting from the default quick control entries. As you’re creating your own generic remote you will have the input set in there instead - those in/out ports are per Remote Device entry - not global.

It depends if you’d make use of the mixer mode and such like, you don’t need to uninstall it. You can just set the ports to be ‘Not Connected’ in the Nektar remote device to run without it.

If you did decide to not use the integration, to get the transport buttons to work, you just learn those buttons and map them to the DAW functions in your custom Generic Remote.

i.e. for transport controls you pick ‘Transport’, Then ‘Device’, and you’ll have loads of options as to what each button does:-

For example - I don’t use f.fwd or rewind buttons so I prefer to set them to next or prev marker, and then have rotary wheel which I can turn to ‘jog’ or scrub through the timeline.

1 Like

That’s great thanks, I will give all this go. I do use the mixer mode but I can see that the generic alternatives might be as good if not better. It will probably take me a few days to get to grips with it as I don’t do music stuff everyday but I am looking forward to learning more. Once again, thanks for your help.

Well I have learned a bit about setting up generic remote control. It was quite a tedious process, unless there are shortcuts I don’t know, but I did get it working. However, when I then tested it out on the problem of the focus jumping, from the track I wanted to record automation on, to the last loaded track the problem was still there. As the Nektar integration works well, especially in mixer mode, I decided to go back to using that. I have resigned myself to having to save, close and reopen the project when I come to record the automation as the problem does not occur then unless I add another track. Thanks for the advice and it has given me a better understanding of the remote control options and settings.

Oh that’s a shame it didn’t work out for you.

Just thinking, you’ve not got auto select enabled in the Nektar remote device settings have you?

That could lead tracks to jump around if you hit a fader on the last track, for example. Although I’m sure that the option didn’t actually enable or disable that feature last time I used it as I remember contacting Nektar about it.

Oh by the way, their support is excellent if you needed further clarification from them. Very personal and helpful.