VST Viewer window is "freezed"

When I open VST Viewer with an previous loaded pdf the window freezes. With freeze I mean, I cannot change the size of the window and I cannot scroll throug the pdf. Buttons and drop downs works. Also I dont see the addtional buttons right of the part name.

Hi @Falfango,

can you please give me a detailed description

  1. Start VL, New Project
  2. Select MODULES and add Module
  3. Load VST Viewer and open editor with “e” control
  4. Select “OPEN” to load PDF

What’s next?

Thank you,

I could not reproduce it with a new project. So I removed the original module and added the pdf again. Now it works as expected. What I remember creating the original module is: When I clicked “OPEN” the icon becomes selected but no pop up window appears. So I clicked it again and the icon becomes deselected but still no pop up. With the third click the file selection window comes up.

I could reproduce it now. Changing only the height of the viewer makes chaos to the window.

… we’ve found and fixed it. Thank you for pointing us to it.

… hm. Maybe it’s related to your PDF file? Because I cannot reproduce it. Can you reproduce it with every PDF file?


As I want to try it with a different pdf, I recognized, that it also happens before I load any pdf. So open the viewer with clicking on “e” and changing the height produce this. Changing width is ok.

I tried it on another pc (laptop). The interesting thing is, on the laptop I cannot change the height of the window and I see there now a footer with the logo at the left and “vstviewer” on the right. I dont see this footer on my desktop pc.

… are you running the latest 1.0.50 VST Viewer? You can download it here
… which VST Live are you running? We have released a new Pre-Release (1.1.53). You can download it here
… which windows Scaling are you using? 125%? 200%? 100%?

Thank you,

Yes. its 1.0.50

On the laptop the scaling is 100%
On the desktop the scaling is 175%

Nothing changed with 1.1.53

… I am trying my best to get reproduced. No chance :frowning: Do you have a chance to screen-capture your doing?
… and which display resolution are you running?


Resoultion ist 3840x2160

The integrated screen recorder of win 10 only records the vst live window but not that of vst viewer I add some screenshots of that.

After clicking on “e”

changing width

changing height

Hope this helps

One additional thing which may gave a hint.

I installed vst live (1.1.50) and vst viewer at the same time. I activated the license of vst live but I didn’t realize, that vst viewer needs a separate activation. I used vst live for few days without activation of vst viewer. The first time I want to use vst viewer, it tells me about the missing license. I activated it, not shure if vst live was running or not during activation. Maybe this could corrupted initial settings of vst viewer.

I tried to deinstall vstviewer. But it still shows up in the modules as available tool in a new project. Of course nothing happens when I clicked on “e”. Reinstalling of vstviewer did no change to the previous behavior.

… I’m lost. Let’s try to get this puzzle solved.

  1. Install VST Live 1.1.53
  2. Install VST Viewer 1.0.50

Checking the VST Viewer file at
C:\Program Files\Common FIles\VST3\Steinberg/vstviewer.vst3
It’s there, fine.

  1. Start VL, New Project
    3a. Checking version of VL with “Menu / About” → I see 1.1.53
  2. Select MODULES
  3. Add Module and load VST Viewer
  4. Pressing “e” to open the editor. Click to lower-right corner logo to see version number “1.0.50”
  5. Close VL

Uninstall VST Viewer with the Uninstaller of Windows.
Checking the VST Viewer file at
C:\Program Files\Common FIles\VST3\Steinberg/vstviewer.vst3
It’s NOT there, fine.

  1. Start VL, New Project, Select MODULES
  2. Try to Add “VST Viewer”. It’s not available.

What are you experience with such kind of description?


I did all the steps from 1 to 9 except 6, as I dont see the whole footer (incl logo). See the screenshot what happens

VST Viewer shows as available, even it is not installed anymore. And I even can select it.

… Ok. Please locate the following file …
C:\Users\YOURNAME\AppData\Roaming\Steinberg\VST Live_64\Vst3Plugins.xml
… and share it with me.

Thank you,

thanks vor your time and effort. Here it is
Vst3Plugins.xml (121.1 KB)

Can you please check
C:/Program Files/Common Files/VST3/Steinberg/!vstviewer (Automap).vst3
→ “Automap”? What’s that?

And I can see that one
C:/Program Files/Common Files/VST3/Steinberg/vstviewer.vst3
That’s the orignal viewer plugin

I guess you need to delete the files manually to get the viewer removed from your system.


Automap is part of the nocturn keyboard to configure the controllers for any vst instrument.


At your named path is only the C:/Program Files/Common Files/VST3/Steinberg/!vstviewer (Automap).vst3 but no C:/Program Files/Common Files/VST3/Steinberg/vstviewer.vst3

I removed the vstviewer (automate) manually and reinstalled vstviewer. Now it works as expected :slight_smile:

I dont know, why automap generates its own vst3-plugin copy of vstviewer, as it does this only for instruments normaly.

Thanks for your help. I really appreciated that!