VST Live 1.1.53 Pre-Release


it’s Friday again and a new Pre-Release 1.1.53 is online.

You can download it here . You also can find a Version History there. If you found new bugs or bugs which are not fixed, please create a new thread and title it with [1.1.53].

Thank you very much for your help,


Hi @Spork ,

Thank you for the update, downloaded and installed (14:00CET, Marc 4.).

  • New “actions” are (zoom to, markers to) welcome :slight_smile:

  • Can’t find, or not working jet: “- Store/Restore SampleRate for Projects”

  • Pencil drawin direction problem still exist, but I know its is easy to fix.

Have a nice day for all of you! F

…is only working for newly saved projects. You can load old projects, then save.
Then when loaded, it sets sample rate to the saved rate.

1 Like

Hi @musicullum !

Plz note, I still didn’t installed to my Mac, just using on the Windows11 “Live Laptop”, therefore some of theese problems are absolutely not existing on OSX. But i keep this laptop “clean”, no garbage and uneeded things are installed

…is only working for newly saved projects. You can load old projects, then save.
Then when loaded, it sets sample rate to the saved rate.

Great! confirming that working with USB/TB devices (Audient, UAD) great. VSTLive still not has power above onboard realtek (Cubase engine can force it to required sample rate), but the situation is much better now as it’s working with booth my external devices :slight_smile: Video is about: starting with UAD (unplugging), then Audient (unplugging), on-board Realtek remains last.

Spent some time for great new features, found some little things, maybe will help the pre-release:
Actions shortcuts… once I changed any Alt+[AnyKey] to something else, can’t set back to Alt+[AnyKey].

Marker selection to selected items (new action, using “P” key). Sometimes working correctly, at some songs, it isn’t:

Have a beautiful week to the team :slight_smile:

ASIO has a function setSampleRate, then we ask for getSampleRate. The Realtek is unofficial, will check if we can find the time to examine it but we follow standard ASIO procedures and here it works with pretty much everything. But good to hear that it works for you in general.

Indeed…fixed with the next version, thanks!

… at the moment it’s only working when you have selected MIDI/DMX events. Audio-selection is broken. But it is fixed now and ready for the next update.


1 Like

Nothing happened, looking fw to future fix.

Another tiny thing, honestly can’t decide if bug or feature. Adjusting event cue position can move event from its position:

… that’s a bug. We’ll fix it!


1 Like

… fixed and ready for the next update. Thank you!

1 Like

I managed to crash VST Live 11.53 - Here’s the setup:
6 audio tracks
1 signature track (4/4)
a very active tempo track
and a lyrics track.

When I play the song with the “Lyrics” page active, first I see the bar/beat indicator on the left side of the screen jumping around - kinda acts like it’s confused by the tempo track. Then, after it’s run for a while (about 50 bars), the app crashes. If I play the song with the “tracks” screen visible, it plays through without any issues.
This is very reproducible for me. Please let me know what all you would like me to provide to help you fix the issue. For starters, I’ve included the Cubase .cpr file and .vlsprj export files. Please let me know if you need media and I’ll send that to you as well.
Archive.zip (126.5 KB)


At First: thanks a lot for your frequent Updates. We Really appreciate your efforts!

Any News/ Timeline for learn midi/dmx?

Regarding this Version:

Maybe its just us, but it seems that the (global) Audio stacks went gone with 1.1.53

Not only they cant be Seen, they cant even be heard anymore (silent).

Had to Revert back to 1.1.50 to Make VST live usable again for live rehearsels.

What do you mean by that? Is it that you cannot create those, or they don’t appear when loading a project?

Our global Audio stacks no longer appear (visibly) and are silent. New global Audio stacks cant be added too.

The global Audio stacks worked without Problems in prior Versions and were already present in the project.

We had to revert back to Older Version of vst live to get the project / Audio Stacks working again/as before.

Hi ericwentz,

… it’s fixed now.

… but I cannot reproduce that one. Can you please have a look at
Can you find a crashlog? And can you share it with us?

Thank you,

can’t be added?
Ok, so I took the time and re-installed version 1.1.50, new project, add Global Part (“GP”), edit Layer, add Stack to GP, insert Amp Rack and save. Then loaded into 1.1.53 and all is there and all is good. I can also add GP to a new project and apply the same routine.
You may send me a .vlpr file which is supposed to hold Stack data in a GP so we can check to see if it was saved correctly or if we can load it?

@ericwentz @musicullum @noiprocks

Hi Guys!
-Tested the global Audio stacks is ok at my setup.
I know the team does their best. But I agree with stability issues. As I’m starting to use intensively, I’m facing with “freeze / not responding” app issues.
Just an example: Opening my project, metronome on, scroll FW … met off, clicking to timeline… And gameover.
Opening again, clicking here and there… And paffff, gameover.
Computer restart
Again… hang…
Than did everithing slowly, careful… app was working great.
Meanwhile sometimes it runs for hours without any freezing.
So with theese instability issues, I’m only brave enough to use at rehearsals/practicing.

Thanks for the tip with location to CrashDumps, Unfortunatelly no dump generated by VSTLive. (Maybe I’m closing too quick via TaskManager as I see the white death / hanging with crolling mouse when screen faded to white).

vst-live-crash.txt.zip (13.1 KB)
Attached is a copy of the “Problem Report” as created from my Mac.
One other thing that I noticed in the lyrics page was multiple black vertical bars in the “bar-beat” column of the display. Here’s a link to a quicktime screen capture Dropbox - Screen Recording 2023-03-09 at 9.02.14 AM.mov.zip - Simplify your life. (Smells like a memory leak to me :slight_smile: ) - This screen capture ends at about bar 50 of the song - which is also where Live crashed. Please let me know what else I can do to help you diagnose this issue.

Hope you can read the dropbox link.

That is fixed with the next version.
Thanks for the crash report, we will check it!

A couple more things on the crash:

  1. Playback started with the lyrics page active
  2. After about 50 bars, the audio cut out
  3. I stopped playback and clicked on the “Tracks” tab - immediate crash.
  4. The song doesn’t seem to matter - it just needs to have the lyrics track populated.