VST Virtual Instruments and Multiple Outs

I think there may be a problem with how Cubase 12 Pro handles Multi Output Virtual Instruments such as ToonTrack Superior Drummer 3 etc.

I recently fired up cubase 12 pro and loaded up superior drummer. I loaded up the drumkit I wanted, and found a groove from the SD browser that I wanted to use, and dragged it to the arrangement page. All good.

I set up the SD kit to output each drum on its own channel.
I then opened up the VST Instrument window and activated outputs.
The VST Instruments panel gives the impression that I am able to activate MONO outputs.

However, Superior Drummer doesn’t appear to give me the option from within to select MONO OUTPUT Channels for each individual mic feed / drum.

When the MONO outputs are selected and activated from within VST Instrument panel
Several Corresponding STEREO channels appear in the mix window

However, I personally prefer to have various drums on mono tracks
as this makes it easier to place using the panning feature.

This is how an analogue mix is usually set up, mono channels for mono sources, stereo channels for stereo sources. I wonder why this way of working has been overlooked.

At the moment, I am not sure if it is Steinberg or Toontrack that need to address this.
Perhaps I should fire up some of my other multichannel virtual plug ins.
Any one have any ideas about this?

I do the same thing using BFD3 instead of SD and it works as expected. Mono within BFD3 appears on Mono Outputs & the Stereo on Stereo. I configured this in my Template some years ago, so not sure, but I think it might have been possible to also access the Left & Right sides of a Stereo signal in Mono too.

As long as the signal itself is Mono it shouldn’t matter for panning placement if the channel itself is Mono or Stereo. There are multiple threads on that topic. Like many folks here I’ve switched to always using Stereo Tracks for both Stereo & Mono content - it really simplifies routing. The only reason I use the Mono outputs in BFD3 is because I set it up that way a long time back and am too lazy to change it. But if I were configuring it now I’d use all Stereo.

I think this is because a hardware Channel is a limited resource, you only have X of them available. But in a DAW you can have as many Channels as you and your computing capacity can manage.

raino is right. The old mono channel thing is because of limitations of hardware mixers.
Put it on stereo and, if the panner doesn’t work for you, try switching to the Stereo Combined Panner.


SD3 will do mono in Cubase. Look in sd3 settings and you will see a tick box specific to Cubase

Hello Folks
Thanks for your replies and sure, I take your points.

Just to clarify, I did find a tick box setting from within SD3 which gave the option to select 32 mono outputs. In the instance that I was getting only stereo outputs, that setting was ticked.

I tried a few different setups, and realise that the problem appears to occur when I have
a particular ez drummer expansion loaded. Perhaps there’s a compatibility problem between the two (ez drummer 2 and SD3). Which would be strange, as both plug ins are made by toontrack. But there ya go. Perhaps the Stereo combined panner may be a work around.

Will have to see how it feels / sounds in practice. Thanks again for your help.