VST2 not showing up

None of the Steinberg VST2 instruments are showing up - only the VST3 ones.

How do I fix this?

Thanks

Did you check in plugin manager…do you have a customised plugin collection in plugin manager?
What vst2 plugin paths do you have listed in PIM?

No, just default, all

The folders are:

C:\Program Files\Common Files\Steinberg\VST2
C:\Program Files\Common Files\VST2
C:\Program Files\Steinberg\Vstplugins
C:\Program Files\Vstplugins
C:\Program Files\Steinberg\Cubase 8\VST Sound
C:\Program Files\Common Files\Steinberg\Shared Components

If you use the add a vst2 plugin path function is there a folder at this location?

C:\Program Files\Steinberg\Cubase 8\VSTplugins

If yes, add it.

You really shouldn’t have any plugins in the vstsound folder…not sure how this ended up in your list…unless you installed 3rd party stuff there by mistake and then pointed to it rather than re-installing to the correct folder.
You could probably delete this one…but have a look at it and see if any plugs or if it’s just the content.

Yes, this folder contains certain VST2 effects (though not all VST2 versions of the VST3 ones) but not any VST instruments

Ahh…would help if I read the question properly.

So the answer is very simple. There are no VST2 instruments in Cubase 8 so of course none show up.

Are you trying to load older projects that had specific VST2 instruments?

…yes

So are only certain VST fx only VST2 too? … the rest VST3?

I believe there are some older instruments available to download if you need backwards compatibility…or maybe you have them still on your system from an earlier version in another location?

Yes some older FX are VST2 only and some newer are VST3 only.
There are no FX with both VST2 and VST3 versions in the standard install (and no need for them as they are interchangeable)

I have The Grand 3, website indicates this supports VST2 and VST3 - but only the VST3 shows up in Cubase… http://www.steinberg.net/en/products/vst/thegrand3/specs_downloads.html

Same indicated for Dark Planet - VST2 or VST3… http://www.steinberg.net/en/products/vst/dark_planet/specs_downloads.html

:question:

Ahh…so we’re not talking aboput included instruments.

At risk of repeating myself…did you check in plugin manager…are they in the list on the left or not?

Are you absolutely sure you installed both versions…you may have had the option to choose one or the other.
If you definitely installed then find the dll files on your drive and add a path to them in PIM.

NB: for backwards compatibility it really shouldn’t matter…the vst3 version would just open in place of the vst2 anyhow.

Originally, I was referring to all the Steinberg ones. But it seems the ones that come with Cubase 8 and above only appear/come in VST3 form.

But now I’m particularly talking about The Grand and Dark Planet, which I have purchased separately. The web pages and product info for these specify that they are available in VST3 and VST2.4, but I have only been able to use the VST3 version in Cubase 8.

How do I use the VST2.4 version

Please read all of my last post and try what I suggested of answer the questions asked.