VSTAudioEngine constantly crashing

Thanks. I’m not sure what I can do with a 2GB .dmp file!

Have these problems been going on ever since you installed Dorico, or did they seem to start at some point afterwards?

It has been intermittent since installation - I’ve tried reinstalling including reinstalling NotePerformer, as well as disabling voicemeeter in case the audio routing was causing problems. Neither of these options seemed to help. It seems that once the VST audio engine loads successfully, I can edit away until I change the template in any meaningful way. I can’t understand why a new project won’t load sounds at all though.

Also, HALion Sonic will open separately from Dorico throughout these issues, and playback with no problem. Unfortunately there isn’t a similar step I can do to verify NotePerformer.

Are there any specific logs from the AppData folder that would be helpful?

This may not explain everything, but I think it will explain at least something! Go to the Play page of Preferences and make sure the slider for the default Mixer output level is set to a value higher than zero, then Apply and Close. Then re-apply your playback template, and hopefully you’ll find that you get sound in your troublesome projects. (If you open the Mixer, you’ll see that all the faders are pushed all the way down.)

Thank you - that has fixed Write mode, but not Play mode!

I hadn’t noticed that default option in preferences, so will make sure to keep it at 0db now. Good to know!

So the notes will now play if I click on them in write mode, but I still have no sound either in Play mode or by hitting play while in Write mode. Switching playback templates has a delay, but eventually either NotePerformer or HALion will show the same behaviour (notes in write are good, playback in either write/play still not working).

Here’s another diagnostic from the current state!
Dorico Diagnostics-AfterMixerFix.zip (875.0 KB)

When you try to play back, does the playhead move at all, or does it stay completely still? Do you see any output in the Mixer’s VU meters? What about in e.g. HALion’s VU meters?

Yes, the playhead moves, there is seemingly output from both the Mixer and the VST channels.

I wonder whether it’s possible that there is somehow a sample rate mismatch somewhere in your system? Can you triple-check the sample rates chosen in the Device Setup dialog in Dorico, in Voicemeeter, and in the Windows sound properties?

Thanks - checked and VM/Dorico are in sync at 48kHz, Windows sound properties were at 44.1kHz but changing this didn’t affect anything.


Noticing now that in the NotePerformer mixer, the white circle at the top of the channel is lighting up for input, but no levels on the fader.

There are levels on that fader when clicking on the note in write mode.

I’m a bit foxed, I’m afraid. I think we need my colleague @Ulf to weigh in, but he’s currently only sporadically checking the forum.

If you take Voicemeeter out of the equation temporarily, do you get any playback if you use either Dorico’s default Generic Low-Latency ASIO Driver?

Hi @ah309 ,

there are probably two issues here. First, you have the new HALion Sonic 7 with the new MediaBay4All which makes the audio engine hanging and waiting for a response from the MediaBayServer. In the diagnostics are two dump files that clearly show that. Have a look at this thread for a temporary workaround. Please try that and see if you still get this hanging of the audio engine.

In regards to no audio coming out, could you pleases try to export a project to Wave format (File > Export > Audio) and see how that goes?

And by the way, you have routed Dorico to stream to Voicemeeter, but where does Voicemeeter send its output to?

My sense is that unless one really needs HALion SE 7 (or whatever its official name is), it is wiser to wait to implement it. I expect that when “Dorico 5” comes out, the install package will include HALion SE 7, and by that time all the kinks with MediaBay Server will have been worked out in the Dorico 5 debugging & compatibility process.

Thank you for the tips @Ulf . This doesn’t seem to have resolved playback fully, though I do not see VSTAudioEngine crashing now (so progress!).

I loaded the following projects:

  • Previously working full orchestra project - loads and plays back ok
  • strings.dorico - previews notes in write mode, does not play in either write or play
  • solopiano.dorico - as above
  • created a new project for classical orchestra, behaves in the same way as strings/solopiano.dorico.
  • reloaded full orchestra project from point 1 - loads and plays back correctly

I have attached diagnostics for the newly created project, perhaps these can help? It seems to be an issue with newly created files at this point - swapping playback templates doesn’t change anything but the previewing of notes doesn’t crash which is good!

NewProjectDiagnostics.zip (1.3 MB)

Exporting to WAV did not work for the broken projects - simply an empty audio file.

Routing for Voicemeeter is:

Dorico → Voicemeeter Virtual ASIO VM-VAIO 1/VM-VAOI 2 → Voicemeeter VAIO (Desktop In) → Headphones

(Pictured is output levels from previewing a note in dorico, can see in VAOI In and Physical out A1)

Hi @ah309 , please open a non-sounding project and then open the Dorico Mixer window (F3). Is there any channel set to mute or solo state? Does the level meter of the master output channel flicker when you start the playback?

Confirmed that VSTAudioEngine is no longer crashing so marked the post above from @Ulf as the solution for that. Thanks again for the debugging session - seems I’m left with a NotePerformer expression map issue which I’ll hunt for a solution for, and post a new issue if I can’t get anywhere.

Very much appreciate the help!

1 Like

Found that importing NotePerformer expression maps manually fixes the playback problem, though this needs to be done on each new project - not sure why its missing but there’s a workaround at least!

NP Exp maps are at Program Files/NotePerformer/Dorico

1 Like