VSTi automatically selected on silenced staves


When I try to make a stave remain without sound, Dorico automatically assigns it a sound.

The NotePerformer playback template is selected. Then, I add other VST Instruments. One of the staves should not play, so I assign it the ‘–’ sound generator in Play.

If I make some changes with other assignments (adding instruments, assigning VSTis), the staff that was assigned the ‘–’ sound generator is automatically set to NotePerformer. I’ve not reselected the playback template.


I suspect Dorico can’t tell the difference between an instrument that has just been added and for which no sound has been loaded versus one for which you have explicitly unassigned a sound. Next time you add an instrument or player, it will assign any unassigned sounds, and that will cause that instrument to become reassigned.

It looks like sort of a horror vacui. Not finding a sound, it forces assignment of one.

I use staves with no sound assigned for guide materials (chord, series, snippets…). These are parallel building materials and tools that disappear in the final version, but are there during development.

A workaround is to assign them the “Suppress playback” option.