VSTi Display in Mac

The display for VSTi’s in Mac first shows a thumbnail and then when you click on the thumbnail the plug-in is displayed in a “lightbox” window. This doesn’t seem to work very well. For example, the drop downs in MOTU Ethno 2 will not work and the keyboard in EWQL Play will not produce any sound. I use Cubase both in Win and Mac and in Win Cubase displays the VSTi’s just like FX plug-ins and I do not have any problems. This problem happened in Cubase 6 and is still happening in 6.5. Is there any way to turn off the “lightbox” display in Mac?


Can you sena screenshot, please? I can’t imagine it. I have no problem on Mac. Maybye, try to delete preferences?


That happens when you use 32bit plug-ins in Cubase 64bit, it’s due to the VST bridge. Use 64bit versions of your plug-ins or use Cubase in 32 bit mode if there are no 64bit versions of your plug-ins (the latest EWQL Play version is already 64bit, MOTU plug-ins I don’t know). Alternatively you can use Vienna Ensemble Pro to host 32bit plug-ins outside of Cubase 64bit if you want to avoid the Cubase VST bridge.

Looks like you may be right. I’m running Cubase in 64-bit mode and I assumed PLAY 2.1.2 and Ethno 2.0.1 were 64-bit for Mac since they are for Windows. However, apparently both are still only 32-bit in Mac.