vsti instrument woulnt play on specific midi channel

This is driving me crazy

I have several vsti instruments and I am not able to select a specific midi channel for playing each instrument. (Live MIDI recording) All instruments play data from all 16 midi channels from the midi interface selected for that track no matter which interface I use. (MOTU Midi TimePeice AV, USB midi interface, Hammerfall)

I have tried adding the instrument in the vst instruments panel turning them on letting it create a midi track going to that instruments midi track and selecting the midi interface for the input and then selecting the midi channel I want to play the instrument with (ie ch 6) and the vst instrument plays midi from all 16 midi channels on the interface Instead of JUST the channel I have selected.

I must be able to have each vsti instrument play on a different incomming midi channel

PLeasde Help

Have you enabled the monitor button on the track? If I’m understanding you correctly, it will play back midi info but won’t let you play live?

Yes, monitor is on it is the only way to hear what I’m Playing

I don’t care about recording yet
Just getting my midi vsti instruments the live set up

all midi vsti instruments
bass ch2 (steinberg virtual bass)
piano ch3
organ channel 4
electric guitar ch 6 (realstrat)
acoustic ch 7 (real guitar2)
drums ch10 halion

need a seperate midi channel for each vsti instrument

So, you are sending several MIDI channels from the transmitting keyboard?
You need to activate a local Input Transformer on each MIDI track (the “crooked arrow” icon near the top right of the track’s Inspector). When the Input Transformer window opens, you can select an appropriate preset to PASS only the intended MIDI channel for that track.

I have tried to use the transformer

I must not be using it correctly

This is what I have done

I have opened transformer and selected “local” for the vsti instrument channel I want to pass only midi data on say channel 6 for (guitar)

this is what i have done…

my idea here is to pass only channel 6
I press “+” button
I set filter target to “channel”
I set condition to “equal”
I set parameter1 to “6” (to filter only channel 6)

I pressed “+” again
I set filter target to “Type is”
I set condition to “All Types” (for all midi data)

I then pressed “+” under action Target
I set operation to “Set to fixed value”
I set Parameter1 to “6” (to pass ch 6 midi)

I then click module 2 (this is how I try to block all other channels… actually i could not figure how to set it to block all other channels so i set parameter to 16 to shift all other channels to channel 16) ((this is what might be the problem))

pressed “+”
Filter Target = “channel”
Condition =“Unequal”
Parameter = “6”
pressed “+”
Filter Channel = “Type IS”
Condition = “all types” (for all data)

I have tried setting the bottom function to both transform and filter and I can not get either to work

What am I doing wrong??

How do I set this to only pass 1 channel and to block all other midi data???

It comes with presets to do so. And don´t forget to switch the modules on…

Yes I am sending multiple keyboard splits each assigned to a different midi channel as well as midi drums on yet another channel, and a midi guitar controller on yet another midi channel

DUH… I now see the presets at the top for filtering and have tried them and it still does not work

thanks for the info

No matter which midi channel I send data on the vsti instrument still plays even though the vsti track is set to channel 6 and the transformer is set to pass channel 6

what am i doing wrong?

As said already: Have you activated the transformer modules…?

Yes I have set the vst track midi channel to channel 6, set the transformer preset to “pass channel 6” and it still does not work

the vst instrument plays all 16 midi channels

I have used different midi interfaces and verified the midi data is only sending on the channels or rather other channels I am testing still the same thing

OK, simple question simple answer and I won´t do this all night long. Have you activated the transformer module…? Setting the preset does not activate the module. There is an on / off button per module. If you don´t know what I´m talking about - Open the manual and read…

If clicking the track transformer button selecting local or global and seeing it is lit, then yes I have activated it


No, that´s not it…

Ok I’m confused then the manual says the transformer module has no apply button “it is active when you activate the on/off button on a module” isn’t that the lighted button on the top right you press to turn on by setting to either local Or global then it lights up?

Where else can you turn it on?

Found it

It works

I could not find that in the manual though

Thanks very much

Strange, so where do you have that from…? :wink: