VSTi loses "focus" when I touch hardware MIDI contr mixer

Hi there,

whenever I play a VSTi in C4 and want to adjust a mixer setting (e.g. volume) via my hardware MIDI controller, the VSTi stops to play and pressing a key on my piano won’t result in any sound. Don’t get me wrong, C4 hasn’t crashed, it simply changed the focus from my VSTi to the mixer, thus not routing MIDI input from my piano to the VSTi.

I remember that there was a setting for this in C3 SX, but I can’t remember what it was exactly…

Can anybody pls help me with this? I am really stuck here and this is really annoying… :wink:


Make sure Release ASIO Driver in Background isn’t checked in Device Setup.

Thanks for your help, but that didn’t really fix my problem.

To clarify what happens:

  1. VSTi loaded in MIDI track, I can play the instrument via my MIDI keyboard
  2. I change volume of that track by moving the volume fader on my Mackie Control, Cubase switches focus to the volume track of the instrument, e.g. Battery. The volume track of Battery is highlighted in track view.
  3. Pressing a button on my MIDI keyboard doesn’t result in sound output, which seems logical, as the volume track of Battery is highlighted… To be able to play Battery on my MIDI keyboard the MIDI track should be highlighted…

There was a setting in C3 SX saying something like “Keep focused on the instrument while changing parameters” and it was found in the settings dialogue under “File”. I browsed like a dozen times through that settings window but didn’t find anything like that in C4.

Then it’s probably Record Enable Selected tracks or Solo Selected Tracks or the like in Prefs.