VU meters and mixer performance - glitchy


I’ve been struggling with this annoying little thing - whenever there is audio playing, the VU meters on each track is being refreshed at very low resolution and are perceived as glitchy and laggy. Tried lowering the resolution from 1440p to 1080p to no avail. There are no spikes in CPU/GPU/Hard Drive or RAM, everything is fine, no audio glitches or mishaps either (buffer size maxed out).

I’m running a good system (not the freshest out of the basket, but decent enough to run heavy projects without a hiccup) and trialing Studio One, everything runs smoothly there.

Any suggestions? Running the latest Cubase 9

Does it help if you go File > Preferences > Metering >
[1] set fallback rate to something high like 30 or 40 db/sec;
[2] set peak hold to something short like 500 or 1000 ms?

That seemed to improve the situation but the whole thing still feels a bit sluggish.
But thank you for the suggestion! It really improved the response time and definition of the meters!