Wacky playback issues

I had not used my Cubase 5 in several months. I recently opened it and loaded a project. The project worked perfectly the last time I had it open. But this time it had all kinds of playback issues. It started playing a beat early, not all the instruments played when they were supposed to, there were lots of staccato notes that were supposed to be sustained (and vice versa), just sounded crazy like it was possessed or something. I tried everything I could think of, checking midi settings and playback settings, checking Windows for any conflicts, etc. Looked all over the internet for someone having similar problems but couldn’t find.

Decided maybe it was finally time to start using 8.5 which I’d had for a while but never used. Opened 8.5 and tried loading the project and it surprisingly loaded up just fine. But when I tried playing the track, it did the same thing as with Cubase 5–really weird playback.

I figured the file itself must be corrupted and I’d just have to reconstruct the track, so closed out Cubase 8.5 and re-opened with a new project and started recording the piano part. When I played it back, it was doing the same thing–started a beat early, sustain not working properly, really weird.

I’m at my wits end. Any ideas what’s going on?