Waveab Pro 9 lags when pressing play

Hi

I´m experiencing a really annoying problem when using plugins as clip and track fx in a montage while mastering.

When there starts to be a few songs with plugins in use in the montage (as clip and track fx), Wavelab lags when pressing play. I can press play and have to wait a few seconds before it actually starts playing. Very frustrating! It´s like Wavelab has to think about something before it start to play. This never happens when there are no plugins.

The plugins I mainly use are:
DMG Limitless (VST3)
DMG Equilibrium (VST3)
DMG Essence (VST3)
Fabfilter Pro-L (VST3)



My setup is:

Mac Pro (Early 2009) 2 x 2,26ghz Quad Core,
OS 10.10.5
96 gb ram
pci SSD drive
Wavelab Pro 9

Converters:
Pro Tools HD Native Card (in the mac) - connected to
Burl Mothership

Wavelab uses Core Audio to access the HD Native card. (Usually set the buffer size to 256 or 512, and buffer number in Wavelab to around 27)

I guess that without plugins, you don’t have the problem. Try to bypass the plugins to maybe find one that causes trouble.

Thanks Phillippe

When using no plugins I don´t have the lag problem. It´s just when using quite a few plugins that this happens. I´ll try removing plugins to see which one is causing the issue

Hi Philippe

So I´ve tried a few things now. I have a montage (containing a mastered album with quite a few plugins). This montage is a perfect example of the lag when pressing play. It takes a few seconds before I hear any sound. (2-3 seconds. Really frustrating!)

So i tried this:

  • Just using the Mac Digital Outputs instead of my PT HD Native Card = same lagging

  • Replacing all VST3 plugins with their VST2 versions = same lagging

  • Remvoing all instances of DMG Essence = same lagging

  • Removing all instances of UAD Massive Passive / UAD Fairchild 670 = slightly less lagging

  • Removing all instances of DMG Equilibrium = even less lagging

  • Removing all instances of DMG Limitless = no lagging

So that´s basically removing all the plugins from the montage. I´ve tried removing just a few of them in different orders, but nothing stands out as being the offending plugin. The only thing I can see is that using plugins (no matter which one) is causing the lagging (like the mac has to calculate before going into play mode).

Why and what does Wavelab have to calculate before it starts playing?

I´ve tried both lowering and making higher the Buffer Number in Wavelab to no help. Same with the buffer size. Also too no help.

So basically it seems as though it lags just because it has to calculate having all these plugins going in the montage. Should it be doning this though?

One more thing: This effect is greatly worsened with higher sample rates. The montage mentioned above is at 96khz. In 44hz the lagging is a lot better, but not completely gone.

Please help

How many montage tracks are there? Are the clips staggered on the tracks, and all tracks unmuted? How many plugins are you using on the tracks, and how many on the clips?

Hi bob99

I´ve got just one Montage track, and 12 song on that track. I´ve got one final limiter as a track fx on that track (DMG Limitless). There’s roughly 3-4 plugins per song as clip fx. 12 songs. (Equilibrium, Essence, Massive Passive, Fairchild 670).

So there´s quite a few plugins.

This particular album I had to master totally itb because of how the mixes sounded. That’s why there’s a lot of plugins per song.

I totally love DMG plugs and use Equilibrium a great deal.

However, they can be very CPU hungry. especially dependent on how you have the plug configured (eg “highest quality in the solar system”). I can make my system grind to a halt with a few instances of highly configured DMG and a 24/96 file.

Maybe have a look at that?

Thanks for the reply:)

I´ve got all instances configured to FIR - Full Minumum. Also tried putting them all in IIR mode, but the lag stays the same.

I´ve got a Mac Pro (2009) 2x26gz Quad Core processor and 96gb of ram, so I think that should be more than enough to run some stereo mixes smoothly, no? :confused:

It sounds like we use many of the same plugins. If you want post the .mon file (no audio, just .mon) I can test it here to see what happens.

Sometimes I see a possibly related issue but I never see it on playback. I always get instant playback. Sometimes when I have montage with many plugins I will get a spinning beachball when I go to render. WaveLab needs to think extra long and then eventually after 3 to 5 seconds the rendering starts and all is normal.

The other place I see something interesting is with plugins on the clips or montage output FX is this:

Have a montage with lots of plugins/latency.

Have audio with a sharp cutoff at the end so there is no “dead air” before the end of the montage. This is important. There must be no marker at the end or if there is a marker, it should be right where the last audio clip ends so the montage won’t keep playing in a silent area.

Then if you play the end of the montage, in the final second of the clip, WaveLab freezes playback for a second or two and then finishes the last split second of audio.

It seems latency related as I can only reproduce when I use a lot of plugins with high latency totals.

Normally my plugin usage in WaveLab is minimal because I use REAPER w/plugins and analog gear for the first part of the mastering so by the time the audio gets to WaveLab it only needs a limiter on the montage output effects and maybe some simple EQ here and there on clips.

Anyway, if you post the .mon I’d be happy to test here to see if somehow that helps.

Hi Justin

Thanks for the reply! :slight_smile:

Here´s a link to download the .mon file. I was´t able to attach it here.

https://fil.email/MCW98com

I get a slight lag when pressing play, but it’s less than one second. I also don’t have the Sonoris Mastering Compressor and I never use external gear (I do it in REAPER) so that could be a factor.

My guess from seeing the montage and the global master section plugins as well is that the total latency is higher than WaveLab can handle or something along those lines. PG would know more.

If you remove the external gear does it get better?

Actually I´m not using any plugins or external gear in the master section, so that´s there by mistake. The master section should be totally empty on this project. I only use the external gear plugin if I master with my analog chain. On this particular album I had to master it 100% itb.

So the last plugin in the chain is the DMG Limitless on the Track FX

I see. For me, with the master section empty, the lag is just under one second. I can’t point to one single plugin but removing them one clip at a time slowly improves the lag.

The only one I can’t speak for is the Sonoris Mastering Comp but I have all the others.

I think between UAD and DMG, it’s just really high latency that maybe WaveLab can’t handle as smooth as it should. If you try that many of more simple plugins like Steinberg Studio EQ (I know it’s not great for mastering) of maybe even FabFilter Pro-Q 2, is it better? Just as a test.

Maybe it´s my processor that´s to slow? Your´s is a new processor. Mine is 2 x 2,26 ghz Quad Core Xeon,

Tried removing the Sonoris. Doesn’t change things much.

I´ll do a test with using loads of the built in wave lab eq´s

Yeah, there are a lot of variables but maybe it’s a combo of WaveLab and/or your processor not handling all the latency very well.

WaveLab does not make any time consuming operation when playback starts, but some plugin could.
Make sure that this check box is unchecked:

That still seems like a long time, doesn’t it? Any other programs to compare?

I always have this box unchecked👍

George, I just wondered does it start faster in Wavelab after the first play? On second and third play. That seems to be the case here with a large load of high process plugins. Also I wondered if you tried the same plugin chains in Reaper or another program. I don’t notice a big difference in Reaper on first play (still slow) with default settings, but I did notice there seemed no delay at all on first play if you select “disable media buffering for tracks that are selected” in the Reaper buffering preferences. Although it might be outputting a playback glitch that way, I’m not sure, but playback started immediately with a heavy load.