WaveLab 10.0.10 update available

Dear Forum members,

We are pleased to announce the availability of first maintenance update for WaveLab Pro and Elements and version 10.0.10.
This version includes several improvements as well as resolving over 50 issues in different areas of the application .

The update is available for download from the Steinberg website and via the Steinberg Download Assistant.

For detailed information, please read the corresponding version history on the download page.

All the best,

YEA Finally! Hope it too is not as buggy as WL10 the original…

looking forward to seeing if it makes 10 usable for me!

don’t see anything in the change log about the accidental auto-saving of audio files when applying plug ins to a file edited from a montage… that’s the big one for me.

Thanks for this … I installed that last night (my time) and it feelz soooo much more solid.

So much better.

Agree! Feels much more solid and stable.

Thanks

George

Now WL 10 refuses to open. (PC Windows 10) no problem with WL 9.5.5. Ideas???

It may be that you need to re-sync your dongle through eLicenser Control … meaning the app is looking for a WL 10 license and can’'t ‘see’ it due to an update/glitch.

If that doesn’t address the issue … when you say ‘refuses to open’ … do you see a ‘This App Can’t Open’ screen … or do you get to the WL splash screen which then disappears or hangs … or does nothing happen at all?

Will it run as administrator (suggesting a security/permissions issue)?

If you cntrl+alt+delete . task manager … is what’s running what you expect to be running?

I will check all those things. Thanks for the suggestions, really appreciate your time.

Audio analysis still doesn’t work as expected :frowning: . When I try to do an analysis by using the “Selected audio” option, it seems to make the analysis, but I get blank FFT and Spectro Scope readings. This make the program still useless for me, I’ll have to use 9.5 instead. This in very annoying.

Audio analysis still doesn’t work as expected > :frowning: > . When I try to do an analysis by using the “Selected audio” option, it seems to make the analysis, but I get blank FFT and Spectro Scope readings

This works perfect here in 10.0.10. Please verify in the about box, that 10.0.10 was really applied.
Else, do you have special settings for the FFT meter. Try with the default settings, as a start.

Philippe

I love CuBase and Steinberg…but really feeling a tad disappointed that the updates to Wavlab Elements 10.10 continually crash on opening. I t is definitely the 10.0.10 update…I managed to check that. It opens for a few seconds than crashes. I know there is a whole debate around is wavLab useful anymore…and since this problem (which began with me paying for the update) I have been mastering in CuBase 10.5 Pro.

Its annoying forking out for something and it not working…even if it wasn’t a lot to fork! It’s the principle. I have looked at forums, and see it has happened to others…I have re downloaded and reinstalled…I wondered if it was Wave plugin related and can’t seem to get into where to look.

Certainly don’t have me wanting Wavlab Pro…and maybe some other mastering software won’t do this. Exporting from mix down in Cubase has the same effect.

Can someone help me before I dump it all together…I was on a journey using it to master for SoundCloud uploads…

Apple error report below.

Opps its too many words for this post…bugga. will see if I can just include system data…to answer all that stuff people may ask…Cubase 10 pro runs totally fine…

Some help would be so appreciated. System info and other shite at the bottom of file.

Process: WaveLab Elements 10.0 [1502]
Path: /Applications/WaveLab Elements 10.0.app/Contents/MacOS/WaveLab Elements 10.0
Identifier: net.steinberg.WaveLab-Elements-10-0
Version: 10.0.10.49 (10.0.10.49)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: WaveLab Elements 10.0 [1502]
User ID: 502

Date/Time: 2019-12-16 10:52:13.960 +1300
OS Version: Mac OS X 10.14.6 (18G103)
Report Version: 12
Anonymous UUID: 81C6D099-F7AD-05D3-B96C-BFDCA2CBBD85


Time Awake Since Boot: 3700 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [1502]

VM Regions Near 0:
–>
__TEXT 0000000109c51000-000000010c5c3000 [ 41.4M] r-x/rwx SM=COW /Applications/WaveLab Elements 10.0.app/Contents/MacOS/WaveLab Elements 10.0

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 com.WavesAudio.WaveShell5-VST3.10.0.62 0x00000001690fa829 WCPluginGraphicaGS::ResizePluginView() + 691
1 com.WavesAudio.WaveShell5-VST3.10.0.62 0x00000001690fa436 WCPluginGraphicaGS::BeforeDraw() + 186
2 com.WavesAudio.WaveShell5-VST3.10.0.62 0x00000001690fb5ff WCPluginGraphicaGSOpenGL::BeforeDraw() + 19
3 com.WavesAudio.WaveShell5-VST3.10.0.62 0x00000001690fa32d WCPluginGraphicaGS::Draw() + 21
4 com.WavesAudio.WaveShell5-VST3.10.0.62 0x00000001690f99f8 WCPluginGraphicaGS::DrawCallback(void*) + 18
5 com.apple.AppKit 0x00007fff34b8eec2 -[_NSOpenGLViewBackingLayer display] + 901
6 com.apple.QuartzCore 0x00007fff418d3551 CA::Layer::display_if_needed(CA::Transaction*) + 627
7 com.apple.QuartzCore 0x00007fff418c17c6 CA::Context::commit_transaction(CA::Transaction*) + 342
8 com.apple.QuartzCore 0x00007fff418c0ea6 CA::Transaction::commit() + 596
9 com.apple.AppKit 0x00007fff348d327a -[_NSOrderOutAnimationProxyWindow initWithSnapshotOfWindow:] + 50
10 com.apple.AppKit 0x00007fff34734841 -[_NSWindowTransformAnimation initWithWindow:type:interruptingAnimation:] + 736
11 com.apple.AppKit 0x00007fff34734548 +[_NSWindowTransformAnimation windowTransformAnimationWithWindow:type:interruptingAnimation:] + 59
12 com.apple.AppKit 0x00007fff3459f65b -[NSWindow _doOrderWindow:relativeTo:findKey:forCounter:force:isModal:] + 597
13 com.apple.AppKit 0x00007fff3459f3a5 -[NSWindow orderWindow:relativeTo:] + 152
14 libqcocoa.dylib 0x0000000111619c3e QCocoaWindow::setVisible(bool) + 1710
15 org.qt-project.QtGui 0x000000010e4965e1 QWindowPrivate::setVisible(bool) + 1505
16 org.qt-project.QtWidgets 0x000000010dca23ed QWidgetPrivate::hide_sys() + 205
17 org.qt-project.QtWidgets 0x000000010dcb5d49 QWidgetPrivate::hide_helper() + 153
18 org.qt-project.QtWidgets 0x000000010dcb5685 QWidgetPrivate::setVisible(bool) + 533
19 net.steinberg.WaveLab-Elements-10-0 0x000000010aebb388 0x109c51000 + 19309448
20 net.steinberg.WaveLab-Elements-10-0 0x000000010aee44cc 0x109c51000 + 19477708
21 org.qt-project.QtCore 0x000000010d6df08b QMetaObject::activate(QObject*, int, int, void**) + 3739
22 libqtx.dylib 0x000000010cfc8927 TPresetBox::LoadPresetAndSignal(TFileName const&, bool, TAbstractPreset::EType, TFlags) + 503
23 net.steinberg.WaveLab-Elements-10-0 0x000000010aee5397 0x109c51000 + 19481495
24 org.qt-project.QtCore 0x000000010d6dcd2a QObject::event(QEvent*) + 426
25 org.qt-project.QtWidgets 0x000000010dcb366a QWidget::event(QEvent*) + 4810
26 org.qt-project.QtWidgets 0x000000010dd65f9f QAbstractScrollArea::event(QEvent*) + 1007
27 org.qt-project.QtWidgets 0x000000010dc79bc4 QApplicationPrivate::notify_helper(QObject*, QEvent*) + 324
28 org.qt-project.QtWidgets 0x000000010dc765db QApplication::notify(QObject*, QEvent*) + 587
29 libqtx.dylib 0x000000010cdbd67c TGuiApplication::notify(QObject*, QEvent*) + 3692
30 net.steinberg.WaveLab-Elements-10-0 0x000000010ac038cb 0x109c51000 + 16459979
31 org.qt-project.QtCore 0x000000010d6adecc QCoreApplication::notifyInternal2(QObject*, QEvent*) + 188
32 org.qt-project.QtCore 0x000000010d6ae8b5 QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) + 1189
33 libqcocoa.dylib 0x0000000111639489 QCocoaEventDispatcherPrivate::processPostedEvents() + 313
34 libqcocoa.dylib 0x0000000111639a7b QCocoaEventDispatcherPrivate::postedEventsSourceCallback(void*) + 43
35 com.apple.CoreFoundation 0x00007fff36e73de3 CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION + 17
36 com.apple.CoreFoundation 0x00007fff36e73d89 __CFRunLoopDoSource0 + 108
37 com.apple.CoreFoundation 0x00007fff36e5774b __CFRunLoopDoSources0 + 195
38 com.apple.CoreFoundation 0x00007fff36e56d15 __CFRunLoopRun + 1189
39 com.apple.CoreFoundation 0x00007fff36e5661e CFRunLoopRunSpecific + 455
40 com.apple.HIToolbox 0x00007fff360b51ab RunCurrentEventLoopInMode + 292
41 com.apple.HIToolbox 0x00007fff360b4ded ReceiveNextEventCommon + 355
42 com.apple.HIToolbox 0x00007fff360b4c76 _BlockUntilNextEventMatchingListInModeWithFilter + 64
43 com.apple.AppKit 0x00007fff3444d77d _DPSNextEvent + 1135
44 com.apple.AppKit 0x00007fff3444c46b -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1361
45 com.apple.AppKit 0x00007fff34446588 -[NSApplication run] + 699
46 libqcocoa.dylib 0x00000001116387a0 QCocoaEventDispatcher::processEvents(QFlagsQEventLoop::ProcessEventsFlag) + 2656
47 org.qt-project.QtCore 0x000000010d6a5e7e QEventLoop::exec(QFlagsQEventLoop::ProcessEventsFlag) + 462
48 org.qt-project.QtCore 0x000000010d6ae232 QCoreApplication::exec() + 130
49 net.steinberg.WaveLab-Elements-10-0 0x000000010abf8c8d 0x109c51000 + 16415885
50 net.steinberg.WaveLab-Elements-10-0 0x000000010b4a7207 0x109c51000 + 25518599
51 libdyld.dylib 0x00007fff62dad3d5 start + 1

Thread 1:
0 libsystem_pthread.dylib 0x00007fff62fa03f0 start_wqthread + 0

Thread 2:: com.apple.CFSocket.private
0 libsystem_kernel.dylib 0x00007fff62ee961a __select + 10
1 com.apple.CoreFoundation 0x00007fff36e852d2 __CFSocketManager + 635
2 libsystem_pthread.dylib 0x00007fff62fa12eb _pthread_body + 126
3 libsystem_pthread.dylib 0x00007fff62fa4249 _pthread_start + 66
4 libsystem_pthread.dylib 0x00007fff62fa040d thread_start + 13

Thread 3:: MeterProcessThread
0 libsystem_kernel.dylib 0x00007fff62ee586a __psynch_cvwait + 10
1 libsystem_pthread.dylib 0x00007fff62fa456e _pthread_cond_wait + 722
2 libc++.1.dylib 0x00007fff5ffdfa0a std::__1::condition_variable::wait(std::__1::unique_lockstd::__1::mutex&) + 18
3 libcommon.dylib 0x000000010ca61acb TWaitableEvent::waitForTrue() + 59
4 net.steinberg.WaveLab-Elements-10-0 0x000000010af46928 0x109c51000 + 19880232
5 libcommon.dylib 0x000000010ca5d287 TThread::run() + 23
6 org.qt-project.QtCore 0x000000010d48bfd0 QThreadPrivate::start(void*) + 496
7 libsystem_pthread.dylib 0x00007fff62fa12eb _pthread_body + 126
8 libsystem_pthread.dylib 0x00007fff62fa4249 _pthread_start + 66
9 libsystem_pthread.dylib 0x00007fff62fa040d thread_start + 13


Latest Mojave

Hardware Overview:

Model Name: iMac
Model Identifier: iMac17,1
Processor Name: Intel Core i5
Processor Speed: 3.2 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 32 GB
Boot ROM Version: 170.0.0.0.0
SMC Version (system): 2.33f10

thanks

graham

This same issue in Mac had been driving me nits…while not a heavy user it was part of my workflow for mastering and uploading to SoundCloud. Just reinstalled 9.5 and works fine . Had done everything I could after paying for the 10.0.5 update and continual crashing on opening. Hate paying for something and it not working…and the answer not being there.

There is something about WL 10 that is buggy. Maybe some bit of code that was changed from 9.5.5 (which works perfectly). I know WL is complex and there are many things that have been changed from 9.5.5 but I just need it to work on a day to day basis so I can get some work done. I have been using WL since version 1.6.2 and except for WL 7 and 8 which, IMHO, were disasters WL has been a stellar DAW. My favorite version has always been WL6. Hopefully this is just a bump in the road and soon it will be back to being the best DAW for mastering on the planet. YEA PG!!!

crashing on opening

Try erasing this file:
/Users/YourName/Library/Preferences/WaveLab Pro 10.0/Preferences/General.dat

Sometimes when switching plugins on and off WL10.0.10 loses audio and hitting play does nothing, a restart is required.
Anyone else experience this odd behaviour?

Same thing noticed here. Just another “bug” in a long list of bugs…

Still unusable in my studio. When using UAD plugins, the processing time is 3-4 times as long as when rendering this exact effects chain in WL8. Please fix this so WL10 is actually an improvement, or at least works as well as a previous version released 7 years ago.

UAD rendering time will be back to “normal” in next update, but I don’t think the speed regression was as much as you quote.

Effects chain rendering for a particular montage in WL10 pro is 10:50
The same exact effects chain rendering duplicate montage in WL8 1:26 … actually I was conservative and it’s even worse than I quoted.

This is not a subtle issue as you suggest, it’s a time wasting deal-breaker on this being usable in a professional studio.