WaveLab 11 Elements Temperamental Audio Driver

Hello All,
I am still relatively new to WaveLab Elements 11.2 (coming from Audacity…quite the upgrade) and thus far I love it, with one huge gripe.

When I open WaveLab and begin editing a file, everything works as it should. If I close that file and open another, it does not play back. It exhibits the same behavior if WaveLab is not the window in focus, even for a moment (e.g., when I move over to file explorer). It puts out no sound and does not play back. Other than that everything works fine. This happens whether or not I have WaveLab set to release the driver or not.

I can usually fix it by going into the ‘audio connections’ tab and clicking the ‘refresh’ button; sometimes though, all audio devices will disappear from the audio connections tab, and I have to restart WaveLab.

The program is still usable but is extremely annoying. There are other things I have encountered such as the audio device and my file having different sample rates, but I managed to work around that. I am not sure if this is normal, but I am used to Audacity, where everything just works - set a output device and it plays. I know there isn’t much comparison between the two programs, but I just want things to work. It isn’t a dealbreaker but is a major annoyance.

I am running Windows 11 on an XPS 13 9310 2-in-1 if that helps. Any input/advice much appreciated…still learning the ropes.

God bless,

What audio device are you using?

I am plugging into the headphone jack of my computer, which uses Realtek drivers. Everything is up to date.

Which audio driver do you select in WaveLab ?

The device called “Realtek ASIO”. It is the only device that WaveLab sees (I also have a virtual device that it sees, but that is not relevant… I had the problem before I created/installed it).

Try asio4all which is freely downloadable as your asio driver. I would always recommend against using onboard sound for professional audio as it’s not really designed for it. That is why asio4all is widely used.

1 Like

I think this is a poor quality driver. Use instead the Generic Low Latency Driver, found in the list.

I will try that… thank you for the suggestion.

There is no option for a Generic Low Latency Driver.

There must be, in the same menu where you selected the ASIO driver.
If you don’t see it, reinstall WaveLab and reboot your machine.

1 Like

Reinstalled WaveLab, and now it sees the Generic driver, which fixed the initial problem, but now I have to use the resampler plugin to set the sample rate to 48000. There is an option in the driver settings to set a preferred sample rate, (which is set to 48000). Is there any way to get around this? It would be nice to be able to work with the original sample rate when editing a file.

Currently, the only way to achieve this is by using an audio device equipped with an ASIO driver that supports the feature. Most audio drivers can handle it, but for some reason, Realtek, despite being a major company, does not provide one.

When I select the Realtek drivers in WaveLab, I can play back at any sample rate natively with no issues. None of the other drivers (Generic or ASIO4All) seem to support that feature. Why would it do this?

I think the Realtek audio driver is sample rate convert in real time
and the other driver Generic or ASIO is more depend on the hardware
and need support with software (sample rate convert) with WaveLab or other DAW’s audio quality is the main thing to have control over, correct me if I’m wrong here…

regards S-EH

Ah, that makes sense. I am planning on getting an external interface at some point (and upgrading my setup in general), so I won’t have to deal with the Realtek drivers, but it works for now, as I am still quite new to these things…

Thank you for the help.