WaveLab 11 issue: record button ineffective after selecting a new recording preset


  1. Start WaveLab 11
  2. Click the record button in the Audio Editor
  3. Select any recording preset other that the current one
  4. Click record in the Recording dialog – nothing happens other that a graphics flash
  5. Close the Recording dialog
  6. Click the record button again (notice the input bus has changed to your first audio input bus)
  7. Select the preset you wanted originally and the correct input bus – now you can record.

Windows or Mac? What is your preset contain? There are 2 kinds of presets: file format only, of global. Which one do you mean?
A quick test here, don’t show any problem.

Windows 10

In the Recording dialog, it has only “Auto-Stop…” set and value Duration 48 mn (in this example the preset is called “C90 archival”:
As soon as I select any other preset, the Record button no longer works. If I just close the dialog and re-open it, the Input has changed to the first named port, but now the Record button will work:
I have to manually change the Input though …
This might be related to the new port-naming facility. I have both WL10 and WL11 installed, so the buss names were migrated, but I then set up the port names in WL11.

Just to make sure we speak about the same thing… Do you mean this button?

No, the Record button
WaveLab 11 does not enter record mode if I have changed the recording preset. I have to close and re-open the Recording dialog and reselect the correct input. The presets I speak about are the ones stored in “.[…]\AppData\Roaming\Steinberg\WaveLab Pro 11\Presets\Recording”. It’s as if, when one is changed, it doesn’t set the actual input correctly.

I have found a workaround: all my Recording presets needed to be re-saved in WaveLab 11 because they were migrated from WaveLab 10, where the port names didn’t yet exist.

As an aside, shouldn’t these presets ideally also store the input setting?