Wavelab 11 not behaving as if it can access appdata folder

It doesn’t look like Wavelab is able to write to my appdata folder (I’m on Windows 10). I’ve created a custom layout, then tried to save as default, but Wavelab still always opens with the original default layout. I’ve also noticed that after clicking the “organize presets” button under the workspace → layouts menu, when I click the “don’t show again” box, it still shows the next time. Seems to me like Wavelab can’t write to that folder properly. Any ideas?

Edit: hmmm this isn’t entirely accurate. If I view Appdata/Roaming/Steinberg/Wavelab Pro 11/Preferences, I can see that the general.dat has been updated today. Also under preset/windowlayout4, the .Default file has also been modified today. And yet, Wavelab still isn’t remembering to make my custom layout the default, and still isn’t remembering when I check the “don’t show me this next time” boxes. Any ideas?

Do you really have this option checked?

Yes, I have that option checked. I don’t know if it’s relevant, but earlier I’d been having some laggy graphics issues (meters not working etc) after upgrading to v11, so I’d deleted the contents of my preferences folder and let Wavelab rebuild it, which solved the issue. But I’m wondering if something else also went wrong during the upgrade, prior to the upgrade it was behaving normally.

Are you sure you are calling the right function? The red arrow, not the orange one.


Yes. Here is what I attempted…

  1. I created my own layout and save it as TW Default. I then open Wavelab, which is showing the Default layout, and select TW Default layout

  2. I then click “Save Current Layout as Default”, close Wavelab, then reopen it to see if it now opens with the TW Default layout.

No matter what I do, it still always opens with the default layout. When I do click the button you pointed to “Restore Current Layout”, it DOES change the layout to TW Default, but it won’t do that by itself upon program launch for some reason.

Edit: I guess this means that Wavelab CAN write to the appdata folder, but for some reason it’s not reading from there properly? The other issue, that it never remembers when I check the “Don’t Show Me This Again” boxes, still remains as well.

When quitting WaveLab, this file should always be updated:
\AppData\Roaming\Steinberg\WaveLab Pro 11\Presets\WindowLayout4.last
Can you check if that really happens?

Well, this is interesting! First, just to make sure, here is the way the files are set up. There is a WindowLayout4 folder, inside of which is a “last” file… You can see that an old file is currently there.

So… When I exit Wavelab, I can see that file get modified in File Explorer, the modified date and time update to the current date and time. BUT, as soon as I open Wavelab again, it replaces that “.last” file with one that has a modified date of 08/08/22.

Weird! I don’t think WaveLab updates that file when running. Do you have some kind of backup/restore application running in the background?
Try to erase the “last” file while WaveLab is not running.

Interesting. I can delete the file just fine, even empty the recycle bin and have it gone for good. The second I start Wavelab, the file with the older date reappears in that folder.

I do have a couple of backups that are normally running, but they have no active restore function, that’s on demand only. Also, neither disk is connected at the moment. I also exited both backup programs, just in case. When Wavelab is open, I can see it overwriting the Default file (when I click “save as default”) and Last file (when I exit) in the WindowLayout4 folder. But the second I reopen Wavelab, both files are replaced with the older ones. I have no idea where Wavelab is even pulling them from. It’s behaving as if it doesn’t see these files and is trying to rebuild them, even though they were there.

I have checked WaveLab again, and this “last” file is only written when quitting. It must be some other process on your computer that causes this.
Try to see the file read-only for a while to see what happens…

Note, both the Default and the Last file are both being changed when Wavelab opens.

Is it impossible that Wavelab is trying to rebuild the correct file hierarchy on program start? I know that when I deleted the Preferences, it rebuilt that section on program start. I thought maybe this was similar behavior, but in this case it’s happening when it’s not supposed to and overwriting good data.

As for your suggestion, yes, if I make both the Default and Last files read only, they will not be modified on program start. The curious behavior is this… I opened Wavelab, selected my custom layout, saved it as Default so that it overwrote the Default file, then I made it read only. Theoretically this should make it so that it can’t overwrite the default and should open with my custom theme. However, when opening Wavelab, it still opens with the Wavelab default layout.

Also worth noting, the “do not remind me again” buttons are also not retaining their state, which indicated a more widespread problem that wouldn’t be fixed by making the Default and Last files read only, which doesn’t appear to be working anyways.

If this can’t be solved, is there a way I can nuke everything and start over? Clearly something has gone wrong with the upgrade. There is zero chance that it is a file backup issue, because none are currently running, and the files are only overwritten when Wavelab starts.

While not running WaveLab:

You could try to erase these 2 preference files:
\AppData\Roaming\Steinberg\WaveLab Pro 11\Preferences\General.dat
\AppData\Roaming\Steinberg\WaveLab Pro 11\Cache\lru.txt

and this folder:
\AppData\Roaming\Steinberg\WaveLab Pro 11\Cache\Window Config\

This will reset some preferences but will preserve all your preset.

Sorry, I didn’t get a notification that you had replied! For some reason the forum stopped sending me email notifications…

So I tried deleting all of these items, and the same weird behavior persists. For example, when I look at the General.dat file, right now it’s modified date and time are 08/29/2020 10:11 am. But as soon as I open Wavelab, it is replaced with a General.dat file with a date and time of 08/08/2022 2:00 PM. Let me see if I can figure out a way to share a video of this behavior…

It doesn’t seem like there’s any way for me to share a video unfortunately

I’ve increased your trust level. You should be able to post it now.

Thanks! Here goes… (no audio, video only)

This is the same behavior that is happening with every file that we’ve been discussing. It’s like Wavelab thinks they don’t exist, even though they do, and it rebuilds the files, overwriting my existing files with the default ones created on the day I upgraded.

The only thing I can imagine: you have set some setting auto-synchro. See picture. Could it be that these fields are set to something?

AHA! Yes, the sync at every launch button was checked! That would explain why it kept overwriting the files. I don’t even remember setting that up, but I must have messed with it at some point. Thanks for the help, I’m not sure I would have ever noticed that myself! After unchecking that box, everything seems to be working normally now. Thanks again!