WAVELAB 11 on WINDOWS 10 CRASH/freeze ON Launch

I’m currently using wavelab pro 10, on windows 10, so I downloaded 11 full version to try it out before I upgrade, when I launch , it asks to activate or start evaluate, when I choose start it just disappears and stays in the task manager , So I updated the windows 1909 to the requirements needed version, same issue, I also tried to press activate and put in fake numbers to see what would happen and it told me my elicenser is old, but I have the latest version, Kept rebooting and trying it opened eventually, but when I re-tried same issue, it gives me the amount of time left to evaluate, tries to load and disappears and stays idle in task manager, Bug ?

AFAIK, it’s not yet possible to evaluate WaveLab.

Oh wow, I didn’t know that, would that be the reason it would not launch ? It does count down the evaluation time every time it tries to open, and it has opened twice after re installing, but ends up doing the same eventually after it closes, but the evaluation time does get lower every time I try to launch, ,

Hi, you should get info from our support team soon. sorry for the circumstances.

Please create a support ticket with your issue. Thanks a lot. Meanwhile, please also try to update the elicenser version within Online Syncronization.

AFAIK, a trial version of any new Steinberg title is always only available a few weeks after launch?

Thanks everyone, I really appreciate it, I’m in Canada so I put in a ticket on the U.S side, and they directed me to Canada to this email steinberg@yamaha.ca, so hopefully it gets resolved, I also did update via online synchronization,


So Support mentioned there is no trial yet for wavelab as some of you had mentioned, and I must be running it off a temp 25 hour license that’s on my USB elicenser , and the product has only been out for 2 days so any issues would be on the forum first, and they are not seeing anyone else with this issue.I only wanted to know if this will happen if i purchase the update , so guess I can purchase it and hope for the best or wait it out and see, It takes about 10 times to open properly and have to kill the process in the task manager before retrying, Thanks everyone for your inputs, All previous versions of wavelab pro open or did open with no issues,

I’ve had a similar issue the past couple days where I open the app, and nothing happens. I check the task manager and it says the app is open and running, but it never opens. Have to “end task” and try to open it again. Eventually it opens, but clearly there’s an issue if other people are having the same problem. :eyes:

Good to know i’m not the only one, because they told me no one else had reported this issue,

1 Like

Hi, there could be a problem concerning the Elicenser usage period or the version. Please also ask Support for more help in that case. In the meantime please also update also the Maintanance Task in the Elicenser Center. Thank you!

Thanks Kay, my version seems to be up to date,(hopefully)
I ran all the maintenance clean up , update etc,
There is also a steinberg non movable remaining time of 12 min 5 seconds on it,
All support says is that Every key has an all applications 25-hour usage license on it to facilitate lost or broken elicenser while waiting on a replacement. and there is no trial available which I know but do not address the issue of the software not opening all the time because they have no other reports of this,