Wavelab 11 Pro breaks mounting of iso files in Windows 11

Exactly what the title says… you will get a dialog that looks like this…

2021-10-12_003518

Windows 11 does not want to load the driver shown unless you disable Memory Isolation (requires reboot) in Windows Security (which would be a little crazy). I found out it was Wavelab that was the culprit by installing the computer fresh and making incremental restore points. Uninstalling Wavelab cures the iso loading issue. Could one of you confirm this who has installed Wavelab on Windows 11 please?

I also tried the recent update…same thing btw…mounting iso’s broke.

:face_with_raised_eyebrow:

This is the driver installed by WaveLab to burn CDs.

1 Like

Windows 11 is not yet a supported OS for any Steinberg product (explicitly warned about here).

Yes, it is rather old and appears to have been recognised as such by Windows 11.

Thank you for your (somewhat unconstructive) reply. I know that they say that Windows 11 is unsupported at this point in time but therein lies the problem…

Windows 11 came out on October 5th and had been in beta a long long time before that. There has been plenty of time in other words. Now maybe you live your life by the sluggish Steinberg timetable (although they are quick to sell “new” plugins) …but I don’t…I can’t in fact. I have my older Windows 10 machines still but for compliance reasons must and have obtained new hardware that is able to host Windows 11.

Now that you understand that, you will of course be able to explain why if Steinberg is moving towards compatibility (albeit very slowly) that they would release a “new” Wavelab (11) that is patently incompatible with Windows 11 and then double down on the error by releasing a patch that perpetuates the error only 7 days ago. Once in the hole you start to dig right?

All I can say is they better fix it quick. I paid good money for ALL Steinberg software and to be unable to use it on the current operating system is completely unacceptable.

I ask again has anyone (user or at Steinberg) tried Wavelab 11 on Windows 11 and can they confirm that is breaks the mounting of iso’s because of that driver failing to load. An acknowledgement by someone at Steinberg would be sufficient for now…but not for much longer.

:call_me_hand:

Welcome to the software world
if you use PT then you have to wait 6-12 month
if updates to new OS, so I think relax a bit with Steinberg.

regards S-EH

1 Like

Why is it a problem that this driver is not loaded?

It hangs Windows 11 and prevents you mounting iso’s. If you delete the driver Windows 11 puts any amount of errors in Event Viewer saying it cannot find a corrupt or missing driver.

Windows 11 will only accept the driver if you wilfully compromise the Memory Integrity security of your computer. There are only two settings for Memory Integrity , on or off. You cannot make exceptions in there for specific drivers.’

You would not want to knowingly switch off Memory Integrity unless you are completely offline or unless you are a masochist with a fetish for self harm of your own computers.

The drivers’ (GEARAspiWDM.sys) days are numbered so why persisting with it even in the latest installer from just 7 days ago?

You cannot update the driver…the last version is from 2014. If you try to using the last Gear installer (which is the same driver anyway) you will prevent your computer from booting and the OS install will be toast unless you have backed up your Bitlocker keys (on by default in Windows 11) to gain access to your drive(s) and have a restore point to roll back to. Bear in mind that System Restore is off by default in Windows 11 so you will need to have remembered to switch it on.

:confused:

Is your hardware compatible with TPM 2.0? This is much recommended by Microsoft for Windows 11.
I might be wrong, but I don’t think you can disable Memory isolation if your computer has TPM 2.0.
Hence my question, since you mention you can disable memory isolation.

Yes my hardware is completely compliant with Windows 11 (11th gen i7 processor, 32GB RAM, TPM 2.0, 2 x 2TB SSD’s etc). You can disable Memory Integrity regardless of TPM 2.0 (but you would not want to). On Windows 11 you go to Windows Security->Device Security->Core Isolation->Memory Integrity and you can flip the switch to off (requires reboot).

This is going to turn out like the “replace Quicktime” saga from a few years ago if you remember. The difference however in this case is that this replacement needs to happen right now or the whole product will not work…

I must assume you read the compatibility info before buying? I’m pretty sure it does not mention Windows 11. So you spent your good money on a product that delivers what is promised.

I first bought Wavelab 6.5 LE iirc on the cover disc of Keys Magazine (Germany) and since then have upgraded through Elements to Pro and through every version up to 11…Wavelab is going to have big issues on Windows 11 unless someone does something about the issue above. It seems such a fundamental oversight that does not appear to be being addressed.

Not fact - only assumption. I think you worry too much :wink:

Can you burn a CD or make a DDP with WL11 in Win11? Did you try reinstalling the driver in compatibility mode?

If all of that is true, I agree that could be a disaster just waiting to happen, and think Steinberg should test it (try to update the driver, using default settings (With system restore off).

I’m sure many users will have Wavelab 11 installed and may go to update to Windows 11. If they have this driver problem, they might try to update the driver.

I doubt anyone who either relies or makes a living from Wavelab will have upgraded to Windows 11 until it is confirmed it is supported etc.

No harm in reporting issues with Windows 11 so @PG1 is aware, but a bit miffed by the surprise re issues with compatibility! :flushed:

2 Likes

Exactly … stability trumps all

1 Like

Hi there,
first of all thank you for the report. Beeing already said, the Wavelab product group has not been yet officially recommended for Windows 11.
However, please try following steps if it would help to solve the problem:

  • Try to re-install the Wavelab 11 version
  • Please give us if possible these steps you do did before for creating the ISO-Image in case of certain settings and also the ISO Image Software you are using.
    This would help us to reproduce the ISO-mounting problem.

Here, the issue by mounting an ISO-Image on a Windows 11 build 22000.258 in the Windows 11 file browser will not show that issue.

Thanx!
cheers
Kay

OK…so…I can load iso’s no problem before installing Wavelab… I am using the Windows ability to load an iso. There is no software being used except the OS in other words. I then install Wavelab Pro 11.0.10 from the current installer and I get this when I try to open an any iso (in this case its Office 2021)…

If you click on “Learn more”…you get taken here…

https://support.microsoft.com/en-us/windows/a-driver-can-t-load-on-this-device-8eea34e5-ff4b-16ec-870d-61a4a43b3dd5

If you wait a little while you get this…

So I uninstall Wavelab and then try to mount the iso again and everything works as it should as you can see here…

:confused:

Maybe the issue would go into that direction. https://helpcenter.steinberg.de/hc/en-us/articles/206632910-Windows-CD-DVD-drives-missing-after-uninstalling-or-updating-WaveLab

Please try check this procedure:

If installed, uninstall WaveLab. 
Open the Run dialog box by pressing the Windows logo key and R simultaneously. 
Enter the following string in the newly opened Run dialog box: regedit
Click OK or press Enter.
Navigate to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}
Double-click the entry "Upperfilters".
A new window opens showing values in separate lines. 
If existent, delete the line with the value ASAPI manually and click OK.
Restart your computer. 
The CD/DVD drive(s) should now be available again. 
If required, reinstall WaveLab.

My model of laptops (as do many other new ones) don’t have a CD/DVD/BluRay drive built in to them,.

https://support.hp.com/gb-en/document/c06961538

The registry key does not have that entry in it either…

I have an external USB DVD (HP dvd600s) that I can plug in if I need to. I get the same thing if I do plug it in anyway and there is no UpperFilter value to delete for that either when plugged in.

I have heard of the “UpperFilter” fix of before that can cure a inaccessible or faulty optical drive, however I don’t have one that is there to fix.

The one other bit of info I can give you is that these are clean installs of Windows 11 not upgrades from Windows 10. The same thing happens on the two identical machines.

:slightly_smiling_face: