Wavelab 11 Pro - M4A convert issue

Hello PG,
I think I found a bug on the converting algorithm.
I have a serious issue when converting WAV 16bit 44100Hz files to M4A AAC.
Wavelab adds a few samples at the beginning and the end of the converted M4A file.
It’s critical as I’m rendering several music “perfect” loop audio files that have to be integrated in a video game in M4A format and my Client has pointed out to me that issue. Can’t find a solution actually.
Looking forward to hearing from you asap please.
Pere

AAC is a quantized lossy file format, this means the file length is not quantized on samples, but on sample blocks. Hence what you see.
This is the same for MP3, but in this case, there is an option to compensate for this, if the decoder can handle it. See further.
Your client should consider another file format, such as WAV, flac, etc… or mp3, with these options:

image

Phillip, never had any issues when encoding to mp3, but now the issue is for real.
I cannot tell to the Client to change the audio file format the game is based on, only “because” my conversion fails.
I do understand the sample block concept but why this problem exactly occurs when converting considering the difference in added samples are quite high (several miliseconds actually) ?
What solution could you suggest please to be able to deliver what my Client requests ?
Thank you !
Pere

The issue is critical as these audios are perfect music loops and need to be played in loop.
The “click” is very audible and there’s obvious gaps in the looping point.

Is your client aware that audio loops are normally not possible with AAC?
If you really need AAC, then you need to use audio files quantized to 1024 (the total number of audio samples must be a multiple of 1024). Maybe also use timestrech. And you might need the loop tweaker.
There is a WaveLab function to help that.


1 Like

Thanks so much for the replies Phillip.
Kind regards,

Phillip, in the Range Selection, there’s not sample precision adjustment in the Round Down Lenght, but seconds and miliseconds. I’m on WL10. How should I proceed please ?

Also, it would help to have a view of the length of the file in samples, not in seconds and miliseconds. This way I could set an specific length in samples multiple of 1024. Any way to work in samples instead of time in the editor ?

Hi!

https://steinberg.help/wavelab_pro/v11/en/wavelab/topics/workspace_window/workspace_window_time_ruler_menu_r.html?hl=time%2Cline

https://steinberg.help/wavelab_pro/v11/en/wavelab/topics/workspace_window/workspace_window_time_ruler_and_level_ruler_c.html

Right click on “Time Ruler” in Audio Files Window or in Montage
select Samples
now you have samples in Range Selection

regards S-EH

Thanks so much S-EH !!

I can set that to samples and processed with the range selection to quantize the file to 1024 samples, but the m4a file keeps the same issues, a silence gap at the start of the file and at the end.

  • I did that in the source wav file, once converted to m4a, the resulting audio file has a different sample length than the source wav (that has been “quantized” to 1024 samples). Audible gap/click.
  • I did that in the converted m4a file. I rounded it to 1024 samples with the Range Selection option, and bounced again as a m4a file. The resulting file is not usable as a loop.
    Any other suggestions please ?

WaveLab is dependent on the Frauhoffer AAC encoder. WaveLab can’t control what’s going on in this encoder. I would suggest this; do your editing in WaveLab as you like, but in .wav format. Then convert to AAC with another encoder (another application) and see if you obtain better results for the AAC file.

Again, no such problem with mp3 here.

Thanks Phillipe, will try that… will get back to this post if that solution works.