Wavelab 12 issue

I need some help here. I just upgraded to wave lab 12. Once the install was done I opened it up located my folders and they won’t open up. I have all my audio files in folders. I double click on them and they don’t open at all. I have a MacBook Pro running wave lab. I have wave lab 11.2 and have no issues whatsoever. I uninstalled 12 because I don’t feel like messing with it right now and re-installed 11.2. 11.2 works fine and 12 doesn’t, so there an issue with 12, maybe a corrupt file or a setting. I did re-install 12 and it didn’t resolve the issue, so I have no clue.

What do you mean with that? WaveLab opens files, not folders.

My files are inside folders. To access them I have to open up the folder, which I can not do. I could take out all my files and just leave them on my desktop, but it’s hundreds of files, that’s why there in folders.

Even from the Mac Finder? If you can open the folder in the finder, then you can drag them into WaveLab.

Yeah, that’s another way, but in 11.2 I don’t have to do that. My folders are on my desktop and once I’m in Wavelab I scroll to my folders double click and they and have access to my audio files.

It sounds like you’re referring to macOS’s security features that require user authorization for applications to access certain folders and data. Here’s how you can allow WaveLab (any application) to access specific folders on a Mac:

(when WaveLab is not running)

  1. Open System Preferences:
  • Click on the Apple menu in the top-left corner of your screen.
  • Select “System Preferences.”
  1. Go to Security & Privacy:
  • In the System Preferences window, click on “Security & Privacy.”
  1. Unlock the Settings:
  • Click on the padlock icon in the bottom-left corner of the Security & Privacy window.
  • Enter your administrator password when prompted to unlock the settings.
  1. Navigate to the Privacy Tab:
  • At the top of the Security & Privacy window, click on the “Privacy” tab.
  1. Select the Appropriate Category:
  • On the left sidebar, select the category that corresponds to the type of access you need to grant. Common categories include:
    • “Files and Folders” for accessing specific folders.
    • “Full Disk Access” for more comprehensive access.
    • (…)
  1. Add WaveLab 12:
  • Click the “+” button below the list of apps in the right pane.
  • Navigate to the application (WaveLab) you want to grant access to, select it, and click “Open.”

Ok, I’m gonna try this. I’ll be right back

I adjusted the settings. Now I’m gonna re-install wave lab 12 to the list. Hopefully this works. I’ll be right back

Damn, it’s doesn’t allow to open up the folders to access my audio files. Am I the only one experiencing this issue. The only other fix is to wipe out my MacBook and start over. Something I’m trying to avoid

Is there any settings within Wavelab 12 that I can check

It’s working now. I don’t know what I did. The folders are now opening up and I can access my audio files and load them into wave lab.

Ok, so I figured it out. It’s my mouse. I have to triple click to open up the folders to gain access to my audio files. I was double clicking on the folders and nothing was happening. I tripled clicked on the folders and they opened right up. I have a razor mouse using third party software to get the scrolling smooth. Now I have to figure out how to reduce the number of times I click to open things up.

For the past 2 years this mouse thing has been driving me crazy. I resolved it. For those who don’t know about this. Click on apple logo and select system settings. Scroll down and click accessibility. On the list you see to the right, scroll down and select pointer control. Adjust the double click speed to 4th notch, issue solved. Mine was all the way up, and that’s why I was having issues opening things up.

1 Like