WaveLab 8.5.10 maintenance update available

Dear Forum users,

Steinberg is pleased to announce the availability of the WaveLab 8.5.10 maintenance update.
The update adds several improvements in areas such as plug-ins, user interface and audio montage.

The update and the WaveLab VersionHistory are available here: Steinberg WaveLab 8.5.10 download

More information on WaveLab 8.5 is available here: WaveLab 8.5 product pages

Fixes and improvements

Plug-Ins

  • • When used as a clip effect, the plug-in the Compressor plug-in no longer shows a transparent background.
    • The input of parameter values via a keyboard no longer leads to display issues.
    • Rendering certain VST 3 effects used within the Master Section now works as expected.
    • Opening RND Portico plug-ins without activated license no longer renders the program unstable.
    • The plug-in settings of the RND Portico plug-ins now remain persistent when reloading plug-ins.
    • The Crystal Resampler combined with Smart Bypass no longer causes stability issues.
    • A fast removal of effect plug-ins from the Master Section no longer renders the program unstable.
    • Collapse folders within the plug-in settings dialog (in case all folders are expanded) now works as expected.

User interface

  • • A graphical error within the Phasescope settings dialog no longer appears.
    • A graphical issue with certain program menus has been resolved (Windows only, OS Style only).
    • The main window no longer maximizes automatically when hovering certain program icons with the mouse.

Audio Montage

  • • When importing an AES31 file, a user template can now be used.
    • An undo command conducted via the history list now also removes the visible flag correctly.

CD-related functionality

  • • The audio CD report now shows correct entries for an Audio Montage used with 48 kHz.
    • Burning a basic audio CD no longer fails in case certain CD-creation options have been activated.

Other/Miscellaneous

  • • The maximum length in time for an audio file wrapped into a DDP file is now set to 99 minutes.
    • WaveLab can now be started from the Mac OS Dock even if the Watch Folders background process is active.
    • An incompatibility issue with the MP2 format has been resolved.
    • Saving Master section presets now works as expected.
    • Renaming of audio clips after auto-split now works as expected.
    • Converting one marker type into another now works as expected.
    • A stability issue with the FreeDB function “read track names” has been resolved.
    • The FreeDB submit dialog is now displayed correctly (Mac only).

More information can be found in the WaveLab 8.5 VersionHistory.

Thanks,
Timo

I asked the same question on KVRAudio, and I’d like to get some feedback on this from PG or whoever is in charge, since my last answer by the support was pretty much “we can’t fix it, not our fault but the fault by the 3rd party devs - bugger off!”.


Just to name those companies I encountered issues with.


Please take note of these following threads:
http://www.kvraudio.com/forum/viewtopic.php?f=7&t=415451
http://www.steinberg.net/forums/viewtopic.php?f=189&t=48712

And also please note my last support inquiry via mail from 27-06-2014.
Or the PM to Mr. Doll at 28-06-2014.



I’d like to know if the VST3 issues will be addressed in the (rumored to be final) WL8.04 update as well, or if we users are once again being forked over.

And I’d like to know if there is a chance to DEMO WL8.5 in a timely manner this time around. As much as I want the Fraunhofer ProCodec being bundled, I don’t want to waste money on this, and I do not agree with the pay-for-bugfixes route anymore.

A short public feedback on this would be nice.

Thanks.

PLUG-INS: Rendering certain VST 3 effects used within the Master Section now works as expected.

We fixed that bug for internal plug-ins which under rare circumstances showed a wrong behavior. Furthermore we had a closer look to some 3rd party plug-ins. Plug-ins of companies which do not have officially released VST3 versions (neither alpha nor beta) will not be analyzed (unless developers get in touch with us beforehand and provide the VST3 plug-in). Other manufacturers were instructed on how to follow the VST3 standard accurately and as a result make their plugins compatible to the WaveLab master section.

Loop find functions is fast as greased lightning now, thanks Philippe!

I get an installer error but the program seems to work anyway. I had the same problem with 8.5.
Here is the error report - for those who know what it means :slight_smile:
Problem Event Name: APPCRASH
Application Name: autorun.exe_Upload Manager
Application Version: 1.0.0.45
Application Timestamp: 4e303490
Fault Module Name: autorun.exe
Fault Module Version: 1.0.0.45
Fault Module Timestamp: 4e303490
Exception Code: c0000005
Exception Offset: 000fae9a
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1030
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Bug in Autosplit:

1 Open or create file with several generic markers

2 open auto split dialog, choose ‘split according to markers’

3 select ‘save as separate files’

4 select ‘As Audio File name (+ count, if necessary)’

Result: error message, auto split will not complete

‘The following file is already opened in Wavelab. You cannot save under that name, or you need to close the file in Wavelab (or the project referring to it). Then try again’

Works fine in v8

@patchen

I confirm this Auto Split issue. Please use “as Marker names” (and have different marker names) until this is fixed.

Thanks Philippe,

Will just us v8 for this function.

Problem with Wavelab 8.5.10

I´ve just bought Wavelab 8.5 for mac after having used an old Wavelab 4 for PC a long time ago. I have updated it with the maintenance update.

I am sorry to say I find quite some bugs in the program. I find a lot of trouble when using my Waves plugins like Renaissance Vox or the Maxx volume plug in that the whole behaviour of the mouse pointer gets sluggish, dissappears for a long time then gets hard to manouver. The Wavelab has also crashed a few times already.
It is definetly a powerful application, but suffers from a rather messy graphic interface where many symbols still seems a bit primitive and also appears on many different windows witch makes it difficult to know where you are. Personnally I would wish that it would be rewritten from scratch, simplyfied and streamlined to the workflow of mastering even more. Still, since Logic´s Waveburner has gone underground WL seems to be the only player on the market in it´s kind. (strangely enough, there ought to be place for some competition there.

The most urgent problem I find is with sluggish mouse pointer. Anyone please, advice on what to do?

yours Frans Mossberg
imac, OS 10.8.5, 8gb Ram, Avid mbox

What Waves version are you using?

I use Waves licence center V9.2.204. Waves version 9.1. / yours Frans Mossberg

It is recommended to run WaveLab in 64 bit. Is it what you do?

Where do I adjust or check that? /Frans

From what I find from my “about my mac” it seems I am on 64-bit. /Frans

From what I find from my “about my mac” it seems I am on 64-bit.

This is not what I am talking about.
Right click on the WaveLab icon, and choose “Get Info”. Then uncheck the option “32 bit”.

Hi again!
When I right click on the app icon on my desktop I just get the ordinary apple info with no such option. When I right click on the icon inside the program it says “wavelab 8.5.10 (build 857) - 32 bit” but I find no way to alter this condition. yours Frans

Sorry I just found it from inside the finder. Thanks ever so much. Hope this helps. / yours Frans

Seems to work now. Thank for quick and adequate response! In the best of worlds it will stop crashing too. Anyway thanks for a great piece of work. /Frans

The 8.5.2 update for OSX does not download in its entirety and is corrupt.