Wavelab 8 won't start - NewHeap.dll is missing..!?

I have suddenly run into the following problem.

Wavelab 8 won’t start on my Windows 7 machine - I get the following system error warning:

The program can’t start because NewHeap.dll is missing from your computer. Try reinstalling the program to fix this problem.

So I just reinstalled WL8, but still get the same warning - this is pretty frustrating, what can I do to fix it…?


Hmm, this a Windows error. Yet, NewHeap.dll is normally found there:
C:\Program Files (x86)\Steinberg\WaveLab 8
after WaveLab’s installation.

What have you changed recently? Did you try starting WaveLab directly from C:\Program Files (x86)\Steinberg\WaveLab 8\ ?

I recommend to do a Windows system restore from a recent point.

I see - thanks
I’ll try to make a restore and see what happens…


Hmm - lost my latest restore points. :unamused:
I’ll try to see what I have in my backups, later today, and report back.

I have found the NewHeap.dl filel in a recent backup. But simply can’t copy it into the C:\Program Files (x86)\Steinberg\WaveLab 8\ - it simply won’t copy

I reckon it’s some protection mechanism, that prevents this action, but I don’t know.!?

Any ideas on how to do it?


Ok Now I have restored the Wavelab 8 folder from a very recent Acronis backup.

But I still can’t start WL8 it says: The Application was unable to start correctly (0xc000906). Click OK to close the application.

What do I do now…?


Can you try the 64 bit version?

I can try the 64bit version yes, but only for trouble-shooting reasons. I have many 32bit plugins, so I’m not ready to switch.

BTW Wavelab 7 starts with no hiccups.

Wavelab 8 64 - just installed and it has no problems starting up.
After this I tried loading the 32 bit version again, but for some reason NewHeap.dll is gone again.

I wonder what’s going on - I have error checked the system and run a virus scan, but without finding anything suspicious. The system disk is a SSD


After this I tried loading the 32 bit version again, but for some reason NewHeap.dll is gone again.

Are you sure you don’t see NewHeap.dll in
C:\Program Files (x86)\Steinberg\WaveLab 8

Yes I am - I also tried to search for it on my system. The NewHeap.dll is only in the Wavelab 7 folder (32bit) and the new Wavelab 8 folder (64bit).

Should I try simply to copy the NewHeap.dll from the Wavelab 7 (or the one from WL8 64bit) folder and see what happens…?

I also wonder if it could be an idea to install in a new folder - if so how can I do this without loosing my preset settings?


The NewHeap.dll is installed for sure by WaveLab, in the place I told you. If you don’t see it, there is an installation problem. Maybe your copy of the installer is damaged? I recommend to make a disk check. Then erase manually the WaveLab 8 program folder. Then install again.
If this persist, install in another place.

Thanks Philippe

Did as you said and succeeded - Very nice to hear Wavelab play again!