Wavelab 9.1 kills my DVD drive

Wavelab 9.0 is all OK, but when I install 9.1 it kills my DVD drive (ATAPI iHAS124) with a corrupt registry error, I have to uninstall Wavelab, and reinstall V9.0,

I assume this is a bug in the 9.1 update,

any one with any ideas on this ?


Andy

WaveLab 9.1 does not change the driver registry set by WaveLab 9.0.

This is the error that Windows gives:-

“Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged” (Code 19)

The device manager shows a yellow triangle and if I try to update the driver, it just says the best one is already installed, yet uninstalling Wavelab 9.1 cures it,

does Wavelab 9.1 add/change the DVD driver ?

thanks - Andy

If you right click the DVD drive in Device Manager and select Properties - go to the Details tab - and then look for the property values in class upper filters and/or class lower filters, do those values change before and after you install Wavelab 9.1?

Like, my class upper filters value says GearASPIWDM.

I don’t have a class lower filters property for my drive.

I don’t really want to try 9.1 again, as it will mess the whole PC up, but at the moment (under a working Wavelab 9.0) the Class upper filters is GEARAspWDM,

which is not quite the same as what you mention (upper/lower case difference), I don’t suppose it is something silly like being case sensitive ?

Sorry, specifically with case, it says GEARAspiWDM here. I’m on Win 10 too. I have no problem with 9.1 and multiple DVD/CD drives.

Have you tried downloading the installer again? Try that and see if it’s the same size, etc. I guess it “can’t be wrong” and run maybe, or maybe it can, Downloading new is worth a try just to see if they’re the same size and checksum I guess.

The problem has to be uncommon or Steinberg would have heard about it by now.

I have downloaded three times now, and each time has the same problem, maybe this is a problem that affects my particular LIteON iHAS124 drive,

Maybe 9.1 is changing a driver that affects my particular drive,


If anyone else has this same drive and all is OK in Windows 10, then I really do have something odd with my system ! It is a new system, so it’s an uncluttered clean install.

otherwise I may have to stay with V9.0 …

Did you check the entries in the class upper/lower filters after doing the new 9.1 installs? Usually the fix for something like this is to delete those entries in the registry, but it would probably be helpful to know first if they change when you install 9.1.

This should fix the problem with the drive in Windows explorer and Device Manager:
https://support.microsoft.com/en-us/help/314060/your-cd-or-dvd-drive-is-not-recognized-by-windows-or-other-programs

However, if you delete the registry entries as in Method #5, you’ll additionally need to get GEAR back for Wavelab to use the drive. The easiest way to get GEAR back so the drive works in Wavelab is to use the method on this page (thanks RayThomas and Mljung):
http://ccm.net/forum/affich-77186-itunes-registry-settings-missing

The standard GEAR uninstall/repair/reinstall functions do not work to make the drive work with Wavelab after following the Microsoft method #5 (and they should !!!). GEAR’s only solution for this is to do a manual registry uninstall, which works, but is a HUGE pain, which nobody should be expected to do for something like this.

If anybody at Steinberg has the time to try this sequence of troubleshooting, starting with the Microsoft Method #5, and then trying to re-install Gear, you’ll see what I’m talking about. It simply doesn’t work. GEAR REALLY(!!) NEEDS to fix their uninstaller and/or installer to cover this. Or make a GEAR Removal Tool.

The above will probably fix the problem after the fact, but still doesn’t answer why it’s happening for this 9.1 install.

Thanks for looking into this, as there is a risk I might not get my DVD drive working again after a 9.1 update, I’m going to stick with V9.0, and hope that by the time V9.2 comes out, the killing the drive issue will be resolved in the installer.

I understand where you’re coming from, but if you’re the only one who’s having this problem, I wouldn’t count on anything changing if there’s nothing to go on. If I were you and a solution doesn’t show up here, I’d file a support request. Just my opinion.