WaveLab 9.5.15 update available

Dear Forum members,

We are pleased to announce the availability of the 9.5.15 update for WaveLab Pro 9.5 and WaveLab Elements 9.5.

This update significantly improves the GUI responsiveness and performance when using 4K and 5K retina displays in high resolution and provides fixes and improvements throughout several areas of the application.

The update is now available for download from the Steinberg website.

For detailed information, please read the corresponding version history on the download page.

Download WaveLab Pro 9.5.15
Download WaveLab Elements 9.5.15

All the best

wavelab pro 9.5 is crashing after splash screen on Maveriks OS, Cubase Pro 9.5 and wavelab 9.0 are working fine, do you think will be a fix for that?
Thanks

Maveriks OS

You need minimum OSX 10.11
https://www.steinberg.net/en/products/wavelab/resources.html

as well cubase pro 9.5 and wavelab 9.0 but they are working flawlessly :wink: maybe there is a fix for that, maybe we don´t know what is possible, I will wait for a official statement. thanks

This is an official statement: you need minimum OSX 10.11
And you can see it there:
https://www.steinberg.net/en/products/wavelab/resources.html

i sow, the same requirements for cubase 9.5 that is working perfectly on Maveriks.

i sow, the same requirements for cubase 9.5 that is working perfectly on Maveriks.

But for WaveLab, the requirement is real. This is not a bug.

ok, will stay with wavelab 9 for a year or two then, thanks. Maveriks is great here, my system is rock solid.

So this puppy wont install for me. I get to the update and it says “ddp player 1.0 is not installed” and thus neither ddp or Wavelab will update.

Any ideas on what I’m missing here?

thanks. :slight_smile:

ddp played installed or not, should not affect the possibility to update. What exactly happens?

Well I have Waveleb 9Pro , and it says 9.5 not installed. So I need 9.5 first I guess… DOE!!! I thought that didn’t matter?

You need a 9.5 license indeed.

Yeah, I was sure I qualified for a free upgrade from 9. But too late I misread that.

My mistake.

So I purchased wavelab 9.5 and I’m still getting the exact same errors. All my elicense software is up to date and and product activation as well.

Damn my MBP fans are going nuts with this new update - 40 % cpu usage from just scrolling the waveform :frowning:

Edit: the effect of not running fullscreen and making the zone with the waveform display smaller makes a huge difference. Guess waveform displaying is quite cpu intense.

Really using 9.5.15 ? Retina display are CPU hungry, but 9.5.15 is much better than <= 9.5.10.
What CPU?

Yeah it’s weird.
I actually find the cpu use --> fan noise a little worse in 9.5.15 compared to the previous versions which is weird since I find Cubase runs smoother now with the new graphics engine and I figured you shared that.

Scrolling the waveform when editing has always made my Macbook hot - also in Cubase.

This happens both when running Wavelab on my Macbook alone but also when running in closed clamshell mode through my 27" Apple tb monitor (non retina)

You can see it in the video here: http://tonekontrol.dk/temp/IMG_3706.MOV

otherwise a great release :slight_smile:

Cubase (and WaveLab 9.1) is not Retina compatible, compared to WaveLab 9.5. WaveLab has 4x more pixels to draw…