Wavelab cast can not upload file to host service

Hi guys, I am a brand new to wavelab cast.
I cannot upload files to host service like Spreaker and Podbean in wavelab cast.
I am using mac m2. Every time I am trying to authorize, it always shows errors " Podcast errorj json_error The document is empty. Offset 0" (this one shows twice )and “The authorized Spreaker account does not contain any podcasts. Before you can upload a podcast episode you must create a podcast on the [Spreaker](Unknown URL) website.”. Actually I already created podcast on spreaker and podbean. It still shows this.
Anyone got a same problem?


I am using Mac mini M2, Sonoma 14.4.1 .

Are you able to upload outside WaveLab ?

Yes, I’ve uploaded two files, one wav, one mp3, to both spreaker and podbean via microsoft new edge browser. The audio file was created by Wavelab cast.

I also tried this function in my other PC via the windows version wavelab cast, got the same error. So I think this may be a bug of wavelab cast.

Please help to check this one.

Hi, thank you for your question.
Please make sure that after creating and completed a new podcast setup first in Podbean or Spreaker, you hit first “Authorization” in the Publish field on Wavelab Cast and then you should also get a Podbean/ Spreaker own Publish site to hit also there “Publish” button. The same also should be done in Spreaker.